サポート » 使い方全般 » 特定のキャリアで全く表示できなくなる

  • 私の運営するWordpressサイトに対し、回線キャリアによって、表示されたり表示されなかったりという現象が発生してます。

    ブラウザやプロバイダには関係なく、あくまでキャリアによって結果が異なるというところまで切り分けています。

    <?php print”Hello” ?>のような簡単なスクリプトを、WordPressのドキュメントルートと同ディレクトリに置いてみましたが、こちらは問題なく表示されますので、PHPの不具合でもなさそうです。

    そもそも、問題のない回線経由でのアクセスでは、普通にサイトが表示されますので、DBのアクセスに失敗していると言った事も関係ないと考えています。

    プラグインも多数インストールしていますので、試しに全てをOFFにしても結果に違いはありませんでした。

    なお、以下の様な条件でテストしています。

    1. NTT西日本+Mopera (PCとAndroid端末) ⇒ OK
    2. Docomo+Mopera (PCとAndroid端末) ⇒ NG
    3. SoftBank (iPhone) ⇒ NG
    4. e-mobile(PC) ⇒ NG

    1.と2.を見て頂ければわかります通り、同じプロバイダを経由するにしても、回線キャリアによって結果が変わっています。

    NGの場合でも、サーバのアクセスログには以下の様に記録されていますので、サーバからレスポンスできない状況の様に思います。

    ### access.log###
    XXX.XXX.XXX.XXX XXX.XXX.jp – [19/May/2011:16:33:13 +0900] “GET / HTTP/1.1” 200 13866 “-” “Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1”

    また、TCPDUMPも取得してみましたが、F(コネクション開放要求)やR(コネクション強制切断要求)のステータスが表示されているのも気になります。

    参考までに、動作環境について記載致します。

    OS: CentOS 5.5 64bit
    Http: Lighttpd 1.4.26 + FastCGI
    PHP: 5.2.13
    MySQL: 5.1.44
    WordPress: 3.1.2
    Thema: TwentyTen(おそらく最新版)

    なお、他の方のWordPressのサイトは、NGの環境でも表示できているという事をお伝えさせて頂きます。

    以上に関しまして、NGとなる原因や、改善方法に関するアドバイスを頂きたく思います。
    宜しくお願いします。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • 昨晩原因の絞り込みを行いましたが、どうやらTwentyTen(1.0)のheader.phpの内容に問題があるようです。
    Ink and wash 1.1.5に変更しても、結果は変わらず表示されませんでしたので、WordPressで表示するheader.phpに共通して、キャリアによって受け付けないコードか何かがあるのだと思います。

    TwentyTenを表示できる環境で、ブラウザから取得したhtmlソースをサーバにアップロードし、
    これに対し接続のできない環境でアクセスをしたところ、やはり、接続はできません。
    bodyの中のどこかが引っ掛かっているというところまで切り分け出来ていますが、まだコレというところまでの切り分けはできていない状況です。

    また、知人のサーバにhtmlをアップしても、不具合が再現できています。

    2. と 3. と 4. において私のところでは特に問題は起きていません。

    TwentyTenはWordPress標準で、かつ、一番使われているテーマだと思われるので、上記の問題がTwentyTenにその原因があるのであれば、もっと騒がれていると思います。

    V.J.Catkick様

    ご回答ありがとうございます。
    再現しない環境もあるんですね。

    WordPressを一からインストールしたクリーンな状態ではどうかと思い、別の領域に再構築をしてみましたが、NGのネットワーク環境では、install.phpですら表示ができませんでした。

    全く持って不可解です。

    こんにちは

    Ink and wash 1.1.5に変更しても、結果は変わらず表示されませんでしたので、WordPressで表示するheader.phpに共通して、キャリアによって受け付けないコードか何かがあるのだと思います。

    link and wash から テーマのhomepageにアクセスしてみましたが、

    chrome

    エラー 324 (net::ERR_EMPTY_RESPONSE): サーバーはデータを送信せずに接続を切断しました。

    となるようです

    他の、メジャーなテーマでも試してみてはどうでしょうか?

    nobita様

    ご回答ありがとうございます。
    テーマ「zBench 1.2.」でも再現しました。
    はじめテーマを疑っていましたが、WordPress3.1.2も疑ってみたいと思います。
    早速3.0.6をインストールしましたが、こちらでも再現します。
    install.phpが表示されません。

    こうなったらApacheではどうかも試してみたいと思います。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「特定のキャリアで全く表示できなくなる」には新たに返信することはできません。