サポート » プラグイン » 特定のメアドを送信先に設定すると送信できなくなる

  • 解決済 tata

    (@ccclabo)


    ※長文失礼します。

    コンタクトフォームの設定画面の「メール」タブで、「特定のメアド」を送信先や追加ヘッダーのBccで指定すると、フォームのフィールドを入力後、送信ボタンを押すと回転する矢印のアイコンは現れるのですが、それっきりで何も起きません。
    ですが、「特定のメアド」以外のメアドを送信先に設定した場合は、何事もなく送信されます。

    https://contactform7.com/ja/faq/the-spinning-arrow-icon-shows-up-once-i-submit-a-form/
    https://contactform7.com/ja/faq/rest-api-is-deactivated-on-my-site-can-i-use-contact-form-7/
    https://contactform7.com/ja/faq/does-a-contact-form-work-on-a-page-with-javascript-deactivated/
    上記ページを確認しました。
    テーマやプラグインを切ってみても送信できません。
    REST API は無効化していないはずです。(Basic認証がかかっているのでサイトヘルスで401エラーが指摘されています..)
    Ajax フォーム送信がダメなのかと思って、JSを切ってみても送信できません。

    https://ja.wordpress.org/support/topic/contact-form-7-でスピナーがまわり続ける/
    フォーラムの中では上記が、似た状況なのかな、、と思って確認しましたが、GETで正常かとか、POSTでエラーに、というところがあまりよくわからず、ちゃんと確認できていません。

    「回転する矢印のアイコンは現れる」とき、下記のようなエラーのレスポンスがブラウザの開発ツールに表示されました

    Failed to load resource: the server responded with a status of 500 (Internal Server Error)

    http://ドメイン/wp-json/contact-form-7/v1/contact-forms/フォームのID/feedback

    Response { type: “basic”, url: “http://ドメイン/wp-json/contact-form-7/v1/contact-forms/フォームのID/feedback”, redirected: false, status: 500, ok: false, statusText: “Internal Server Error”, headers: Headers, body: ReadableStream, bodyUsed: false }

    {“code”:”rest_no_route”,”message”:”URL とリクエストメソッドに一致するルートが見つかりませんでした。”,”data”:{“status”:404}}

    ブラウザにはこれ以外のエラーは特に検知されていません。また、FireFox, Chrome, Safariで試しましたがいずれも送信できません、ブラウザの開発ツールに表示されるエラーにも特に違いはありません。

    サーバのエラーログには、関係あるかどうか不明ですが、以下のようなメッセージがありました。

    [cgi:error] [pid 54281] [client IPアドレス] malformed header from script ‘index.php’: Bad header: /home/ドメイン/dead.letter… Sa, referer: http://ドメイン/formtest/

    「特定のメアド」というのは、問題が起きているサイトのドメインを@の直後に含むメアドです。(公開されていないサイトなのでURLを示すことはできません)
    サイトのドメインが hoge.com だと仮定して、
    foo@hoge.com →送信不可
    foo@hoge.info →送信不可
    foo@hoge2.com →送信できる
    foo@test.hoge2.com →送信できる
    hoge.com@bar.com →送信できる

    「特定のメアド」というのは、「問題が起きているサイトのドメインを@の直後に含むメアド」と書きましたが、これ以外にもNGになるものは存在するのかもしれません。ですが、さすがに、試していません。
    
希望は、サイトと同じドメインを送信先に設定することです。
    次善案として、送信先には送信可能と確認できているメアドを設定しておき、追加ヘッダーにBccで「特定のメアド」を設定して試しましたが、その場合「送信先」と「メール2の送信先」にはメールが届くことが確認できています。でも、フォームの送信画面上では、スピナーが回り続けており、上記に書いたのと同様の「500エラーのレスポンス」があります。

    WP5.7.2、Contact Form 7は 5.4.1です。
    サーバはさくらインターネット(レンサバ スタンダード)、PHP7.4.19、マルチサイトもそうでないサイトもあり両方で問題が起きています。「特定のメアド」はGoogleのサーバで運用しているようです。
    別のさくらインターネットのレンサバで動いているWPで「特定のメアド」を送信先に指定してテストしましたが、これは問題なく動きました。

    Contact Form 7 プラグインを他のWPサイトでもちょくちょく利用させていただいてますが、このようなケースにあったことはありません。しかし、こういうことは、問題としてはよくあるものなのでしょうか?
    URLを公開できないですし、直接解決につながるようなサポートいただくことは難しいと存じますが、どのような状況であれば、このような不具合が起きる可能性があるのか、ヒントをいただければ大変助かります。
    また、不足の情報等ありましたらご指摘いただけますと幸いです。

3件の返信を表示中 - 1 - 3件目 (全3件中)
3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「特定のメアドを送信先に設定すると送信できなくなる」には新たに返信することはできません。