サポート » 使い方全般 » 独自ドメインに変更後、画像が表示されません

  • この度、質問させていただきたいことがあります。

    ロリポップさんでサブドメインのwordpressから独自ドメインに変更したくて
    多くのサイトを拝見したり、最終的にはロリポップの問い合わせ窓口にご相談し、
    技術的なサポートを受けました。

    ですが、独自ドメインに変更後、画像が全く表示されません。
    バックアップした画像を『wp-content』フォルダにもう一度アップロードしてみたりもしましたが、やはりだめでした。

    ロリポップの技術を担当してくださった方は、
    『なんらかの方法で画像までのパスが知ることができたりすると解決できるかもしれませんが、もう技術的な事なのでこちらではお答えできません』との事でした。

    独自ドメインを使いたい場合は『もう手動で一つ一つ移動するしかない』ともおっしゃっておりました。

    画僧を表示する方法をお知りの方、もしくは手動ではなくとも過去のサブドメインのブログのログを独自ドメインにお引越しする方法をお知りの方がいらっしゃいましたら、教えていただければ本当に助かります。
    どうぞよろしくお願いいたします。

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • rierose3さんこんにちは。
    記事を編集画面にしたときは画像は表示されていますか?
    表示されているのであれば、画像を選択して編集(鉛筆マークを)クリックしてください。
    画像の設定画面が出てくると思うので、画像を右クリックし、[画像アドレスをコピー](chromeの場合)してその画像のURLをコピーしてください。
    コピーしたURLをブラウザのアドレスバーに貼り付けて[Enter]を押して画像がきちんと表示されますか?
    画像が表示されるかされないかで対処が異なります。

    tetsumさん、こんにちは。
    お返事本当にありがとうございます!

    早速ですが、お教えいただいた通りの方法で画像を表示できるか試してみました。
    全部ではないんですけれども、ブラウザーのアドレスバーで表示できるのも多くありました。

    この方法で画像が見えるとしたら対処法などはありますでしょうか?

    ちなみにですが、

    その後、バックアップしている画像をFTPソフトで20個くらいずつこまめにアップしていたからか、何が原因かはわからないんですけれども投稿の一番上の画像以外は記事に反映していたり。

    アイキャッチ画像がところどころ表示されていなかったりと歯抜け状態のところもあり、
    一定していない状態ですが、画像が表示されないのは確かなのです。

    もし、ヒントになるような事がありましたらお知恵をお貸しください。
    よろしくお願いいたします。

    • この返信は2 ヶ月、 2 週間前に  rierose3 さんが編集しました。

    ブラウザーのアドレスバーで表示できた画像が含まれている記事を見た場合も画像は表示されない状態でしょうか?
    ブラウザのアドレスバーに貼り付けて画像が見えたものに関しては少なくとも記事中の画像のURLが間違っているわけではないということになります。

    あとキャッシュ系(WordPressの速度アップとかの目的の)のプラグインを使っていたら一度全部停止して確認してみてください。

    tetsumさん、こんばんは。

    さっそく試してみました。
    ブラウザのアドレスバーに表示された画像は記事では見ることができました。

    記事の一番上に表示される画像が出てこない場合が多く、その画像達は一応WP-contentフォルダには画像がある事にはなっています。

    でもアドレスバーにURLを入れて見てみると、グレーで出てきてしまいます。

    それで、メディアライブラリを確認してみると、やはりグレーでした。

    FTPソフトでの転送は無理ですが、記事の投稿画面からバックアップしてある画像を選んで設定すると表示されるようになります。

    コツコツ設定することも考えつつも、
    教えてくださったように、キャッシュ系やプラグイン停止をして少しずつ様子をみる方法を試している最中です。

    また報告させてくださいね。

    無理だと思っていたので希望が見えてきて本当に助かります。
    ありがとうございます!

    うーん、あまり聞いたことがない状態ですね。
    役に立てず申し訳ないです。

    なにかわかったらまた書き込みたいと思います。

    tetsumさん、こんにちは。
    とんでもないです。
    お力になって下さりありがとうございます。

    10日間ほど悶々とした状態で、サポートセンターの方にも諦めるような感じのニュアンスでのお答えでしたから、教えていただけてとても助かりました。

    お声をかけていただけたおかげでてハッと気付いたりすることもありました。

    プラグインはまだ途中ですが整理するきっかけにもなりました。

    画像の件はおかげさまで0%から70%ぐらいまでコツコツとですがアップしています。

    また、報告させてもらうかもしれません。
    お力になっていただきありがとうございます

    最後に1つだけ。
    “Lazy Load”というプラグイン(画像の遅延読み込み)を使っていると同様の事象が発生するそうです。
    “Lazy Load”プラグインや似たような機能を持つプラグインを使用していたら一度停止してみてください。

    また使用しているテーマによっては、”Lazy Load”と同等の機能を提供しているテーマがあったりします。
    私が使用しているSimplicityもテーマの機能として持っています。
    もし使用しているテーマが同様の機能を持っていて、設定がオンになっているのであればオフにしてみてください。

    ちなみに”Lazy Load”プラグインがらみで発生している場合は、本来の画像の代わりに”1×1.trans.gif”が表示されます。
    本来の画像の大きさだけぽっかりと白い空白ができるようなイメージです。

    解決できることを願っています。

    tetsumさん、こんばんは。

    私も現在使用してるテーマが『Simplicity』です。
    そうなんです、おっしゃるとおり画像の部分が抜けている感じの状況なんです。
    このテーマを使用していますが、また違う理由でいろいろ考えることがあったので、バックアップの準備をして
    Lazy Loadと同じ働きをするプラグインとの関係を調べてみたいと思います。
    (現在出張中ですので戻り次第報告いたしますね)

    教えていただきありがとうございます。
    感謝いたします。

    もし、Lazy Loadプラグインが有効化されているのであれば無効化、あとsimplicityを使っているんであれば、[テーマ] > [カスタマイズ] > [画像] と選択して、[Lazy Loadを有効(画像の遅延読み込み)]をオフにすればいいです。

    SimplicityのLazy Load無効化手順も含めて今回のケースを記事にまとめましたので参考にしてください。

    WordPressで記事の画像が表示されず、画像部分が白抜きで表示される場合の原因と対処

    tetsumさん、今、まとめてくださった記事を拝見しました!
    素人の私でもとてもわかりやすく、あの悶々と悩んでいた事が晴れそうな気がしてなりません。
    今までいろいろwordpressを知識ないまま触りすぎましたので、手直ししながら記事を熟読させていただき作業します。
    解決したら必ず報告したいと思います。
    お知恵をかしていただき本当に感謝いたします。

    rierose3

    (@rierose3)

    tetsumさん、こんばんは。

    画像が表示されなかった件ですが、
    まずはプラグインを必要無さそうなのを調べて
    停止や削除をして片っ端から調べていました。
    とりあえず必要最低限にしました。 

    画像はトップ写真以外は出現されているのもあったので、抜けている画像を再アップしたりもしていましたが、画像数が多く少々途方に暮れ気味でした。

    後半でtetsumさんにお声かけしていただき、
    テーマが「Simplicity」で“Lazy Load”プラグインとの関連性を教えていただき
    説明どおり実行してみました。
    そうしたら、直りました!直ったんです!

    すぐに報告したかったのですが
    サブドメインから独自ドメインに変えたので、リダイレクト方法に失敗したりもろもろで、少し間を要してしまいました。

    一時は独自ドメインでブログをする事も諦めなければいけないと思いましたが、お教えいただけたおかげで無事移行することができました。
    本当にありがとうございましたm(_ _)m

    tetsum

    (@tetsum)

    rierose3さん、画像がきちんと表示されるようになって良かったですね!
    お役に立ててよかったです。

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • このトピックに返信するにはログインが必要です。