サポート » 使い方全般 » 画像の編集ができない

  • 解決済 ziong197

    (@ziong197)


    画像をアップロード後、メディアライブラリから任意の画像を選択し、「画像を編集」ボタンを押下すると画像が表示できない旨のアイコンが表示されます。
    その状態で、画像の回転や反転アイコンをクリックすると、「プレビュー画像を読み込むことができませんでした。ページを読み込み直してもう一度お試しください。」と表示されます。
    また、トリミングアイコンはグレーアウトしています。

    メディアライブラリでは、リスト表示、グリッド表示ともに問題なく一覧表示されます。

    サーバは自前ですが、JPG、GIF、PNG等の画像はアップロード後にサムネイル等が生成されるため、GDライブラリは正しく機能していそうです。

    WordPress側の設定または環境の問題等あると思いますが、どの部分を疑うべきでしょうか?
    ご教示いただけますよう、お願いいたします。

    <環境>
    ・OS
    CentOS release 5.7 (Final)

    ・Apache
    Server version: Apache/2.2.22 (Unix)
    Server built: May 28 2015 11:59:40

    ・php(5.2.17 ⇒ 5.6.9へソースからV/UP)
    PHP 5.6.9 (cli) (built: Aug 25 2015 20:19:20)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies

    ・gd(php.info)
    GD Support: enabled
    GD Version: bundled (2.1.0 compatible)
    FreeType Support: enabled
    FreeType Linkage: with freetype
    FreeType Version: 2.2.1
    GIF Read Support: enabled
    GIF Create Support: enabled
    JPEG Support: enabled
    libJPEG Version: 6b
    PNG Support: enabled
    libPNG Version: 1.2.10
    WBMP Support: enabled
    XBM Support: enabled
    JIS-mapped Japanese Font Support: enabled
    WebP Support: enabled

    ・mysql
    mysql Ver 14.14 Distrib 5.6.25, for Linux (x86_64) using EditLine wrapper

11件の返信を表示中 - 1 - 11件目 (全11件中)
  • gblsm

    (@gblsm)

    テーマを例えば Twenty Fifteen、プラグインは WP Multibyte Patch だけ有効に(他を停止)しても、変わりありませんか?

    ziong197

    (@ziong197)

    gblsmさま

    ご返信ありがとうございます。
    テーマをTwenty Fifteenに、プラグインをWP Multibyte Patchのみ有効の状態にして試してみましたが、状態は変わりませんでした。

    gblsm

    (@gblsm)

    この過去トピックが参考になるかもしれません。
    [解決済み] stream_preview_iamge()が偽を返して画像を編集できない

    ziong197

    (@ziong197)

    gblsmさま

    そちらは既に参考にしていて、libpngのバージョンを変えたりもしてみたのですが、解決しませんでした。

    libpngのバージョンを変えた場合、画像アップロード時にPNG画像の場合のみサムネイルが作られなくなり、バージョンを元に戻したところ、サムネイルが作られるようになりました。
    元に戻した状態のバージョンでlibpngが機能したといえるかと思います。

    gblsm

    (@gblsm)

    そうでしたか。実際に経験したことがないのでこれ以上はわからないです、ごめんなさい。

    ziong197

    (@ziong197)

    gblsmさま

    いえいえ、ご丁寧に対応いただき、ありがとうございました。

    引き続き、他にも何か情報をお持ちの方がいらっしゃいましたら、ご助言いただけないでしょうか。
    どうぞ宜しくお願いいたします。

    gblsm

    (@gblsm)

    自信ありませんが(コメントがつかないようなので)、apacheとphpのログに怪しい出力がないでしょうか。debugレベルによって違うかもしれません。

    ziong197

    (@ziong197)

    gblsmさま

    ご連絡ありがとうございます。
    apacheとPHPのログには、今件に関するものは何も出ておりません。

    gblsm

    (@gblsm)

    試すとよさそうなのは、環境を複製してphpをCentOSのリポジトリのものに差し替えてみる位しか思いつきません。。。

    ziong197

    (@ziong197)

    自己解決しました。
    Apacheのバージョンを2.2.22から2.2.29に上げたところ、画像の編集を行えるようになりました。
    その際、モジュールを全てオンにしているため、バージョンの問題なのかモジュールの問題なのかは切り分けられていません。
    ひとまず解決しましたので、本スレッドは解決済みとさせていただきます。

    gblsmさま

    ご返信ありがとうございます。
    ちょうどコメントをいただいた時期にPHPの入れ直しも試していましたが、ダメでした。
    最後の望みでApacheをインストールし直したところ、解決いたしました。

    gblsm

    (@gblsm)

    解決してよかったです。不思議なことがあるものですね、勉強になりました。

11件の返信を表示中 - 1 - 11件目 (全11件中)
  • トピック「画像の編集ができない」には新たに返信することはできません。