サポート » 使い方全般 » 管理画面に入れなくなりました!

  • こんばんは!
    相当古いバージョンですが「TwentyEleven1.3」をカスタマイズしてHP運営(http://hisashige.net)しています。
    うろ覚えなので申し訳ないのですが、何かの「プラグイン」をアップデートしようとしたのですが、アップデートを完了する前に画面がフリーズしてしまい、その後、一切管理画面が表示されないようになりました。
    なんとか解決したくアドバイスお願いします。
    ちなみにログインは可能です。
    お手数をおかけしますが、よろしくお願いいたします。

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • kntn13さん

    ログインは可能とのことですが、ログインをしても画面が真っ白とかそういう状況でしょうか?

    本来ならプラグインを全て無効にしてみて試すのが良いと思うのですが、管理画面が真っ白だとそれもできないと思うので、ftpでサーバーにはいっているプラグインそれぞれのフォルダ名を一度リネームするなどで強制的に無効にしてみて、改めて管理画面が見れるか試してみてはいかがでしょうか?

    リネームしてもすぐに戻せるように、名前にアンダーバーを付けるなどの簡単なものにしておいたほうが良いです。

    それでもだめな場合は、WordPressのデバッグモードを使ってみてください。

    https://wpdocs.osdn.jp/WordPress%E3%81%A7%E3%81%AE%E3%83%87%E3%83%90%E3%83%83%E3%82%B0

    YATさん!
    素早いご回答ありがとうございました!
    直りました!

    アドバイス通り、「FTP」のプラグインフォルダのフォルダ名「broken-link-checker」を「broken-link-checker_」と変更したら管理画面が表示されるようになりました!
    的確なご指示、ありがとうございました!

    ただ現状、管理画面の「プラグイン」では「プラグイン broken-link-checker/broken-link-checker.php はエラーにより停止しました。エラー: プラグインファイルが存在しません。」となっています。
    もしこれを正常に動作させる方法をご存じであればお教えください。(結構重宝しているプラグインなので・・・)

    ともかく最悪の状況は脱することができました。
    ありがとうございました!

    kntn13さん

    無事表示されたようで良かったです!

    >> ただ現状、管理画面の「プラグイン」では「プラグイン broken-link-checker/broken-link-checker.php はエラーにより停止しました。エラー: プラグインファイルが存在しません。」となっています。
    もしこれを正常に動作させる方法をご存じであればお教えください。(結構重宝しているプラグインなので・・・)

    これについては、考えられることがいくつかあるので、どうすれば解決できるというのをお伝えすることが難しいのですが

    • プラグインが他のプラグインと競合してる部分がある
    • おつかいのWordPressのバージョンにプラグインが対応していない
    • プラグインバージョンアップでの不具合がある

    などが考えられますが、これ以外の理由もあり得ると思います。
    一旦ローカルに開発環境をつくって、サーバーの状況と同じ状況にして開発やテストを行っていろいろ試してみるのが最善策かと思います。
    その上で不明点や疑問点がある場合は、改めてフォーラムなので検索した上で、それでも改善できない場合は改めてトピックを立ててみてはいかがでしょうか?

    YATさん

    このたびはお世話になりありがとうございました。
    私の使用環境が古過ぎることも原因のひとつなのだと思います。

    >> 一旦ローカルに開発環境をつくって、サーバーの状況と同じ状況にして開発やテストを行っていろいろ試してみるのが最善策かと思います。

    これが大事なのはわかっているのですが、知識が無いため「ローカル開発環境」が作れません。
    そのためWordPressのバージョンアップにも踏み切れずにいます。
    これについてはいろいろ調べて試してみたいと思います。
    もし「ここを見たらいいよ!」というのがあればお教えください。

    ありがとうございました。

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • このトピックに返信するにはログインが必要です。