サポート » 使い方全般 » 管理画面ダッシュボードが真っ白

  • coolhotride

    (@coolhotride)


    昨夜、突然管理画面が真っ白になってしまいました。
    サイトは表示されます。
    その前にプラグインを4、5くらい自動バージョンアップしたので、それが原因かと思いプラグインを全て削除しましたが駄目でした。
    フォーラムの過去に真っ白になった場合の対処方法、グーグルで検索などしてあらゆる事を試しましたが駄目でした。
    IE,CROME,FIREFOX,SAFARIで試しましたが真っ白です。
    ただ不思議な事に、iphoneを使えば管理画面が表示され全ての事が行えます。

    サーバーはさくらインターネットです。
    どうぞよろしくお願いします。

15件の返信を表示中 - 1 - 15件目 (全31件中)
  • shokun0803

    (@shokun0803)

    まずはじめに「バグ報告と提案」はwordpressの明らかなバグを報告するところであって、個別の問題を投稿する場所ではありません。この場合「使い方全般」が適当だと思われます。厳しいことを言うようですがここに投稿していることで人の目に付きづらくなっていることも返答がなかなかこない原因にもなっていますよ。

    で、突然何かが発生した場合は「それまでに何を行ったか?」や「サーバーにソフトのバージョンアップや障害情報などは発生していないか?」あたりが一番怪しくなります。

    その前にプラグインを4、5くらい自動バージョンアップしたので、それが原因かと思いプラグインを全て削除しましたが駄目でした。

    とあるので、前者の「それまでに何を行ったか?」は確認できている?ようですが、テーマの削除なども試してみましたか?(defaultテーマなど最初から入っているものは消してはいけませんよ)
    プラグインはテーマが依存している場合もあるので、削除したことでテーマが動かないことも考えられます。また、

    iphoneを使えば管理画面が表示され全ての事が行えます

    とありますが、iphoneでは通常のPC用の画面が表示されているのでしょうか?携帯関係のプラグインなどで携帯用のログイン画面が表示されたりはしていませんよね?(プラグインを全て削除しているのでそのようなことはないと思いますが・・・)

    このことから考えうることはPCからのアクセスが全て蹴られている、もしくはブラウザかその中間サーバにキャッシュが残っていることなどでしょうか。PCからのアクセスが蹴られているとすればhtaccessなどになにか問題が発生していないかなどの確認、キャッシュが残っているだけだとすれば、キャッシュの削除、もしくは別のPCからアクセスしてみるなどの対処方法を試してみましょう。

    kvex

    (@kvex)

    メモリな気もしますが・・・

    真っ白でも、実はブラウザからソースを見るとソースは読み込まれてる、とかはないですかね?

    coolhotride

    (@coolhotride)

    shokun0803さま

    よく理解せず「バグ報告と提案」に投稿してしまいまして申し訳ございません。
    ご指摘はごもっともです。
    以後気をつけます。

    「それまでに何を行ったか?」は確認できている?ようですが、テーマの削除なども試してみましたか?

    テーマの削除をしてdefaultテーマにしています。classicテーマは削除しておりません。
    あと管理画面が真っ白になる数日前に、知らない新たな購読者がユーザー登録しました。
    購読者の削除はしておりません。

    iphoneでは通常のPC用の画面が表示されているのでしょうか?携帯関係のプラグインなどで携帯用のログイン画面が表示されたりはしていませんよね?

    専用のプラグインは削除しましたのでiphoneではPC画面が表示されております。

    PCからのアクセスが蹴られているとすればhtaccessなどになにか問題が発生していないかなどの確認、キャッシュが残っているだけだとすれば、キャッシュの削除、もしくは別のPCからアクセスし

    htaccessには問題が無いか検証しておりますが、問題があったとしてもその問題が何かわかっておりません。
    htaccessのどの部分が怪しい等、教えて頂ければ幸いです。
    よろしくお願いいたします。

    キャッシュは先ほど使用ブラウザ全てで削除してみましたが駄目でした。
    他のPCでも管理画面真っ白でした。

    kvexさま

    実はブラウザからソースを見るとソースは読み込まれてる、とかはないですかね?

    右クリックし「ページのソースを表示」したところ、ソースは表示されました。
    メモリはどこをチェックすればよろしいでしょうか。
    よろしくお願いいたします。

    shokun0803

    (@shokun0803)

    右クリックし「ページのソースを表示」したところ、ソースは表示されました。

    ということは、アクセスが蹴られているわけではなさそうですね。htaccessは考えられるとすればredirectあたりかと思いましたが、今回は関係なさそうです。

    とすればkvexさん曰くメモリ?ということですが、おそらくPHPのメモリのことでしょう。同じくhtaccessなどでphp_value memory_limit 16Mなどのように記述するのですが、”突然”なのですよね?今まで使えていたのですよね?そのあたりが不思議です・・・

    ちなみにwordpressのバージョンは2.8.4ですか?(2.8にはダッシュボードがメモリを激しく食う問題があったと記憶しています)

    coolhotride

    (@coolhotride)

    shokun0803さま

    ”突然”なのですよね?今まで使えていたのですよね?

    突然だったと思います。
    何の前触れも無かった様に思われます。
    前日までは管理画面で投稿しておりました。

    ちなみにwordpressのバージョンは2.8.4ですか?

    2.8.4です。
    このバージョンアップは1週間ちょっと前にやりました。
    バージョンアップ後、しばらくは管理画面が表示されておりました。
    しかし、言われるようにダッシュボードメモリを食っているのかもしれません。
    htaccessにphp_value memory_limit 16Mと記述してみます。

    coolhotride

    (@coolhotride)

    追記
    大変申し訳ございません。
    php_value memory_limit 16Mとはどのフォルダに記述すればよろしいでしょうか。
    よろしくお願いします。

    coolhotride

    (@coolhotride)

    「wp-settings.php」に記述し試しましたが駄目でした。

    kvex

    (@kvex)

    違います。phpの設定ですので、php.iniや.htaccessに記述します。

    しかしながら、ブラウザにソースが読み込まれていることから(本当に最後まで読み込まれているならば)ブラウザのエンコーディングとかではないですかね?

    <doctype ~~
    からはじまって
    </html>
    まで読み込まれているっぽいですか?

    coolhotride

    (@coolhotride)

    ご指摘ありがとうございます。

    しかしながら、ブラウザにソースが読み込まれていることから(本当に最後まで読み込まれているならば)ブラウザのエンコーディングとかではないですかね?

    <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>
    <html xmlns から <script type=”text/javascript”>
    try{document.getElementById(‘user_login’).focus();}catch(e){}
    </script>
    </body>
    </html>

    こんな感じで1から48行くらいになってます。

    ブラウザのエンコーディングはどのように設定をすればよろしいでしょうか?
    どうぞご教授下さいません。

    .htaccess.txtはwordpress直下のディレクトリに入れており
    下記のように記述されてます。

    <files async-upload.php>
    AddHandler application/x-httpd-phpcgi .php
    </files>
    <Files plugin-install.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files update.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files update-core.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files admin.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files options-general.php>
    AddHandler application/x-httpd-phpcgi .php

    php_value memory_limit 16M
    </Files>

    モデレーター JOTAKI Taisuke

    (@tai)

    「バグ報告と提案」から「使い方全般」に移動しました。

    かんりしゃ

    kvex

    (@kvex)

    php_value memory_limit 16M
    </Files>

    ではなく

    </Files>
    php_value memory_limit 16M

    のほうは良いかと思います。
    というか、現状でphpinfoを見たときに16Mとかじゃないですかね?
    32Mや64Mにしたらどうですか?

    coolhotride

    (@coolhotride)

    kvexさま
    ご丁寧にありがとうございます。

    32Mや64Mにしたらどうですか?

    下記のように.htaccess.txtに記述しましたが駄目でした。

    <files async-upload.php>
    AddHandler application/x-httpd-phpcgi .php
    </files>
    <Files plugin-install.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files update.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files update-core.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files admin.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files options-general.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    php_value memory_limit 64M

    他に考えられる原因がありましたらどうかお願いいたします。

    masaru

    (@masaru)

    横レス失礼

    下記のように.htaccess.txtに記述しましたが駄目でした。

    まさか.htaccess.txtのままサーバーにFTPなどを使いUPしてませんよね?
    サーバー側でのファイル名は.htaccessにしないと認識しませんよ。

    さくらインターネットは管理画面より【PHP設定ファイルの編集】を選択すればphp.iniの編集ができるみたいなので確認してみてはどうでしょうか?
    できるのならそちらにphp_value memory_limit 64Mを記載してみてください。
    参考をみると「memory_limit」はもとから128Mって書いてありますね・・・。
    phpinfoで現状の設定を見るほうがいいかもしれませんね。

    ファイル名phpinfo.phpを作成して内容は下記を記載。
    <?php phpinfo() ?>
    サーバーにアップロードしてphpinfo.phpにアクセスすれば表示されると思います。

    あ。レンタルサーバーは使った事ないのでWeb情報のみなので現在の仕様と違う場合や、プラン?等の違いに使えないかもしれません。

    coolhotride

    (@coolhotride)

    masaruさま

    ありがとうございます。

    まさか.htaccess.txtのままサーバーにFTPなどを使いUPしてませんよね?
    サーバー側でのファイル名は.htaccessにしないと認識しませんよ。

    そのまさかです。
    .htaccessに変更してアップすると、管理画面がInternal Server Error~となりますので、.htaccess.txのままアップしておりました。

    さくらインターネットは管理画面より【PHP設定ファイルの編集】を選択すればphp.iniの編集ができるみたいなので確認してみてはどうでしょうか?

    早速、* php.ini 設定ファイル編集 *にphp_value memory_limit 64Mと記述しましたが、Internal Server Errorと表示され管理画面に入れません。
    設定ファイル編集の欄の下に下記のような注意書きがありましたが、今回の件と何か関係があるのでしょうか?

    <注意事項>
    php.iniの項目の詳細についてはサポート対象外となります。
    .htaccess に PHP_Flag や PHP_Value を指定せず、php.ini に設定してください。htaccess に記述した場合、Internal Server Error になります。
    設定内容を間違えるとInternal Server Error となりますので注意してください。

    ファイル名phpinfo.phpを作成して内容は下記を記載。
    <?php phpinfo() ?>
    サーバーにアップロードしてphpinfo.phpにアクセスすれば表示されると思います。

    ファイルを作りアップしましたが、PHPのソースが、そのまま表示されてしまい見せません。
    申し訳ございませんがphpinfoをよく理解しておりません。
    wp-settings.phpのlimit 32Mとなっておりました。

    他に問題点があればどうぞ教えて下さい。
    よろしくお願いします。

    masaru

    (@masaru)

    .htaccessに変更してアップすると、管理画面がInternal Server Error~となりますので、.htaccess.txのままアップしておりました。

    これは注意事項の制限に引っかかっているので正しい動作になりますね。
    なので.htaccessへの記載は削除してください。

    早速、* php.ini 設定ファイル編集 *にphp_value memory_limit 64Mと記述しましたが、Internal Server Errorと表示され管理画面に入れません。

    すみません。コピペミスしてました(汁
    memory_limit = 64MB
    が正しいですね。

    管理画面に入れないってさくらのですかね?WordPressのですかね?
    さくらならFTPでルート直下?にphp.iniがあると思うので
    (なければ探して見てください。)直接編集してみてください。

    WordPressならさくらの管理画面から再度修正してみてください。
    これで大丈夫だと思います。

    ファイルを作りアップしましたが、PHPのソースが、そのまま表示されてしまい見せません。

    さくらはPHPファイルのパーミッションを705か755にする必要があるみたいですが変更されていますかね?

    wp-settings.phpのlimit 32Mとなっておりました。

    これはdefine(‘WP_MEMORY_LIMIT’, ’32M’);とかが記載されいるのですかね?
    //define(‘WP_MEMORY_LIMIT’, ’32M’);
    としてコメントアウトしてみてください。

    手探りなサポートになって申し訳ないです。

15件の返信を表示中 - 1 - 15件目 (全31件中)
  • トピック「管理画面ダッシュボードが真っ白」には新たに返信することはできません。