サポート » テーマ » 重大なエラーが発生

  • akikotamura16

    (@akikotamura16)


    このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。

    —————-

    と表示されて、メールが届きました。

    ——————

    こんにちは。

    WordPress には、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能があります。

    今回の場合、WordPress がテーマ LION MEDIA でエラーを捉えました。

    まずはじめに、ご自分のサイト (https://arkadas-jinzai.sakura.ne.jp/jinzai/) を開き、目に見える問題がないか確認してください。次に、エラーが発生したページ (https://arkadas-jinzai.sakura.ne.jp/jinzai/jinzai/wp-admin/themes.php?activated=true) を開き、同様に問題がないか確認してください。

    この問題をさらに調査するにはサーバーホストに連絡してみてください。

    もしサイトが壊れていてダッシュボードに正常に接続できない場合、WordPress には特別な「リカバリーモード」があります。これによりダッシュボードに安全にログインし、さらに調査をすることができます。

    https://arkadas-jinzai.sakura.ne.jp/jinzai/wp-login.php?action=enter_recovery_mode&rm_token=X0VujsUxFKPFAZm8bv0cye&rm_key=BlwPBfJaZzgXBF1u1uUYrc

    サイトを安全に保つため、このリンクは1日に有効期限が切れますが、ご心配なく。有効期限後にこのエラーが再度発生した場合は、新しいリンクをお送りします。

    この問題を解決するためにヘルプを求めた場合、以下の情報を尋ねられるかもしれません。
    WordPress バーション6.3.1
    現在のテーマ: LION MEDIA Child (バージョン 1.2)
    現在のプラグイン:  (バージョン )
    PHP バージョン8.0.29



    エラー詳細
    ===============
    エラータイプ E_ERROR が /home/arkadas-jinzai/www/jinzai/wp-content/themes/lionmedia/functions.php ファイルの 5030 行目で発生しました。 エラーメッセージ: Uncaught Error: Call to undefined function create_function() in /home/arkadas-jinzai/www/jinzai/wp-content/themes/lionmedia/functions.php:5030
    Stack trace:
    #0 /home/arkadas-jinzai/www/jinzai/wp-settings.php(600): include()
    #1 /home/arkadas-jinzai/www/jinzai/wp-config.php(93): require_once(‘…’)
    #2 /home/arkadas-jinzai/www/jinzai/wp-load.php(50): require_once(‘…’)
    #3 /home/arkadas-jinzai/www/jinzai/wp-admin/admin.php(34): require_once(‘…’)
    #4 /home/arkadas-jinzai/www/jinzai/wp-admin/themes.php(10): require_once(‘…’)
    #5 {main}
     thrown

    サイトも見れず、ダッシュボードにも入れず、リカバリーモードへすすんでも、「Recovery Mode not initialized.」と表示されました。

    もうこのテーマいれなくてもいいので、重大なエラーを無くしたいです。

    ヘルプの必要なページ: [リンクを見るにはログイン]

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • munyagu

    (@munyagu)

    こんにちは

    PHP のバージョンを 7.2.x に変更してください。

    トピック投稿者 akikotamura16

    (@akikotamura16)

    ありがとうございますm(_ _)m

    ただ、レンタルサーバで見ましたが7.2.xがなく、数字の近い7.4は非推奨でサポートが終了していました…

    こんにちは。
    解決済みであれば聞き流してください。
    PHPのバージョンを変更できない状況でしたら、別のテーマに変更してみてはいかがでしょうか?
    https://ja.wordpress.org/support/article/appearance-themes-screen/

    munyagu

    (@munyagu)

    5.6 ~ 7.x なら何でもいいので、サポートされているものに変更してみてください。

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック「重大なエラーが発生」には新たに返信することはできません。