サポート » プラグイン » 鬼太鼓(oni daiko)プラグインでのエラーについて

  • 解決済 takunomi

    (@takunomi)


    マルチサイトの子テーマの最新投稿をまとめて親サイトに表示してくれる便利なプラグイン「鬼太鼓(oni daiko)」をWordpress3.1にて試しています。
    http://experiment.street-square.com/2010/12/21/onidaiko/

    ウィジットにて、トップに表示させてみたのですが、下記のようなエラーが表示されます。

    Warning: krsort() expects parameter 1 to be array, null given in /home/xxxxxx/public_html/wp-content/plugins/oni-daiko/oni_daiko_contents.php on line 42

    Warning: array_slice() [function.array-slice]: The first argument should be an array in /home/xxxxxx/public_html/wp-content/plugins/oni-daiko/oni_daiko_contents.php on line 43

    Warning: Invalid argument supplied for foreach() in /home/xxxxxx/public_html/wp-content/plugins/oni-daiko/oni_daiko_contents.php on line 48

    該当するoni_daiko_contents.php内の42行目付近をみてみましたが、いまいち、エラーの意味が分からず、立ち往生気味です。

    プラグインのVerは、0.5.4となっています。
    テーマは、Twenty Ten 1.2です。

    よろしくお願いします。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • webnist

    (@webnist)

    エラーの後に子ブログの記事は表示されていますか?

    トピック投稿者 takunomi

    (@takunomi)

    Webnistさん、ありがとうございます。

    すいません、インストールしているプラグインをすべて外し(削除)て、もう一回、インストールし直したら、表示できるようになりました。
    何か競合していたのか確認すればよかったんですが、何も考えずに削除してしまったので・・。

    ご返信いただき、ありがとうございます。

    webnist

    (@webnist)

    こちらでも同じ現象を再現できました。

    子ブログから記事が取得できない場合に同じ様なエラーが出ておりました。

    エラーの報告ありがとうございます。
    プラグインの方を修正しておきます。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「鬼太鼓(oni daiko)プラグインでのエラーについて」には新たに返信することはできません。