サポート » 使い方全般 » 記事のパスワードをかけて、開けません

  • 投稿の記事にパスワードをかけましたが、
    記事を読むときにパスワードを入力しても、開けません。
    どうすればいいでしょうか?

    以前ME2.2.3だったときも同じでした。
    バージョンアップすると直るかと思ったのですが同じです。

    よろしくお願いします。

15件の返信を表示中 - 1 - 15件目 (全20件中)
  • モデレーター IKEDA Yuriko

    (@lilyfan)

    パスワードに記号が含まれていませんか? シングルクォート (‘) やダブルクォート (“) が含まれている場合、パスワード保護がうまく動作しないようです (WordPress のバグ)。

    記事を保護するパスワードは、英数字のみにするのが無難です。

    あと、トピックにつけるタグは空白区切りではなく、コンマ区切りです。入力し直していただきますようお願いします。

    スレッド開始 yu4

    (@yu4)

    ご連絡ありがとうございます。
    単純に「1」をパスワードにしただけでもできません。

    タグには何も入力していません。

    引き続きよろしくお願いします。

    モデレーター IKEDA Yuriko

    (@lilyfan)

    ひょっとすると、php.ini で magic_quotes_gpc がオンではないでしょうか。wp-pass.php の 4,5 行目の magic_quotes_gpc に関する if 文を削除するとどうでしょう?

    これで改善するとすれば、WordPress のバグですので、報告してみます。

    スレッド開始 yu4

    (@yu4)

    4,5 行目の以下を削除して、サーバーにアップしましたが、やはりパスワードを開くことができませんでした。
    それとも、削除しすぎたのでしょうか。
    引き続きお願いします。

    if ( get_magic_quotes_gpc() )
    $_POST[‘post_password’] = stripslashes($_POST[‘post_password’]);

    スレッド開始 yu4

    (@yu4)

    if ( get_magic_quotes_gpc(0) )

    にもしてみましたが、できませんでした。

    モデレーター IKEDA Yuriko

    (@lilyfan)

    うーん。変ですね。if 文だけ除いて、stripslashes が強制適用されるようにしたらどうでしょう。

    スレッド開始 yu4

    (@yu4)

    ご連絡ありがとうございます。

    <?php
    require( dirname(__FILE__) . ‘/wp-config.php’);

    $_POST[‘post_password’] = stripslashes($_POST[‘post_password’]);

    上記のようにifをなくしましたが、できませんでした。

    また、ifだけでなく、↓も削除してみましたが、できませんでした。
    $_POST[‘post_password’] = stripslashes($_POST[‘post_password’]);

    ちなみに、
    サーバーは、さくらインターネットを使っています。

    引き続きお願いいたします。

    スレッド開始 yu4

    (@yu4)

    htaccessは以下になっているのですが、この原因になるようなことはありますでしょうか。
    よろしくお願いします。

    DirectoryIndex index.html index.htm index.php .ht
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    スレッド開始 yu4

    (@yu4)

    WordPressのパスワードをマニュアルでリセットする方法

    このサイトで、解決方法らしきものが書いてあるのですが、
    phpmyadminのコントロールパネルが、このサイトと自分のが違うために、わかりません。

    自分のは以下です。
    MySQL クライアントのバージョン: 4.1.20
    「Function」「Value」がこのバージョンでは表示されていません。

    これに相当するのはどちらでしょうか?

    よろしくお願いします。

    2.6.5使用中です。

    必要が生じて記事を保護しようとすると、全く同じ現象がでて困っています。
    これについては解決していないようなので返信として投稿させていただきました。
    解決方法などご存じでしたらご教示下さい。
    上記の方法は全て試しましたが、解決していません。
    なにとぞよろしくお願い申し上げます。

    乗っかってすみません。
    私も同じ問題で困っています。
    記事を保護の設定をすると、いくら単純なパスワードにしても開きません。
    ネットでも結構検索しましたが解決に至らずです。
    解決できれば助かります。
    何か解決方法の糸口でもご存知の方、よろしくお願いいたします。

    利用環境
    wordpress:2.6.3
    サーバ:さくらインターネット

    すみません私も同じ様に記事の保護で投稿記事にパスワードを設定したのですが
    いざ開こうと思ったら開けません。

    2.6.5を使っています
    サーバーはjust size networkです。

    小粋空間さんで紹介しているWordPress で「続きを読む」の折りたたみ Web2.0で入れるShow Hide “more” with WordPressを使っていませんか?

    これ導入しているとパスワードかけた記事が開けないってコメントがありました。
    記事コメントはこちら
    コメント投稿している人がコード変更版を書いているみたいなので対象でしたら変えてみたらどうでしょうか?

    まったく該当しなければごめんなさい。

    kentanjp様レスありがとうございます。
    Show Hide “more” with WordPressというのは特に使用していませんので
    該当しません。

    もう完全にお手上げ状態です。(×_×)

    う~ん。そうなるとお手上げです^^;

    ただプラグインの影響等も考えられるので、まだ試してないならプラグイン全停止して
    開けるか確認してみてはどうでしょうか?
    #ないとは思いますがテーマもデフォルトにすると切り分けになるかもです。

    この状態で開けるなら何かのプラグインが干渉してるってことになるので
    1つづつ有効にしてどれが駄目かを見つけるしかないですね。

    この状態で開けないなら・・・サーバーとの相性?なのかな・・・。

15件の返信を表示中 - 1 - 15件目 (全20件中)
  • トピック「記事のパスワードをかけて、開けません」には新たに返信することはできません。