サポート » 使い方全般 » 2.7 Flash 10 Firefox メディアのアップロード時のエラー

  • 2.5系では既出だったと思うのですが、2.7でも発生しましたので記載します。
    いくつかのBlogで2.7ではFlash 10でも利用できると書いてあったのですがどうなんでしょうか?
    当方、Wordpressは初心者です。
    Firefox 3.0.4
    Flash 10.0 r12
    PHP info

    WordPressを導入し、問題なくSWFを使ってアップロードしていたのですが突然エラーになりはじめました。
    ブラウザアップロードでは問題ないようです。
    また、htaccessなども設置していません。
    何度かブラウザのキャッシュをクリアしたり、Flashのバージョンを9にしてみたりしているのですが同様のエラーが出力されます。
    IEでは問題なく動作いたします。

    HTTP エラー。
    アップロード中にエラーが発生しました。後ほど再度お試しください。

    何か見落としているかもしれませんが、助言いただけませんでしょうか?

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • 追記になります。
    先ほど、Flash 10 デバックで実行したところ以下のエラーが出力されました。

    Error #2044: ハンドルされていない IOErrorEvent : text=Error #2038: ファイル I/O エラー。

    参考になれば幸いです。

    何度かブラウザのキャッシュをクリアしたり、Flashのバージョンを9にしてみたりしているのですが同様のエラーが出力されます。

    どうやってバージョンを変更してますか。
    アンインストーラで完全に削除してインストールしないとFlash Playerのバージョン違いが複数インストールされることがあります。

    またデバッグ版だと通常版では発生しないエラーをキャッチし動作できないこともあります。

    WordPress2.7+Flash player 10でのFlashアップローダは動作しているようです。
    通常版のFlash Playerで試すことをお勧めします。

    返答ありがとうございます。
    Flashアンインストーラーを利用し、再起動、最新版をインストールという手順で行っております。
    再度、通常の10をインストールしましたが同様の症状が現れました。
    突然、アップロードできなくなったのでFlash以外の別の問題なのでしょうか。
    Flash以外のアドオンをOFFにしましたが変らずです。
    IEでは問題なく、動作いたしました。
    記載し忘れましたが、OSはVistaです。

    ついでにファイルの破損も考え、上書きにて再度ファイルをアップロードし直しました。

    余談になりますが、アップロードの進行を表すバーは完了直前でエラーで停止いたします。
    500Kのファイルをアップロードしようとしています。
    画像

    WordPress 2.7
    Flash Player 10,0,12,36
    Firefox 3.0.4
    OS X 10.5.6
    の私の環境では使用できてます。

    http://demo.swfupload.org/v220beta3/index.htm
    SWFUploadのデモページです。
    ここで使用できるなら、WordpressのFlashアップローダのなにかが悪いことになります。

    >完了直前でエラーで停止
    完了直前なんですよね、アップロード処理をするPHPに原因があるような気もしますが。

    >IEでは問題なく、動作
    IEもPlayerは10ですか?

    もしかするとVistaが悪いとか?
    でもそうだったらもっと大騒ぎになってそうです。

    Vista+Firefox3.0.4+Flash10.0r12+wordpress2.7-jaで試してみました。
    1MB超のファイルでもFlashアップローダーでアップロードできました。
    ただし、特定の画像ファイル(確認できたのは690kbのjpg)が何度やりなおしても、画像の下のほうが壊れる現象になりました。(アップロードは成功します)
    ファイルサイズの問題ではなさそうなので原因は不明です。(何度かやったら成功するかも?)
    なにか問題の切り分けのヒントになれば。

    taikikenさん
    shokun0803さん
    ご返答ありがとうございます。

    SWFUploadのデモページで動作を確認すると問題なく動作いたしました。
    Flashの問題ではなさそうです。
    そのため、DBとPHP全て削除しBlogというディレクトリに再インストールを行いました。

    すると、問題なく動作いたしましたが別の問題が発生いたしまいた。
    アップロードが完了したと思うと、ログイン画面が出力されるようなりました。
    ちょっと意味不明な現象ですが画像を参照していただけますでしょうか?
    画像

    そして、Blogディレクトリとは別にhakoというディレクトリに新規にWordpressをインストールしました。
    するとこちらは、アップロードに関しても全て問題なく動作いたします。

    再度、Blogディレクトリ内のWordpress本体とDBを削除し同名のディレクトリに再インストールしたとことログイン画面が現れるという現象が発生しました。

    どうやら、Blogという名前のディレクトリで作成するとうまく動作しないようですので
    どこかのキャッシュがいたずらをしていると思っています。

    画像を見たところ
    hako Blogへ戻る のリンクがついていますが
    BlogディレクトリのWordPressでアップロードをしたのに
    その画像の状態になっているということでしょうか?

    可能性をつぶしていきましょう
    hakoのWordPressとBlogのWordPressで同じDBを使用しているのでしょうか?
    当然テーブルの接頭語はそれぞれ変えていますよね?

    というかWordPressを再インストールする際にも
    DB内のテーブルを一度全て削除なりはされてますか?

    でなければご使用の鯖の仕様が関わってくるかもしれません
    URLのチルダがらみとか

    torocha2002さん、返答ありがとうございます。

    BlogディレクトリのWordPressでアップロードをしたのに
    その画像の状態になっているということでしょうか?

    申し訳ございません、画像が不適切でした。
    Blogディレクトリの場合は以下になります。
    画像

    hakoのWordPressとBlogのWordPressで同じDBを使用しているのでしょうか?
    当然テーブルの接頭語はそれぞれ変えていますよね?

    はい、同じDBを利用しております。
    また、接頭語もBlogディレクトリの接頭語は「blog」。hakoディレクトリの接頭語は[hako]としております。

    というかWordPressを再インストールする際にも
    DB内のテーブルを一度全て削除なりはされてますか?

    はい、テーブルは削除して再インストールを行っています。

    自宅サーバなのでDB辺りの設定がうまくいっていないのでしょうか。

    先ほど、再度検証しまとめましたので記載いたします。

    Firefoxのタブでの検証
    Firefoxのタブ機能を利用して、同一ドメインにて2つ以上のWordpressにアクセスしSWFを用いてファイルをアップロードするとログイン画面が出力されたりHTTPエラーが発生する。

    タブ機能を利用して、2つのWordpressを操作し全てログアウトしてもHTTPエラーが発生した。
    一旦ブラウザを終了し、1つだけログインすると問題なくSWFを用いてファイルをアップロードできた。
    2つともログイン状態でも起こるときと起こらないときがありました。
    偶発的に発生するようです。

    IEでのタブでの検証
    Firefoxと同一環境で検証したが、まったく発生しなかった。

    1つだけログインすると問題なくSWFを用いてファイルをアップロードできた。

    だとするとWordpress 2.7 + Flashアップローダ + Flash Player 10 は無実みたいですね。

    2つ以上のWordpressにアクセスしSWFを用いてファイルをアップロードするとログイン画面が出力されたりHTTPエラーが発生する。

    FirefoxのCookie管理の仕様に関係してくるのかもしれません。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • トピック「2.7 Flash 10 Firefox メディアのアップロード時のエラー」には新たに返信することはできません。