サポート » バグ報告と提案 » 2.7.1に自動アップグレードするとmarkdown.phpが削除される

  • 解決済 riywo

    (@riywo)


    自動アップグレードを使って2.7から2.7.1にアップグレードすると,
    なぜか/wp-content/plugins/markdown.phpが削除されるようです.

    動かしているのはさくらのレンタルサーバ上です.
    原因までは突き止めていませんが,2つあるWordPressで両方とも
    発生しました.その後markdown.phpを再度アップロードすれば
    何事もなかったかの様に動くので大した問題ではないのですが…。

    http://blog.riywo.com/2009/02/14/073430

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • riywoさん、こんにちは。

    自動アップグレード時に削除されるファイルwp-content/plugins/markdown.php が入っていました。

    自動アップグレードの中で、過去のバージョンで使われていたけれど現在のパッケージには含まれないファイルを削除する処理が入るのですが、markdown が昔本体に同梱されていたとか、何かあるのかもしれませんね。
    とりあえず大事に至らなくてよかったです。

    開発側に伝わっているか、どなたかお分かりになりましたら教えてくださいー。

    PHP Markdown

    モデレーター Seisuke Kuraishi (tenpura)

    (@tenpura)

    markdown.php は過去に公式パッケージに含まれていたプラグインなので存在した場合に削除されてしまうようです。
    markdown-.php 等変名しておくか wp-content/plugins/markdown/markdown.php のように 1 階層下においてみてはどうでしょうか?

    bonopsさん tenpuraさん

    ありがとうございました.過去に公式に含まれていたんですねー.
    とりあえず置き場所を変更しておくことで対処しておきます.

    2.6でバージョンアップしてた時は削除されなかった記憶があったので
    怪現象だなと思っていたら,削除は2.7からの機能なんですね.

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「2.7.1に自動アップグレードするとmarkdown.phpが削除される」には新たに返信することはできません。