サポート » インストール » 2.8 アップグレードのトラブルシューティング

  • モデレーター Naoko Takano

    (@nao)


    Happiness Engineer at Automattic

    以下は MichaelH さんが英語版フォーラムに投稿した、2.8 Problems and Solutions (FAQ) の訳です。2.8 アップグレードの際に問題が発生したら、まず以下を試してみてください。

    アップグレードの前にバックアップをとりましょう
    データベースのバックアップ(WordPress Codex 日本語版)を参考にしてください。

    ログインしてプラグインを無効化できない場合

    • phpMyAdmin を使い、wp_options テーブルの option_name フィールドで active_plugins を探す。option_value field の値を a:0:{}に変更
    • プラグインフォルダの名称を一時的に変更する

    ビジュアルエディタやエディタツールバーの問題解決
    (訳者注: その他、管理画面の表示に関する問題解決にも参考になるはずです)

    • ブラウザーの再読み込み、キャッシュの削除
    • Google Gears を使っている場合、一度オフにしてまたオンにする
    • wp-admin/wp-includes フォルダを削除し、新しいパッケージをダウンロードしてアップロードする。または自動アップロードを再度試す。
    • http://example.com/wp-includes/js/tinymce/wp-tinymce.php (example.com は自分のドメインに置き換え)というアドレスに行って、PHPエラーや警告が表示されないか確認。もしなにか書かれていれば、レンタルサーバーに連絡して解決してもらう。
    • define( 'CONCATENATE_SCRIPTS', false ); というコードを wp-config.php の最初に追加する。WordPress のスピードは遅くなるので、数日後に削除してまたテストしてみること(これを行うことで古いネットワークキャッシュを削除できます)。
    • ツール > アップグレード > 自動再インストールを実行、を試してみる
    • プラグインをすべて無効化して、ひとつずつ有効化しながらどれに問題があるのかを発見する
    • 他のブラウザーを使ってみる
    • プロフィールページの「ビジュアルリッチエディターを使用しない」のチェックを外す

    ウィジェット関連のトラブルシューティング問題解決

    • プラグインをすべて無効化して、ひとつずつ有効化しながらどれに問題があるのかを発見する
    • 外観 > ウィジェットページの右上にある「表示オプション」をクリックし、「アクセシビリティモードを有効にする」リンクをクリック
    • ブラウザーの再読み込み、キャッシュの削除

    Fatal error: Allowed memory size of xxxxxxxx bytes exhausted というエラーメッセージが出る
    プラグインを無効化しても効果がない場合、以下の方法で PHP メモリを増やしてみます。

    • PHP.ini ファイルを編集できるなら、memory_limit = 32M となっている場合、memory_limit = 64M にしてみる。
    • PHP.ini ファイルに触れない場合、.htaccess ファイルに以下を追加: php_value memory_limit 64M
    • wp-config.php ファイルに以下を追加: define('WP_MEMORY_LIMIT', '64M');
    • レンタルサーバー会社に相談する

    アップグレードは完了したがログインできない、エラーメッセージが表示される場合
    プラグインファイルについてのエラーの場合、そのプラグインフォルダの名前を変更するか削除してみる

    ブログのホームページに投稿がいくつも表示される
    プラグイン関連の問題の可能性が高いので、すべて無効化してみる

    アップグレード中に Warning: gzinflate() [function.gzinflate]: data error というエラーメッセージが出る

    • ツール > アップグレード > 自動再インストールを実行、を試してみる
    • 手動アップグレードを実行する

    アップグレード後に500エラーが発生

    • 管理パネルから、もしくは上記の「ログインしてプラグインを無効化できない場合」を参考にプラグインを無効化する
    • 手動アップグレードを実行する

    ログイン後ページが真っ白になる

    • 管理パネルから、もしくは上記の「ログインしてプラグインを無効化できない場合」を参考にプラグインを無効化する
    • 使用中のテーマのフォルダの名前を変更して、強制的にデフォルトテーマに変更させる

    Fatal error: Cannot use object of type WP_Error as array というエラーメッセージが出る

    • Options、Structure テーマに問題があることが報告されているので、これらを使っている場合はアップグレードを行う
    • デフォルトテーマに変更する
4件の返信を表示中 - 1 - 4件目 (全4件中)
  • wp-admin/update-core.php で 500 Internal Server Error が出てアップグレードに失敗してしまうサイトがありましたが、

    1. 稼働中のプラグインをすべて停止
    2. アップグレード実行
    3. プラグインを再有効化

    の手順で、無事アップグレード出来ました。
    一括でプラグインを止めてしまったのでどれが癌だったのが分かりませんが、アップグレード時に干渉するプラグインがあるのは間違いないようです。

    以上、ご報告まで。

    # もしこのスレッドに付けるのが不適切であれば、削除等頂ければと思います。

    既出かも知れませんが、2.8.3への自動アップグレードで、アップグレードの進行を阻害するプラグインがありましたのでお伝えします。

    • プラグイン名:cforms II (version 10.6)

    このプラグイン停止後、自動アップグレードは正常に動作しました。
    ご報告まで。

    #もし個別のプラグイン名を出すことが不適切、または既に内容が既出であれば本投稿を削除頂ければ幸いです。

    はじめまして。
    最新バージョンにアップロードしようとしたら、「解凍しています」で2時間以上固まったままで、渋々リロードしたところ、再度ログインすると、ログインページ上部にエラーメッセージが表示されます。

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wassup/wassup.php on line 2010

    プラグインのせいだと思い、ログインできない場合もありますが、たまたまログインできると、ダッシュボードは表示されず、下記のようなメッセージのみが表示されます。

    ===
    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wassup/wassup.php on line 2010

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-login.php on line 290

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-login.php on line 302

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-includes/pluggable.php on line 662

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-includes/pluggable.php on line 663

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-includes/pluggable.php on line 664

    Warning: Cannot modify header information – headers already sent by (output started at /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-content/plugins/wp-social-bookmark-menu/wp-social-bookmark-menu.php:1) in /export/sd01/www/jp/r/e/gmoserver/5/6/sd0027856/blog.shigekazu.jp/wp-includes/pluggable.php on line 865
    ==
    私のような場合は、上記でご説明いただいているどのパターンで修復すれば、よいでしょうか。

    ご存知の方がいらっしゃいましたら、教えていただけると助かります。
    宜しくお願いします。

    はじめまして。

    サイトを立ち上げる際、以下のようなエラーが表示されてしまい、
    どう修正すればいいのか分からずにおります・・・。

    Warning: Cannot modify header information – headers already sent by (output started at /home/timecap/public_html/viva88/wp-config.php:1) in /home/timecap/public_html/viva88/wp-includes/pluggable.php on line 865

    この場合、wp-config.phpファイルの1行目や、
    pluggable.phpファイルの865行目をどのように修正すれば良いのでしょうか。

    ご存知の方がいらっしゃいましたら、お教えいただけましたら幸いです。

    何卒宜しくお願い致します。

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック「2.8 アップグレードのトラブルシューティング」には新たに返信することはできません。