サポート » インストール » 3.7 アップグレードに伴う既知の問題とその解決方法

  • モデレーター Naoko Takano

    (@nao)


    この情報は、英語フォーラムの「Troubleshooting WordPress 3.7 Master List」を訳したものです。更新されている場合もありますので、原文も参照してください。

    ————————————

    Basie がリリースされました。 アップグレード後に問題に遭遇しましたか?

    まずは、深呼吸

    このスレッドにはプラグインやテーマとバージョン3.7に関する既知の問題が含まれています。すべてに目を通した上で、更新される予定ですのでまた後ほどチェックしてみてください。
    落ち着いて、我慢強く、礼儀正しい行動をしてください。フォーラムボランティアの方々が手を貸そうと努力してくれるはずですが、質問を投稿する皆さんにもご協力頂く必要があります。すべてのフォーラムルールが適用されます。

    フォーラム投稿がすぐに表示されない場合は、少々お待ちください。通常よりもたくさんの質問が投稿されているため、誤ってスパムとしてマークされてしまう可能性が高くなっています。複数の投稿を行うとさらに時間がかかってしまいますので、投稿は一度だけにしてください。匿名として表示されてしまった場合、後ほど修正しますのでしばらく待ってみてください。

    • 詳しい説明を含む件名をつけてください(「ひどいバージョンです、早く助けて下さい」よりも、「3.7へのアップグレード後、パーマリンクがすべて動作しなくなりました」 の方が効果的です)。
    • 問題を分かりやすく説明してください。今見えている画面を詳しく描写する、エラーメッセージをペーストする、スクリーンショットにリンクするなど必要に応じて最適な方法を考えてみてください。フロントエンドの問題の場合、サイトへのリンクを貼るのも参考になる場合があります。
    • サイトがダウンしてしまうのは嫌なものですが、同じ内容を何度もフォーラムに投稿するのは控えましょう。
    • 新規トピックを作成しましょう。他の人が既に投稿したトピックと同じ問題が発生していると思われる場合、その人と同じバージョンの WordPress を使っていて、同じホスティングサービスの物理的に同じサーバーにファイルがあり、完全に同じプラグイン・テーマ・設定を使っているわけではない限り、そのスレッドへコメントせずに自分のトピックを立てたほうがよいでしょう。
    • 問題が解決したら、「解決済み」にマークしましょう。フォーラムボランティアが何度もトピックを確認する必要がなくなります。
    • お忘れなく、あなたは一人ではありません!

    また、WordPress の方向性が気に入らない場合は不満を訴えるトピックをフォーラムへたくさん投稿すべきではありません。既に誰かが似たような話をしている場合はそこにコメントするか、開発プロセスにもっと早めに参加することをご検討ください(例えば、SVN 経由のベータテストなど)。ここにあるのは何ヶ月間もの作業とテストの積み重ねです。何かが完全に壊れているのではない限り、変更される可能性は低いでしょう。

    投稿するに以下をお読みください。

    この投稿スレッドすべて、およびドキュメンテーションの WordPress 3.7 新機能リストに目を通してください。
    インストール済みのサイトの「WordPress について」のページ(http://example.com/wp-admin/about.php など)で、何が変更されたかをチェックしてください。
    また、以下をまずお試しください。

    • キャッシュ系プラグインを無効化し、サーバー・ブラウザキャッシュをすべて削除する。
    • すべてのプラグインを無効化し、問題が解決するかどうかチェックする。もし解決した場合はプラグインを1つずつ有効化し、どれが問題なのかをつきとめる。管理画面に入れない場合は、FTP または MySQL 経由でプラグインフォルダをリセットしてみる。無効化されているように見えるプラグインが問題を引き起こしている場合もある。また、mu-plugins フォルダのプラグインもフォルダ名の変更などによって無効化すること。
    • テーマを Twenty Twelve または Twenty Thirteen に変えてみて、テーマ関係の問題を排除してみる。管理画面に入れない場合は、FTP で他のテーマファイルを移動・削除してみること。twentythirteen フォルダのみしかない場合、このテーマが自動的に使われる。
    • 手動アップグレードを試す。どうしてもうまくいかない場合は、バージョン3.7のZIPファイルを入手し、インストールし直す。wp-admin および wp-includes フォルダをサーバーから削除する必要がある場合もある。手動アップグレードについて詳しくはドキュメンテーションを参照。
4件の返信を表示中 - 1 - 4件目 (全4件中)
  • モデレーター Naoko Takano

    (@nao)

    コアの変更

    更新点:

    • バックグラウンド更新: WordPress は今後、セキュリティリリース向けのマイナーリリースを自動的に更新するようになりました。つまり WordPress 3.7.1 が公開されると、一定の条件を満たしている場合自動的にアップグレードが実行されます。もし SVN や Git などのバージョンコントロールソフトウェアを利用していたり、アップグレードの際に FTP 情報を入力する必要がある場合にはバックグラウンド更新は無効になります。
      自動バックグラウンド更新が動作する環境かどうか確認したい場合は Background Update Tester プラグインをご利用ください。

    他にも検索の改善、日時クエリの強化などの変更はありますが、今回のリリースではほとんどの機能は開発者向けのものとなっています。

    モデレーター Naoko Takano

    (@nao)

    自動バックグラウンド更新のデフォルト有効化について

    コア開発チームなどはこの変更について非常に長い間じっくりとディスカッションを行ってきました。自動更新はセキュリティ上の問題を最小限に抑えるためのものであり、デフォルトで有効化されている理由は「この機能を最も必要としているユーザー層は、変更に気づかず有効化しないのではないか」という想定からです。こういった理由付けに同意しない方もいるかもしれませんが、どちらにしろデフォルトで有効化されているという事実はバグではありません。例えばプラグインをインストールする際に FTP ログイン情報を記入する必要がある環境など、自動更新が無効化されるべきユーザーに対しては無効になっています。

    メンテナンス・セキュリティアップグレードに対して自動更新を無効化することは決しておすすめしません。それでも無効化する必要がある場合はこちらの手順に従ってください。

    モデレーター Naoko Takano

    (@nao)

    既知の問題

    WP 3.8-alpha がインストールされてしまった場合:

    新に 3.7 をダウンロードして上書きアップロードしてください。ベータテスタープラグインを意図せず有効化していたか、RC 版を使っていため 3.8 の開発版にアップグレードされてしまった可能性があります(少しの間だけそのような現象が起こる重複タイミングがありました)。もしそのどちらでもなく、3.7 ファイルでの上書きによってサイトを修正できなかった場合はフォーラムに新規投稿してください。

    モデレーター Naoko Takano

    (@nao)

    報告済みのプラグイン・テーマ関連の問題

    【テーマ】
    現在報告されている問題はまだありません。

    【プラグイン】

    • Reed Write: バージョン 1.5.6 で 3.7 アップグレード後に fatal error が発生する。
    • WP United: 全般的には正しく動作するが、設定によっては問題が発生する可能性がある。
    • Plugin Organizer: 早すぎるタイミングでフックを行おうとするため正しく動作しない。詳しくはこちらの記事の情報と修正方法を参照。
4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック「3.7 アップグレードに伴う既知の問題とその解決方法」には新たに返信することはできません。