サポート » インストール » 3.7.1にアップデード後、ログインできない。

  • 初めて投稿します。

    ワードプレス初心者ですので、情報不足や説明がわかりずらいところがあるかもしれませんが、何とぞ宜しくお願い致します。

    数日ほど前、管理画面に3.7.1へのアップデートの表示があったので、更新作業しました。

    更新作業中に画面が固まってしまったので、ブラウザを再起動後、再度ログインしようとしました。

    サイトの表示は問題なかったのですが、ログイン画面の上部に以下のようなエラー表示が表示されIDとパスワードを入力しても
    “エラー: 無効なユーザー名か、間違ったパスワードです。”と表示されてしまいます。

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘wp_authenticate_spam_check’ was given in /export/sd202/www/jp/r/e/gmoserver/5/5/sd0199955/pamda.info/wp-includes/plugin.php on line 199

    ログインできない状況が続き困っています。

    どうかお助けください。

    何とぞよろしくお願いいたします。

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • 메텔

    (@digitmaetel)

    ログインする時に不正アクセスされないようなプラグインを設定してましたか?

    ご連絡ありがとうございます。
    プラグインはいくつか入れていたのですがすべて覚えておらず、ログインできくなり確認が取れない状態です。
    折角ご連絡いただいたのに、申し訳ありません。

    메텔

    (@digitmaetel)

    サイト「国立・私立医学部専門予備校PMD」は問題はなさそうなので、
    プラグインを一時的に向こうにしてみてはどうでしょうか。
    スパム・チェックでトラブルが発生しているようなので
    そのためのプラグインが特定できれば幸いですが。

    何度もありがとうございます。

    初歩的なご質問で大変申し訳ないのですが、、ログインできない状態でプラグインを無効にするにはどうすればよろしいでしょうか?

    お手数お掛けいたします。何卒宜しくお願い致します。

    메텔

    (@digitmaetel)

    FTPでサーバーにアクセスして、プラグインのディレクトリをリネームしてください。

    onamaeサーバーをご利用のようですから、
    Filemanager で
    pamda.info/
    wp-content/plugins/
    で『名前変更』をしてください。
    そして、同じディレクトリの階層に空のディレクトリ「plugins」を作成してサイトにもう一度アクセスしなおしてください。
    一応ブラウザのキャッシュはクリアしておくと良いでしょう。

    本当にありがとうございます。

    ご教授いただいたように、既存のpluginsの名前を変更し、同じディレクトリに新しいファイルをpluginsの名前でつくってみましたが、ログインのエラーは解消されませんでした。

    메텔

    (@digitmaetel)

    もとのpluginsディレクトリを見れば、使っていたプラグインはわかると思います。
    ログイン制限を設定しているプラグインがありませんか。
    もし利用していたのなら、アップデートの際に無効化しておかなかったのが事故になったのだと思われます。

    初めまして。

    3.7.1への更新を中断したことが原因かもしれません。
    ※ コアが不完全な状態ではその後の動作に保証はできないと思います。

    ダウンロードページから3.7.1をダウンロードして、展開したものをftpで上書きした方が良いのでは?
    ただし、デフォルトテーマを改造している場合は、テーマ名をリネームしてから行ってください。

    追加情報です。

    「wp_authenticate_spam_check」で検索すると、公式フォーラムに同じ様なエラーメッセージが出たという「locked out of site for both admins」がありますね。

    こちらでは wp-content 以外のディレクトリを上書きするようコメントがありました。

    digit@maetelさん

    ありがとうございます。

    >もとのpluginsディレクトリを見れば、使っていたプラグインはわかると思います。
    >ログイン制限を設定しているプラグインがありませんか。

    確認してみました。ダウンロード時に入っていたプラグインに加え、all in one seo pack、sitemap generator, haadspace2,mata-managerといったプラグインが確認できました。

    他、ログインを規制するようなプラグインは見つけられませんでした。。。

    메텔

    (@digitmaetel)

    wp-includes/plugin.phpの 199行目にトラブルの原因ヒントが有ると思います。

    all in one seo pack、sitemap generator, haadspace2,mata-managerといったプラグインが確認できました。

    それらならログインを規制するような動作はしませんね。
    セキュリティ系プラグインが壊れているのかと想定してました。

    shirakobato さんのアドバイスと同じく、

    wp-content 以外のディレクトリを上書きするよう

    お勧めします。
    3.7.1 にする前がいくつだったか情報不足ですが、
    onamaeサーバーにある、わたしが運営している中で不安定なサイトを試しにアップデートしてみましたら、
    案の定、不具合を起こしました。
    一見、フリーズしているようにみえるのですがメンテナンスに時間がかかる時が起こるようです。
    FTPで上書きするのがスムーズです。
    一旦バックアップコピーを撮っておいて、上書きしましょう。
    ただし、wp-config.phpはそのままに。

    shirakobatoさん
    digit@maetelさん

    ありがとうございます!

    上書きの方向でやってみます。
    また結果がわかりましたらご報告させて頂きます。

    宜しくお願い致します!

    shirakobatoさん
    digit@maetelさん

    ありがとうございます。
    wp-content 以外のディレクトリを上書きして解決できました。

    重ねてお礼申し上げます!

    메텔

    (@digitmaetel)

    復旧できてよかったです。
    メジャーアップデートの場合は何かと起こりやすいですね。
    今回は途中でブラウザがフリーズしたのがきっかけなのでしょうけど、
    わたしは別々のブラウザでログインしておいて、
    片方で実行します。

    幸いな場合だと、別の方ではログイン状態でいられるので軽度な誤りはそこで対応できるからです。
    ブラウザ経由でのトラブルは増えているように感じています。
    自動更新はサーバーの負荷も影響するのでFTPを使うほうが短時間で完了できる時もあります。

    以前のプラグインはインストールしなおして、リネームしたディレクトリは削除して大丈夫です。

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • トピック「3.7.1にアップデード後、ログインできない。」には新たに返信することはできません。