サポート » バグ報告と提案 » 3.9になって、更新ボタンが押せなくなる時があります

  • macdigi

    (@macdigi)


    初めての投稿です。私なりに検索しましたがわからず、投稿します。失礼がありましたら、ご容赦ください。
    3.9にアップデートしてから、と思うのですが、過去の記事を編集後、「更新」ボタンを押そうとしても、アクティブにならない(押しても何も反応しない)ことがあります。
    100%ではなく、時々、そうですね、1割程度でしょうか。

    これはバグでしょうか。
    回避策はありますか。

11件の返信を表示中 - 1 - 11件目 (全11件中)
  • Fumito MIZUNO

    (@php-web)

    状況が曖昧なので、以下の確認をお願いできますか。

    ・お使いのブラウザは何でしょうか?もし手元に他のパソコンがあれば、そちらから試してもらえますでしょうか?
    ・(テーマがTwentyFourteenでない場合)テーマをTwentyFourteenにした場合も同様でしょうか?
    ・(プラグインを使用している場合)プラグインを無効にした場合も同様でしょうか?

    witch_doktor

    (@witch_doktor)

    同様の症状が起こっておりましたので調査してみました。

    まずは症状の説明から。

    編集画面を開いて1分ほど経ったときの自動保存時、エディタの下部に「下書きを保存しています…」というメッセージが表示されますが、これが成功せずに上記メッセージが表示されたままになります。

    このときに記事を編集すると「公開(更新)」「下書きとして保存」といったボタンが非アクティブな状態となります。しばらくするとアクティブに戻る時もありますが、戻らない場合もあります。こうなると記事の保存ができません。

    なお、編集画面を離れて入りなおしても、内部的に自動保存は成功している模様であり、記事本文は最終編集時から失われないようです(ただしカスタムフィールドテンプレートの編集は駄目でした)。

    環境は

    • MacOS 10.9.1
    • Chrome
    • テーマはオリジナルテーマ
    • プラグインはたくさん入ってます

    で、まずはテーマを変えましたが、状況は変わりません。

    次にプラグインをすべてオフ。
    これで解決しました。

    ひとつひとつ調べてみると私の場合「Post Type Switcher」というプラグインを無効化すると解決する模様でした。
    macdigiさんが同じプラグインを使っているならそれでしょうし、もしかすると「Post Type Switcher」と同様の何らかの処理を行うプラグインが原因になっているのかもしれません。

    ひとまず、プラグインをひとつひとつ地道に切って確かめるのがよさそうです。

    macdigi

    (@macdigi)

    MIZUNO様、Fukazawa様
    コメントありがとうございました。
    後先 反対になりましたが、私の環境を書きます。

    MacOSX 10.9.2
    Safari 7.0.3
    テーマ:Stinger3 ver20131023
    プラグイン:いくつか使ってますが、「Post Type Switcher」は使ってませんでした

    テーマ、プラグインと、ミスフィットする要素はいろいろありますね。
    大変だけど、その分楽しく、勉強になります。

    何かわかりましたら、投稿します。
    ありがとうございます。

    macdigi

    (@macdigi)

    その後の状況をご報告します。

    ◯テーマの変更(Stinger、Twenty Fourteenなど)
    ◯プラグインのチェック(以下の各種)
     *Amazon JS
     *Wordpress Popular Posts
     *WordPress Importer
     *TinyMCE Advanced
     *WP-PostViews

    原因は救命できませんでした。

    witch_doktor

    (@witch_doktor)

    テーマをデフォルトに戻しても、プラグインをすべて無効化しても同様の症状が現れる、ということですね?

    ちょっと私では他の原因が思いつきません。どなたか同様の症状について知見のある方の回答を待ちましょう。お力になれずすみません。

    モデレーター Daisuke Takahashi

    (@extendwings)

    ブラウザのJavaScriptデバッガーで調べてみないと何とも言えないですが、変更履歴の自動保存が正しく動作していないならば、サーバの設定の可能性もあります。

    Tadashi Yoshida

    (@tadashi-yoshida)

    私も同様の症状になります。

    witch_doktorさんの解説に補足すると

    編集画面を開いて1分ほど経ったとき(WordPressのデフォルトの設定では最後の編集から自動保存まで1分)の自動保存時、エディタの下部に「下書きを保存しています…」というメッセージが表示されますが、これが成功せずに「下書きを保存しています…」メッセージが表示されたままになります。成功すれば「11.19.43pmに下書き保存しました。」というメッセージに変わるはずです。

    このときに記事を編集すると「公開(更新)」「下書きとして保存」といったボタンが非アクティブな状態となります。しばらくするとアクティブに戻る時もありますが、戻らない場合もあります。こうなると記事の保存ができません。

    回避策として、テーマ・プラグイン等をデフォルトにしたわけではありませんが、この症状が発生するのはある特定の固定ページです。他の固定ページではこの問題はおこりません。

    念のため、一旦、該当する固定ページを削除した上でキャッシュ(WP Super Cache)を停止してみたのですが、症状は改善しませんでした。

    自動保存が正常に終了しないので「公開(更新)」「下書きとして保存」といったボタンが非アクティブな状態になるというのは、もっともなこととも言えます。つまり、根本的には自動保存が終了しないことがそもそもおかしいと思います。

    挙動を見た限りでは、最後の編集から1分たって始まる自動保存が何らかの理由で終了しない。ただし、この時は、「公開(更新)」「下書きとして保存」は機能する。

    ここで、もし正しく自動保存が終了すれば、再び、次の最後の編集から1分後まで自動保存は遅らせるはず。ところが、最初の自動保存が終了しないので、すぐに自動保存しようとする。

    これを2〜3回繰り返すと、「公開(更新)」「下書きとして保存」が有効にならなくなる。だいたいこんな感じです。

    解決策は提示できませんが、同様の問題に遭遇したので参考までに投稿しておきます。なにかわかったらまたあらためて投稿します。

    モデレーター Daisuke Takahashi

    (@extendwings)

    WP Multibyte Patchの有効化・無効化を試してみてください。

    Tadashi Yoshida

    (@tadashi-yoshida)

    WP Multibyte Patchの有効化・無効化を試してみましたが、問題の症状は改善しませんでした。

    このプラグインは関係なさそうです。

    Fumito MIZUNO

    (@php-web)

    Tadashi Yoshidaさんへ、

    witch_doktorさんの解説の

    テーマをデフォルトに戻しても、プラグインをすべて無効化しても同様の症状が現れる

    ということでしょうか?

    同じサーバー上で、WP3.9を新規インストールした場合でもなるでしょうか?

    私も、Tadashi Yoshidaさんと同じ状況です。
    固定ページで「下書きを保存しています…」で「公開(更新)」「下書きとして保存」といったボタンが非アクティブな状態となります。

    FireFOXの「Web Developer1.2.5」では、JavaScritのエラーは検知しません

11件の返信を表示中 - 1 - 11件目 (全11件中)
  • トピック「3.9になって、更新ボタンが押せなくなる時があります」には新たに返信することはできません。