サポート » 使い方全般 » 4.7.1にバージョンアップ後、Warningが出て文字化けするようになった

  • 4.7.1へのバージョアップ後、HP全体が文字化けするようになり、HPの上部に以下のWarningが表示されるようになりました。
    対処法をご教授下さい。

    【表示されるようになったWarning】

    Warning: Invalid argument supplied for foreach() in /virtual/sendaiymca/public_html/wordpress/wp-content/plugins/head-cleaner/head-cleaner.php on line 2895

    Warning: Invalid argument supplied for foreach() in /virtual/sendaiymca/public_html/wordpress/wp-content/plugins/head-cleaner/head-cleaner.php on line 2895

    Warning: Invalid argument supplied for foreach() in /virtual/sendaiymca/public_html/wordpress/wp-content/plugins/head-cleaner/head-cleaner.php on line 2895

    Warning: Invalid argument supplied for foreach() in /virtual/sendaiymca/public_html/wordpress/wp-content/plugins/head-cleaner/head-cleaner.php on line 2895

    Warning: ksort() expects parameter 1 to be array, object given in /virtual/sendaiymca/public_html/wordpress/wp-content/plugins/bbpress/includes/core/template-functions.php on line 316

    Warning: ksort() expects parameter 1 to be array, object given in /virtual/sendaiymca/public_html/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 192

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • CG

    (@du-bist-der-lenz)

    Warning 文を見るだけで明白。Head Cleaner を無効化しましょう。

    CG

    (@du-bist-der-lenz)

    また、もう一つの「ksort() expects parameter 1 to be array …」は、WordPressを4.7.1にアップグレードした他に、PHP7 を指定してませんか。

    > Warning: Invalid argument supplied for foreach()

    の方に関してはHead Cleaner 1.4.4 で対策されてるはずなのでそちらはアップデートしてみてください:)

    • この返信は2年、 10ヶ月前にHinaloeが編集しました。
3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「4.7.1にバージョンアップ後、Warningが出て文字化けするようになった」には新たに返信することはできません。