サポート » インストール » 4.0アップグレード後管理画面にログインできない

  • 解決済 Masahito NAGATA

    (@masahito-nagata)


    4.0にアップグレード後、ログイン操作を行うと、
    Fatal error: Call to undefined function hash() in XXXXXXXX/wp-includes/session.php on line 64
    のエラーが表示されます(XXXXXXXXは当方固有のディレクトリ名なので伏せ字にさせて頂きました)。

    PHPのhash()関数が未定義ですよ、と言われていることは認識できて、
    WordPress英語版フォーラムでも本件と同一と思われるトピックを見かけましたが、
    当方の環境は

    PHP 5.2.13
    MySQL 5.1.45

    なので、4.0の要件は満たしていると認識しており、どう対処すべきか認識できませんでした。
    RapidSiteのVPSシリーズVPS-01プランの下で動かしています。

    対応策として考えられるものがあれば、教えて頂けないでしょうか。
    よろしくお願い致します。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • PHP5.2ならデフォルトでhashが使える筈ですが…一つ可能性として
    コマンドラインから

    $ php -i

    またはphpinfoでhashが有効になってるか確かめてみてください…

    (hash support : enabled)

    Masahito NAGATA

    (@masahito-nagata)

    Hinaloeさん
    助言ありがとうございます。

    phpinfoを見たところ、”hash support” の項目自体がありませんでした。
    configureオプションを見たところでも、hashに関する項目は特に見あたりませんでした。

    ‘./configure’ ‘–prefix=/usr/local/php5’ ‘–with-config-file-scan-dir=/usr/local/php5/etc’ ‘–with-apxs2=/usr/sbin/apxs’ ‘–disable-all’ ‘–enable-libxml’ ‘–with-libxml-dir=/usr’ ‘–enable-reflection’ ‘–disable-cli’ ‘–disable-cgi’ ‘–enable-zend-multibyte’ ‘–enable-filter’ ‘–with-regex=php’ ‘–with-pcre-regex’

    hash関連を何らかの形で追加しないといけないということですね。

    あれ……5.1.2以降ではデフォルトでサポートされてるはずなんだけどなぁ……

    そもそもPHP5.2は既にサポート終了しているのでよっぽどの理由が無い限り出来るだけ新しいバージョンを利用すべきなのですが……

    同じ状況で悩んでいました。こちらの環境は、
    PHP 5.4.3
    MySQL 5.5.23

    これはレンタルサーバー側で、hashがインストールされていないということでしょうか…?
    ちなみに、RapidSiteでは問題なく4.0に上げられました。

    とりあえず3.9に戻すのが早いかと思って対応中ですが…。

    Masahito NAGATA

    (@masahito-nagata)

    >Hinaloeさん
    よほどの理由がない限り新しいバージョンを利用すべきであることは承知しているのですが、VPS側の仕様により、運用会社側からしかアップグレードできないようです。

    >erizouさん
    VPS-01プランではhashがインストールされていない、ってことになるんだと思います。
    3.9に戻したいところですが、肝心の管理画面ログインができないため、3.9に戻せないのです。

    Masahito NAGATA

    (@masahito-nagata)

    巷のサイトを参考にして、Wordpressのバージョンを3.9.2に戻し、管理画面にログインできるようになりました。お騒がせしました。
    御助言くださった皆様、ありがとうございました。

    PHP5.3が利用可能とRapidSiteのVPS紹介ページに書かれていましたが管理画面から変更出来ませんか?

    あるいは3.9に戻す場合、ftp等から3.9.2をアップロードしなおします。

    あ、入れ違いになりましたね…

    Masahito NAGATA

    (@masahito-nagata)

    >Hinaloeさん
    VPSシリーズとサーバー運用開始時期による、PHPバージョン違いがあるかもしれません。
    また、本件で運用しているWordpressはサブホストにインストールしたものゆえ、標準搭載のWordpressとは別に、自分でインストールして運用していました。

    今回は、http://tumonet.com/log/wp-downを参考にして、手動バージョンダウンを実施しました。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • トピック「4.0アップグレード後管理画面にログインできない」には新たに返信することはできません。