サポート » インストール » エラーメッセージ: couldn't connect to host “

  • 解決済 Kan

    (@kupoe)


    マルチサイトにてWordpressサイトを運用しています。

    マルチサイトの構成は
    http://サイト.com/ (サイト1)
    http://サイト.com/jp (サイト2)
    http://サイト.com/en (サイト3)
    といった感じのものです。

    はじめはWordpress 4.2.3で運用していまして、その時は特に問題なく使えていました。
    先日 Ver4.2.3 → Ver4.2.4 にアップデートし、その後ネットワークのアップグレードを試みたところ以下のようなエラーが発生し、ネットワークの更新を完了できませんでした。
    “ 注意してください!http://mysite.com/en の更新中に問題が発生しました。サーバーは稼働しているサイトに接続できないようです。エラーメッセージ: couldn’t connect to host “
    (プラグイン停止、キャッシュの削除等行った上で作業しています。)

    またアップグレードの不具合と相関があるのか分かりませんが、同じタイミングで管理画面の挙動が極端に遅くなってしまいました。(管理画面のみで、ウェブサイト自体の挙動は特に気になる点はありません)

    フォーラム等で調べたところ、上記の症状はそれぞれSSL下やプロキシ接続時に発生することがあると知ったのですが、このサイトでは両方とも利用していないためそれらが原因ではないと思っております。プラグインをすべて停止しても変わらず、プラグインが原因ということもなさそうです。

    だとすると他にどういった原因が考えられるでしょうか?
    よろしくお願いします。

    [モデレーター編集: トピックタイトルが空でアクセスできなかったため、タイトルを設定しました。]

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • モデレーター Daisuke Takahashi

    (@extendwings)

    サーバの環境がわからないので何とも言えないですが、PHPからcurlなどで http://mysite.com/en にアクセスできていれば基本的にアップグレードが動作します。

    アクセスできない場合はサーバのhostsファイルなどが関係していることがありますのでサーバ管理者に聞いてみてください。

    ご回答ありがとうございます。

    すみません、サーバー環境の記述が漏れてしまっていました…
    – PHP : 5.3.3
    – データベース環境 : MySQL 5.1.73
    WebサーバーはApacheです。

    PHPのcurlで http://mysite.com/en/ したところ、該当URLにアクセスできていました。
    (なぜか http://mysite.com/en では何も取得できなかったのですが、これは仕様であり今回の問題には無関係なのでしょうか?)

    サーバー管理者にも問い合わせてみました。ひとまずそちらからの返答を待ちたいと思います。
    ありがとうございました。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「エラーメッセージ: couldn't connect to host “」には新たに返信することはできません。