サポート » インストール » 4.4-jaでメディアライブラリ等が表示されない

  • 解決済 Tara E

    (@kumiko-e)


    WordPress4.4-jaにアップデート後、下記不具合が出ています。

    【記事への画像投稿】(投稿・固定ページ問わず)
    ・『メディアを追加』→『メディアライブラリ』に画像一覧が表示されない(クルクルが止まらない)
    ・過去の画像を検索しても、クルクルが止まらず検索結果が出ない
    ・ファイルアップロードは可。サイドバーの『メディア』→『ライブラリ』には問題なく表示されている

    【記事でのリンク挿入】(投稿・固定ページ問わず)
    ・『リンクの挿入/編集』において、過去記事が一切表示されない
    ・過去の記事を検索しても、クルクルが止まらず検索結果が出ない

    【プラグイン更新】
    ・プラグイン更新ボタンを押しても、クルクルが止まらず更新されない
    ・FTPで直接プラグインフォルダを入れると更新される

    ネット検索で調べ、テーマをデフォルトに戻す、『WP Multibyte Patch』を止める、admin-ajax.phpを書き換えるなどしても状態は変わりませんでしたが、『Contact Form 7』を止めると全て正常に動作することが分かりました。
    念のため『Contact Form 7』を再インストールしても直りませんでした。

    現在導入しているプラグインは下記の通りで、すべて最新版です。メインブラウザはFirefox(Windows)ですが、Safari(iPhone)でも同様の状態でした。
    『Contact Form 7』または4.4-jaを諦めるしか手は無いでしょうか。あまり専門的な知識が無いのですが、正常に動作するよう、どなたかアドバイス頂ければと思います。

    BackWPup
    WordPress Backup Plugin
    Biz Calendar
    Breadcrumb NavXT
    Contact Form 7
    Easy FancyBox
    Easy Timer
    Google XML Sitemaps
    Image Widget
    Meta Slider
    NextScripts: Social Networks Auto-Poster
    Remove Category URL
    Simple Tags
    Theme Test Drive(停止中)
    TinyMCE テンプレート
    Tweet, Like, Google +1 and Share
    WP Edit
    WP Multibyte Patch

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • ネット検索で調べ、テーマをデフォルトに戻す、『WP Multibyte Patch』を止める、

    『WP Multibyte Patch』以外を止める、ですね。
    プラグインをひとつひとつ有効にしていくことで原因となるプラグインを特定できる場合があります。

    https://ja.forums.wordpress.org/topic/11794?replies=1

    메텔

    (@digitmaetel)

    わたしの方では相対的なパフォーマンスへの影響はなく、むしろ 4.4-ja は快適なのですが、今朝更新したサイトでプラグイン「Contact Form 7」がインストール出来ない問題が発生しています。
    こちらの対処はこれから試みるのですが、プラグインの機能に依存するサイト運営でしたら、使用プラグインがアップデートをするまではWordPressのアップデートは様子見の方が良いでしょう。本番サイトは時期を待って、ローカル環境でアップデートの検証をすることを奨めます。

    >mimosafa様
    ご返信ありがとうございます。
    検索したページでは『WP Multibyte Patch』が原因のケースだったようで、停止した次第です。

    いま『Contact Form 7』と『BackWPup』、『Contact Form 7』と『WordPress Backup Plugin』…と全てのプラグインとの相性を試してみたところ、不具合は出ませんでした。
    ですが全てのプラグイン(ThemeTestDrive除く)を有効にしたところ、同様の不具合が起きました。ですので、『Contact Form 7』含む3つ以上のコンフリクトかと思います。地道に相性を見ていきたいと思いますが、数が多いのでかなり時間がかかりそうです。

    しばらくは맹조様の仰るとおりWPダウングレードで様子見、また『Contact Form 7』の使用自体も再検討してみます。

    モデレーター Takayuki Miyoshi

    (@takayukister)

    テーマは何をお使いですか?

    以前にも同様の報告がありましたがその時はテーマに問題があったと記憶しています。デフォルトのテーマに切り替えて試してみてください。

    >Takayuki Miyoshi様
    ご返信ありがとうございます。今のテーマは自作です。
    『Twenty Twelve 』と『Twenty Sixteen』の最新版をダウンロードして適用しましたが、不具合はそのままでした。

    モデレーター Seisuke Kuraishi (tenpura)

    (@tenpura)

    検索したページでは『WP Multibyte Patch』が原因のケースだったようで、停止した次第です。

    まず、WP Multibyte Patch が最新版のバージョン 2.5 に更新されているか確認してください。2.5 より古いバージョンの WP Multibyte Patch は、WordPress 4.4 とは互換性がありません。

    WordPress 4.4 + WP Multibyte Patch 2.5 の組み合わせで不具合を見つけた場合は、お手数ですが新しいトピックを立てて報告してください。

    >Seisuke Kuraishi 様
    ご返信ありがとうございます。WP Multibyte Patchはバージョン2.5です。

    自動更新での通知に頼ってはおりますが、ただいま更新通知は出ておりませんので導入プラグインはすべて最新かと思います。すべてWPのプラグインページからダウンロードしています。

    余談ですが、検索では私と同様の不具合は見つからず、内容的に比較的近い(『メディアライブラリが表示されない』という単一不具合)と思い参考にしたページは、すべて4.4-jaより古いバージョンでの情報でした。

    モデレーター Seisuke Kuraishi (tenpura)

    (@tenpura)

    余談ですが、検索では私と同様の不具合は見つからず、内容的に比較的近い(『メディアライブラリが表示されない』という単一不具合)と思い参考にしたページは、すべて4.4-jaより古いバージョンでの情報でした。

    これらの内容のブログを見かける度に記事を書かれた方に連絡して確認しておりますが、ほとんどのケースは単にその方が WP Multibyte Patch の更新を怠っていたために互換性の問題が起きたものです。その他は JavaScript に不具合のある他のプラグイン・テーマが WP Multibyte Patch の JavaScript をブロックしてしまうケースです。実際のところ、ここ数年間の WP Multibyte Patch の過去バージョンにおいて、『メディアライブラリが表示されない』等の原因となるようなバグは一度も見つかっておりません。

    ご返信ありがとうございます。
    恥ずかしながらそこまで検証する知識がなく、似た事例を検索して実行出来そうな対策であれば真似してやってみるしかない状況です。
    ご指摘のWP Multibyte Patchの件は大変参考になりました。心に留めさせて頂きます。

    特に解決法も見つかってはいないのですが、不具合が更に2つ見つかりました。

    (1)サイドバー『外観』→『ウィジェット』→ウィジェットの内容を変更して『保存』ボタンを押すと、クルクルが止まらず保存が終わらない
    (2)サイドバー『外観』→『カスタマイズ』をクリックすると、画面が真っ白で何も表示されない

    (2)は英語版フォーラムでプラグインのコンフリクトが原因だったケースを拝見し、『Contact Form 7』を停止してみると同じく問題なく動作しました。
    https://wordpress.org/support/topic/white-screen-of-death-in-customise?replies=2

    いずれにせよ、プラグインの相性を確認しつつ、引き続き様子を見ようと思います。

    モデレーター Takayuki Miyoshi

    (@takayukister)

    (2)サイドバー『外観』→『カスタマイズ』をクリックすると、画面が真っ白で何も表示されない

    WP_DEBUG のデバッグモードにすれば何かエラーが出力されるんじゃないでしょうか。

    (1)サイドバー『外観』→『ウィジェット』→ウィジェットの内容を変更して『保存』ボタンを押すと、クルクルが止まらず保存が終わらない

    この場合も、おそらく Ajax のリクエストに対する応答が正しい形式になっておらず、何らかのエラー出力のためにフォーマットが崩れていることが考えられるので、例えば Firebug の「コンソール」タブで応答内容を確認するなどすればエラー内容を知ることが可能かもしれません。

    あとは PHP のエラーログに何か出ているかもしれません。

    いずれにしてもエラー出力からたどるなどして問題の直接原因(具体的にどのファイルのどのコードが間違っているのか)を突き止めないことにはどうにもなりません。ソフトウェアなので漠然とした「相性」といったものはありませんし、それがわかったところで問題解決の役には立ちませんので。

    >Takayuki Miyoshi様

    ご返信ありがとうございました。
    アドバイス通りにデバッグモードにしてみると、無事解決致しました!

    下記のエラーが出ましたので、wp-config.phpのメモリサイズを64MBから96MBに上げたところ、いずれも正常に動作するようになりました。

    デバッグモードの存在をすっかり失念していた上、mimosafa様にご案内頂いたページの下部を完全に読み落としておりました。大変ご迷惑をおかけ致しました。
    アドバイス頂きました皆様、本当にありがとうございました。

    ———-

    【外観→ウィジェット→保存エラー】
    (1)wp-debugモード
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 71 bytes) in xxx/functions.php on line 2876
    (2)Firebug
    『admin-ajax.php』の5行目?(右側に青文字)
    http://xxx/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,underscore,shortcode,backbon&load%5B%5D=e,wp-util,wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views,thickbox,media-upload&ver=4.4
    (3)Macintosh Safariの開発モード
    『admin-ajax.php』インターナルサーバーエラーが表示されていました。

    【メディアライブラリが表示されない】
    (1)wp-debugモード
    何も表示されず
    (2)Firebug
    『admin-ajax.php』の5行目?(右側に青文字)
    http://xxx/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,plupload,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomple&load%5B%5D=te&ver=4.4
    (3)Macintosh Safariの開発モード
    『admin-ajax.php』インターナルサーバーエラーが表示されていました。

    【外観→カスタマイズ→真っ白】
    (1)wp-debugモード
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 30720 bytes) in xxx/wp-admin/includes/template.php on line 1096
    (2)Firebug
    何も表示されず
    (3)Macintosh Safariの開発モード
    確認漏れです、申し訳ありません。

    【プラグインの更新エラー】
    メモリ修正前は更新がなく検証できませんでしたが、修正後にちょうど来た更新では正常に動作しました。

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • トピック「4.4-jaでメディアライブラリ等が表示されない」には新たに返信することはできません。