サポート » バグ報告と提案 » 4.4.2–jaへ更新で新規追加する投稿記事のパーマリンク設定が反映されない

  • 解決済 isonori

    (@isonori)


    よろしくお願いします。

    以前は、2~3更新前のものを使っており、
    ワードプレスを最新の4.4.2–ja に更新したところ、
    新規追加する投稿記事のパーマリンク設定が
    反映されなくなってしまいました。

    設定→パーマリンク設定では、
    カスタム構造を選び「/%category%/post-%post_id%.htm」
    になっていて、再度、基本に戻し、再度カスタム構造に
    同じものを入れ、「変更を保存」をしましたが、反映されません。

    反映されなくなるのは、
    http://sitename/?p=3856&preview=true
    と、基本の設定になってしまうということです。
    これは、基本設定のパーマリンク構造と思います。
    投稿を表示ボタンもひょうじされません。

    希望するのは、
    http://sitename/categori/post-3856.htm 投稿を表示
    のようなアドレスになります。

    正常動作は、
    パーマリンク: http://sitename/categori/post-2406.htm 投稿を表示
    と、投稿を表示ボタンも表示される状態です。

    調べたところ、%postname%が入っていないからだめと
    ありましたが、3バージョン前くらいまでは問題なく使えておりました。

    かなり投稿数があるので、パーマリンクは変えることは
    避けたいと考えております。

    ためしたのは、
    ブラウザをIE、クローム両方試してみる
    プラグインを全てオフにする
    テーマを基本のTwenty Fourteenバージョン: 1.6にする
    その上で、最新バージョンを再インストールしましたが、
    反映されませんでした。

    http://sitename/wp-admin/options.php
    で見ても、きちんとパーマリンク設定はいっていました。

    最悪、前のバージョンへ再インストールで、ずっとそのバージョンを
    使い続けることですが、セキュリティ面などが心配です。

    何かよい解決法をご存知の方お見えでしたよろしくお願いします。
    半日頑張っておりましたが、お手上げです。

    簡単なphpファイルのカスタマイズなどは行えますので、
    phpファイルを直接修正する、暫定的な処置でもよいかと思います。

    よろしくお願いします。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • パーマリンクの表示が変ですが、公開ボタンを押したところ、
    http://sitename/?p=3856&preview=true
    から、
    http://sitename/categori/post-3856.htm
    へと、希望するものに自動的に切り替わりました。

    最新版に更新していないサイトも所持していますので、
    比較してみたところ、明らかに挙動が違います。

    パーマリンクの表示の仕方の仕様が変更になったのかもしれませんが、
    こういった無意味な修正は混乱の要因となるので、
    修正を行うチームの方、ぜひとも今後控えていただきたいです。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • トピック「4.4.2–jaへ更新で新規追加する投稿記事のパーマリンク設定が反映されない」には新たに返信することはできません。