サポート » プラグイン » Advanced Custom Fieldsの「画像を追加する」ボタンが消えてしまった

  • 解決済 wakaba2014

    (@wakaba2014)


    Advanced Custom Fieldsで作った画像を追加するためのカスタムフィールドで、
    「画像を追加する」ボタンが固定ページ編集中にいつの間にか非表示の状態になってしまいました。

    新規の固定ページを作成し、カスタムフィールドを設定しているテンプレートに変えると問題なく画像を追加するボタンが出てきますが、
    新規ページでも画像を追加や削除を繰り返しているとボタンが消えてしまう現象が起こりました。

    プラグインが原因という記事を見つけ、
    疑いのあるプラグインを停止・削除していきましたが、
    メディアボタンは復活しませんでした。

    Advanced Custom Fieldsは最新版に更新もしており、
    何が原因でこのような現象が起きているのか見当がつきません。
    よく質問として挙がってくるような画像を追加するボタンがクリックしても反応しない、
    ではなくボタン自体が表示されない状態になっています。

    どなたか心当たりのある方がいませいたら解決法をご教授していただけないでしょうか?
    どうかお願いします。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • スレッド開始 wakaba2014

    (@wakaba2014)

    【Wordpress固定ページ編集画面のカスタムフィールド入力欄のコード】
    デベロッパーツールで確認してみたところ、
    画像を削除したはずなのに画像がある状態のときのCSSになっていました。
    CSSがおかしいため取り除く、編集ボタンも画面外?に隠れて見えなくなっています。
    <div class="has-image">
      <div class="hover">
        <ul class="bl">
          <li><a class="acf-button-delete ir" href="#">取り除く</a></li>
          <li><a class="acf-button-edit ir" href="#">編集</a></li>
        </ul>
      </div>
      <img class="acf-image-image" src="" alt="">
    </div>
    .acf-image-uploader.active .has-image {
      display: block;
    }
    
    <div class="no-image">
      <p>画像が選択されていません <input type="button" class="button add-image" value="画像を追加する"></p>
    </div>
    .acf-image-uploader.active .no-image {
      display: none;
    }

    この判定はプラグインが行っていると思いますが、
    何が原因で判定がおかしくなっているか全くわかりません。

    僕も似たような状況になり、自己解決しましたので、ここに記します。

    僕の場合はAdvanced Custom Fieldsで画像のカスタムフィールドを作って、画像を追加したまでは良かったのですが、画像を入れ替えようと思い、(カスタムフィールドから削除する前に)「メディア」から当該画像を「完全に削除する」にしてしまったのです。

    ・カスタムフィールドにデータは残ったままだが、アップロードした画像データはもう無い。
    ・画像データが無いので、カスタムフィールドのところに、画像や削除ボタン(☓ボタンですね)も表示されない。
    という状態になりました。

    仕方がないので、phpMyAdminからデータベースのwp_postmetaテーブルの中に、Advanced Custom Fieldsが作った当該データを見つけ出して削除しました。
    もちろん、すべて元に戻りました。

    -*-*-*-*-*

    wakaba2014さんの「画像を追加や削除を繰り返していると」という状況がよく分かりませんが、一度、データベースの中を見られてはいかがでしょうか?
    wp_postmetaテーブルの中に何かしらのデータが残ってしまっているのでは無いかと想像しています。

    ↓参考にどうぞ
    http://notnil-creative.com/blog/archives/1752

    スレッド開始 wakaba2014

    (@wakaba2014)

    >mizuponさん
    ありがとうございます!
    おかげさまで謎が解けました…。
    詳しい内容を教えていただきありがとうございました。

    ちょうど自分もメディアの追加とカスタムフィールドでの挿入を
    同じ画像で試していたので、その中で今回のような不具合に出会ってしまったようです。
    メディアから削除したというのを覚えていなかったため、
    どう対処していいのか原因となる操作を特定できなかったのも良くなかったかも…もっと豆にチェックしよ。

    私の場合は、デベロッパーツールを開いてCSSを書き換えて無理やり追加ボタンを出して画像をアップロードし直しました。
    ですが原因がわからないためモヤモヤを抱えていたので解決済みにしていなかったのですが、
    mizuponさんのおかげでスッキリしました!

    本当にありがとうございました!

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「Advanced Custom Fieldsの「画像を追加する」ボタンが消えてしまった」には新たに返信することはできません。