サポート » プラグイン » Advanced Tabs Gutenberg Blockのタブが機能しない

  • 解決済 takechi05

    (@takechi05)


    Gutenbergにタブのブロックを追加してほしいとの要望があり、Advanced Tabs Gutenberg Blockのプラグインをインストールしたのですが、ブロック一覧には「tabs block」と出て、エディタ内でタブの作成はできるのですが、いざ更新を押すとcss等が全く効いてない状態で表示されてしまいます。

    テーマはオリジナルテーマなのですが、デフォルトでインストールされていた他のテーマではタブとして機能しておりました。
    オリジナルテーマの場合、どこかにAdvanced Tabs Gutenberg Block用のcssやjsの記述が必要なのでしょうか?

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • takechi05 さん、こんにちは。

    オリジナルテーマの場合、どこかにAdvanced Tabs Gutenberg Block用のcssやjsの記述が必要なのでしょうか?

    他のプラグインは問題ないのでしょうか?

    多くのプラグインでは、 wp_enqueue_stylewp_enqueue_script等を用いて CSS や JavaScript を追加していると思います。

    wp_enqueue_style で追加された CSS は、 wp_head() や wp_footer() を通じて WordPress に読み込まれますが、テーマの中で wp_head() や wp_footer() 等を使用しているでしょうか。

    https://wpdocs.osdn.jp/テーマの作成 の「テンプレートファイルのチェックリスト」を読んで、WordPress 標準のルールに適合しているかを確認してみてください。

    </head> 終了タグよりも前に wp_head() を挿入する。プラグインはこのアクションフックを使ってスクリプトやスタイルシート、その他の機能を追加する。

    wp_footer() を、body の閉じタグ直前に挿入する。

    のように記載されております。

    • この返信は1年、 4ヶ月前にKOJIが編集しました。
    トピック投稿者 takechi05

    (@takechi05)

    KOJIさん ご返信いただきありがとうございます。
    ご指摘いただいた件、hrader.php内のwp_head()が削除されておりました…。
    初歩的なミスでお騒がせしてしまいました…。
    ご指摘いただき見直すことができました、感謝いたします。
    無事プラグインも動作いたしました。
    本当にありがとうございました!

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「Advanced Tabs Gutenberg Blockのタブが機能しない」には新たに返信することはできません。