サポート » 使い方全般 » AMPエラー(型不明)

  • Google search consoleでサイトマップを送信すると「型が不明」のエラーが出ます。
    表題はAMPエラーとなっています。
    詳細はimgがamp-imgではないかほか5類くらいに分けられていますが、wordpressで何か設定しなければいけないのではないかと思っているのですが、分かりましたら教えて下さい。
    タグに問題があるとも書いてありました。よろしくお願いします。
    wordpressは最新です。all in packをセットしてあります。

    ヘルプの必要なページ: [リンクを見るにはログイン]

15件の返信を表示中 - 1 - 15件目 (全18件中)
  • CG

    (@du-bist-der-lenz)

    リンク先のサイトを閲覧はしませんが、「ほか5類くらいに分けられていますが」も、何があるのか判断できませんが、一つづつ片付けていきましょうよ。「型が不明」というのから、サイトマップが正しく書かれているのか、項目などを確認しなおして再送信しませんか。

    ご面倒をお掛けし誠に申し訳ありません。よろしくお願いします。
    1、許可されていない属性がHTMLタグ「amp-img」にあります。
    2、タグ「style custom」内のテキストに[css! important]が含まれてます。これは許可されていません。
    3、タグ「style amp-custom」のCSS構文エラー。無効な構文エラー「@important」があります。
    4、タグ「img」はタグ「noscript」の子孫としてのみ使用できます。「amp-img」ではありませんか。
    5、必須属性「height」のタグが「amp-img」にありません。
    80歳のジジイがボケ防止のつもりでfan blogを始めたのですが段々はまり込みwordpressまで手を伸ばしてしまい、HTMLもCSSも皆目わからないので一旦何か起こると手の出しようが有りません。これだけ出てきますと、AMPのアカウントエラーか、wordpressdeでなにか操作しなければいけなのかなんて思っています。
    私のURLhttps://www.ishi-toshi.comをご覧にくださいましても結構です。何がいけないのかお教えいただければ幸甚です。

    こんにちは

    AMPが何かはご理解されているのでしょうか?
    また、AMPページはどうやって実現されているのでしょうか?

    ご面倒をお掛けし誠に申し訳ありません。よろしくお願いします。
    1、許可されていない属性がHTMLタグ「amp-img」にあります。
    2、タグ「style custom」内のテキストに[css! important]が含まれてます。これは許可されていません。
    3、タグ「style amp-custom」のCSS構文エラー。無効な構文エラー「@important」があります。
    4、タグ「img」はタグ「noscript」の子孫としてのみ使用できます。「amp-img」ではありませんか。
    5、必須属性「height」のタグが「amp-img」にありません。
    80歳のジジイがボケ防止のつもりでfan blogを始めたのですが段々はまり込みwordpressまで手を伸ばしてしまい、HTMLもCSSも皆目わからないので一旦何か起こると手の出しようが有りません。これだけ出てきますと、AMPのアカウントエラーか、wordpressdeでなにか操作しなければいけなのかなんて思っています。wordpressはAMPの錨マークのようなものをインストールして、有効化はしました。
    素人が手を出したのが間違いなんですかね。本当にご面倒をお掛けします。
    挿入した画像が問題なんでしょうか。
    私のURLhttps://www.ishi-toshi.comをご覧にくださいましても結構です。何がいけないのかお教えいただければ幸甚です。

    お使いのテーマではAMPページ生成の機能があるようですが、AMPの錨マークのようなものと機能が競合しているのではないでしょうか。
    どちらの機能で生成されているのでしょうか?

    というか、記事のampページは生成されていないようですが、どのampページで問題が生じているのか、具体的なページのURLを教えていただけないでしょうか。

    お手数をお掛けし誠に申し訳ありません。とにかくHTMLもCSSもないも分からないです。
    始めはgoogle search consoleのアカウントをとりました。
    それからなんでAMPに行ったのか自分でも忘れてしまっているのです。
    AMPはプラグインを開き右側のキーワードにAMPといれて出てきたもので錨マークのようなものをインストール有効化しました。今これをやると、
    Google Analyticator
    説明として
    Adds the necessary JavaScript code to enable Google’s Analytics. After enabling this plugin you need to authenticate with Google, then select your domain and you’re set.
    こんな文字が出てきます。
    80ジジイが何にもわからないのにwordpressに手を出し、今あげるブログはエラーーばかりです。
    ご指導お願いします。

    CG

    (@du-bist-der-lenz)

    ダッシュボードの「外観」テーマの管理では、ystandardが有効化されていますが、子テーマでしょうか、親テーマのままでしょうか。このテーマは独自機能として、AMPページを生成するオプションがありますが、「AMPページの生成を保証するものではありません。使用しているプラグインや投稿内のHTMLタグ、インラインCSS、javascriptコードによりAMPフォーマットとしてエラーとなる場合もあります。」と明示されています。「AMPページ作成の条件や通常ページへのリンク出力設定など」は完了していますか。プラグイン名もダッシュボードのプラグインページで、有効されているものを正確に記して下さい。明日のライヴの準備の合間に診ているので、「錨マークのようなもの」では、同じ状況を再現させることが厄介です。その前に、サイトマップが正しくGoogle search consoleで受け付けられていないのではないですか。

    大変ご面倒をお掛けしました。
    googleよりメールを頂き、結論としてsearch consoleの最後の確認事項URL記入が行われていなかったようです。
    これで少しの間様子を見たいと思います。
    Ystandard親テーマなのか、子テーマなのかとことでしたが、はっきり申し上げますと、使ってはいますが
    どちらか分かってないんです。
    ただエラーサイトのサイトマップを送りなおすことが出来ていますので、ご面倒をお掛けしましたが、もし
    何かありましたらまたお問い合わせを致します。大変お忙しそうで申し訳ありませんでした。

    サイトマップの送信とAMPのエラーは関係がありません。

    それからなんでAMPに行ったのか自分でも忘れてしまっているのです。

    私の質問は、AMPがどういったものかご存知ですか、ということです。
    AMPが何か分からないのであればGoogle Search Consoleのエラーが解消されてどうなるとお考えなのでしょう。
    AMPページについてどうでもいいならエラーは無視されたらいいと思います。

    • この返信は2 ヶ月、 2 週間前に  munyagu さんが編集しました。

    本当に申し訳ありません。
    最初に申し上げました通りHTML、CSSについて全く理解が無いのです。
    こちらからお尋ねしながら貴方様の質問にも答えず、御怒りはごもっともです。
    googleからメールが来てそれをいじっていましたら偶然気付いてただ解決だと喜んでしまいました。
    タグエラーがまた出たときはまた困るでしょうがもうあなた様は私を相手にしないでしょう。
    自分のふがいなさを恥じてます。お忙しい時間を無駄に使わせお許しください。
    タグのエラーが出たときはもう解決できません。その時はxserverを解約しなければいけないと思っています。ご親切は感謝します。どうぞお怒りを鎮めて下さい。
    いまもう目が見えにくくなってます。打ち間違いもあるかもしれません。ご勘弁を。

    全く怒ったりはしていません。
    ここで質問されるということは、親切な方の時間を使うということです。
    解決すべき問題がないならそのようなことは避けられたらどうかと思い、AMPが何かをご存知なのか質問しました。

    AMPが何なのかわからないなら、エラーは出たままにしておいてもなんの問題もないようなものです。
    「困る」とお書きですが、困る必要があるでしょうか。

    エラーが出ているのが気持ち悪いといった理由で質問さらてももいいかと思いますが、それならAMP機能を停止したら良いと思います。

    何度もご丁寧なお言葉感謝します。
    30、1日とどうしても遠出をしなければならなくなり、ご返事遅れました。
    少しAMPをそのままで、searchi consoleを使ってみます。
    エラーがずっと出続ける場合はまた質問するかもしれません。
    その時はまたご支援いただければと思います。
    有難う御座いました。

    you should change your wordpress theme or template in order to set amp verion on your site.

    ご指摘有難う御座いました。theme Ystandardがどうしていけないのか分かりませんが、themeを変更しなければならないとすれば、どのthemeにすればいいのかも分かりません。私もsearch consoleの設定がうまく有効化していないのではないかと思ってはいましたが、実際どのthemeがいいのかも分かりません。
    theme設定しなおしになるとまた大仕事みたいな感じになります。しかし必要でしたら、やらなければいけないでしょう。許されるならどのthemeを使えばいいのか教えて頂きたいのですが。

    Thank you for pointing out. Excuse me, are you Japanese or American? I do not understand English, so I could understand Japanese. I would like to use Japanese if possible. Is there no problem for me to use Japanese?

    No there is no problem but you can use genesis frameworks in your site. Like foodie pro you can this foodie pro theme template as well as my website whatsapp dp images. This is like a tutorial for you. you can use this template in your site. This template has fast speed and everything as well as Amp version. Amp version setting is not a big problem but its depends on your theme or template. Most of themes can’t set up amp verion therefor in that case we use frameworks instead of using other wordpress themes. Hope your problem will be solve and sorry for my bad english.

    • この返信は2 ヶ月、 2 週間前に  WhatStatus さんが編集しました。
15件の返信を表示中 - 1 - 15件目 (全18件中)
  • このトピックに返信するにはログインが必要です。