サポート » テーマ » AtlantisというテーマでFlash 3D sliderが反映されない

  • 解決済 Teppei222

    (@teppei222)


    お世話になっております。
    Atlantisというテーマを使ってサイトを作っているのですが、トップページのFlash 3D sliderが反映されません。

    実際はこうなるはず→http://jinsonathemes.com/fabs/?themedemo=Atlantis
    製作中のサイト→http://www.chimofan.com/
    テーマ配布サイト→http://www.web2feel.com/atlantis/

    説明にある通り、./wp-content/uploads/の中に900px*300pxの画像を入れて、記事の投稿ページにURLを指定しました。

    何が間違っているのかわからないので、すごく漠然とした質問になっていまいますが、
    わかる方いましたら、よろしくお願いします。

15件の返信を表示中 - 1 - 15件目 (全27件中)
  • モデレーター Takuro Hishikawa

    (@hissy)

    swfobject.jsが読み込まれていないですね。なぜ読み込まれていないのかはよく分かりませんが。

    デモサイトのソースにはありますがchimofan.comには無い
    <script type='text/javascript' src='http://jinsonathemes.com/fabs/wp-includes/js/swfobject.js?ver=2.2'></script>

    swfobject.jsが読み込まれていないですね。

    だとすると、使用しているテーマのヘッダーに<?php wp_head(); ?>がないとか?

    モデレーター Takuro Hishikawa

    (@hissy)

    All in One SEO Packのソースが吐き出されてるので、wp_head()はあるっぽいです。
    functions.phpでアクションフックを消しているとか?

    トピック投稿者 Teppei222

    (@teppei222)

    hissyさん、shokun0803さん、ありがとうございます。

    swfobject.jsが読み込まれていないのが原因なんですね。
    アクションフックとは何でしょうか?
    ググってみたんですが、私にはよくわかりませんでした。。。

    とりあえずfunctions.phpをテーマ配布サイトからダウンロードしなおして上書きしたのですが、変化ありませんでした。

    header.phpでwp_head()を検索したところ、以下の記述はありました。
    <?php
    if ( is_singular() ) wp_enqueue_script( ‘comment-reply’ );
    wp_head(); ?>

    他になにか手掛かりになりそうなことがあれば調べますので、教えていただけると嬉しいです。
    よろしくお願いします。

    トピック投稿者 Teppei222

    (@teppei222)

    FTPソフトで見てみたのですが、そもそもswfobject.jsがどこにもないようです。
    どうしたら良いのでしょうか・・・?

    モデレーター Takuro Hishikawa

    (@hissy)

    swfobject.jsはWordPressに同梱されています。
    テーマのデータをダウンロードして確認してみました。
    header.php 17行目の wp_enqueue_script(‘swfobject’); がswfobject.jsを呼び出している部分です。
    消したりしていませんか?

    トピック投稿者 Teppei222

    (@teppei222)

    hissyさん

    ありがとうございます!
    消した覚えはなかったんですが、見事に消えてました。。。

    修正したところ、swfobject.jsは読み込むようになったようなのですが、動いてくれません。。。

    sliderXML.phpに何かおかしいところがあるのでしょうか?
    http://chimofan.com/wordpress/wp-content/themes/Atlantis/sliderXML.php

    モデレーター Takuro Hishikawa

    (@hissy)

    表から見た感じ、Atlantis User Guideの通りに設定しているのであれば、これ以上はちょっと分かりませんね…。
    配布ページのコメント欄で同じような質問があるかもしれません…。

    あるいは、PHPのパーミッションの問題かもしれません。勘ですが。
    一応、確認されることをおすすめします

    トピック投稿者 Teppei222

    (@teppei222)

    hissyさん

    配布ページ等見ながら頑張ってみます!
    ありがとうございました!

    カテゴリーの選択をしていないのでは?

    トピック投稿者 Teppei222

    (@teppei222)

    orangemintさん

    カテゴリーは選択してるんですよー
    でももしかしたら、パーマリンクの設定に問題があるのかと思い、デフォルトから「月と投稿名」に変更してみましたが、変化なし・・・
    うーむ・・・

    写真をFTPでアップしたのでは?

    トピック投稿者 Teppei222

    (@teppei222)

    orangemintさん

    いえ、ログインページのメディアライブラリからアップしたので、大丈夫だと思いますー

    トピック投稿者 Teppei222

    (@teppei222)

    配布サイトにこんな書き込みがあったのですが、英語がわからず読めません。。。
    なにか重要なことのような気がするのですが、英語がわかる方いましたら教えてください。

    I had the same problem as many here about the slider.
    I noticed the flash component shows, but has “Imaging Loading”.
    How I fixed it.
    Upload the images to /wp-content/upload/ folder.
    WP doesn’t do this for your automatically.
    Also, on the post edit under “Slide image url” just place the image file name “slide-image.jpg”.
    I got to this point after doing the CHMOD777, installing the swfobject plugin and nothing was happening.
    The point is the flash component couldn’t find the images, because even if we select ‘featured image’ or ‘add to post’ it … nothing. Hope this helps.

    トピック投稿者 Teppei222

    (@teppei222)

    Safariでサイトを開いてエラーコンソールを見てみたところ、
    「Failed to load resource: the server responded with a status of 404 (Not Found)」
    /wp-content/uploads/2011/03/◯◯◯.png(スライダーに読み込ませているファイル)
    と、表示されました。
    同じテーマを使用してスライダーが正常に動いている他のサイトでは表示されません。

    これは/wp-content/uploads/2011/03/◯◯◯.pngが見つからないということでしょうか?

15件の返信を表示中 - 1 - 15件目 (全27件中)
  • トピック「AtlantisというテーマでFlash 3D sliderが反映されない」には新たに返信することはできません。