サポート » プラグイン » BackWPup有料になりました?

  • 解決済 berghilo

    (@berghilo)


    BackWPupを最新のバージョン 3.0.2にしたところ、データベースのバックアップが出来なくなりました。
    logには「3 ERRORS」とあり、

    ERROR: No MySQLi extension found. Please install it.

    となっていました。
    メニューのabout欄を見ると
    Features / differences between Free and Pro
    という欄があり、そこにある
    Database backup for additional MySQL databases項目のFree欄は×になっています。

    これってデータベースは有料のProを買わないとバックアップできないと云うことでしょうか。

    どなたか同じ現象になっていますか?

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • BackWPupプラグインは使っていないですが、
    Free版とPro版があって、機能が異なるようですね。
    http://marketpress.com/product/backwpup-pro/

    使いたい機能がPro版にあるのなら、
    Pro版を購入すれば良いと思います。

    ご投稿ありがとうございます。
    バージョンアップしたところ、データベースがバックアップできなくなり、突然に有料になったのかなと思った次第です。
    ご連絡のアドレスはダッシュボードからもリンクされているのですが、
    Complete database backupという項目はFree版とPro版もできるようなのですが、私の設定が間違っているのどうか、不明。
    もう少し、設定画面見てみます。

    こんにちは。
    私もきのう同じタイミングで3.0.2へバージョンアップし、同じく「No MySQLi extension found. Please install it.」エラーが3つ出ました。

    おそらくエラーの表記通りの原因で、お使いのレンタルサーバーにmysqliの拡張モジュールがインストールされていないのが原因だと思います。Free版かPro版かは特に関係ないかと…多分、多分。
    BackWPupがメジャーバージョンアップしたタイミングでデータベースの取得処理にmysqliを使うようになり、サーバーが動作要件を満たさなくなってしまった。という感じではないでしょうか。
    http://wordpress.org/extend/plugins/backwpup/
    > Database Backup (needs mysqli)
     とありますので、DBのバックアップに必須なのでしょう。

    (ちなみに、私はロリポップサーバーを利用しています。この件でロリポップ様にmysqliの導入をリクエストしたところ「今の所予定はありませんが、いただいた要望は今後の対応を検討します」とのことでした。日本のユーザーも多いプラグインでしょうし、対応してもらえるとありがたいですね…)

    開発者の方が読んでくださることを期待して、プラグインレビューにて意見を書きました(開発元公式のフォーラムは有料版購入&登録者しか書き込めないようでしたので)。
    もしかしたら、何かしらリアクションがあるかもしれません。
    http://wordpress.org/support/view/plugin-reviews/backwpup?filter=3

    現時点でできる対応としては
    ・ファイルのみBackWPupでバックアップ、データベースは別の手段で
    ・(セキュリティ上好ましくないが)バージョン2.x代を使い続ける
    あたりかなあと思います。

    Mutsumi Ryockaさん、ご丁寧なお返事ありがとうございます。
    mysqlじゃなくてmysqliだったんですね。
    これがエラーということはこちらの環境でもみ導入だと分かりました。

    ご指摘のように旧バージョンにするか、DBはwp-dbmanagerなどの他のプラグインで対応ということにします。

    ありがとうございました。

    こんばんは。
    「解決済み」になっていますが、一度レスしました手前こちらのスレッドにて報告させてください。

    本日より、ロリポップ様のPHPが5.4対応になりました。
    http://lolipop.jp/info/news/

    先ほど自分のロリポアカウントのPHPバージョンをテスト的に5.4に上げphpinfoしましたところ、5.3の時には表示されていなかった「mysqli」のモジュール情報が表示されるようになりました!

    ならばいけるかも?…と、やっつけですがBackWPupのテストも行いました。
    BackWPupのバージョンは最新の3.0.4、最低限の設定のみ行い「Dropboxにデータベースの全ダンプをzip圧縮して転送」というJobをマニュアル実行しました。結果は成功です。ログを見ても特にエラーの箇所はありませんでした。

    というわけで、ロリポップをご利用の方はPHPのバージョンを5.4に上げると、データベースバックアップが成功するかもしれません。
    ※スケジューリングでの自動実行やファイルも含めたバックアップテストは行っていません。
     また、PHPのバージョンを上げることでWordPressや他のプラグイン等に悪影響が出るおそれもあると思います。
     くれぐれもご自身の責任においてお試しください。

    ちなみに、先日レビューで書いた意見に対して開発者の方から直々にお返事をいただきましたが、MySQLi無しでも動くようにするというのは考えておられないように感じました。
    http://wordpress.org/support/topic/how-do-i-run-backwpup-without-mysqli?
    こちらでも同じような質問がありますが「考えてみます」という感じの反応ではないようなので…
    http://wordpress.org/support/topic/error-no-mysqli-extension-found-please-install-it?

    Mutsumi Ryockaさん、ご連絡ありがとうございます。
    私のサーバー環境でもPHP5.3.6にしたところ、動作しました。

    でも、同じサーバー環境でも動かない場合があり、まだ不安定なんでしょうか。
    最近頻繁にリビジョンアップがありますね。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「BackWPup有料になりました?」には新たに返信することはできません。