サポート » プラグイン » BackWPup 2.1.17で Dropboxへの関連付けをするとエラーが出てしまいます。

  • 解決済 10642

    (@10642-1)


    Headway3.4.11で作ったHPのバックアップを取ろうとしています。

    BackWPup 2.1.17で Dropboxへの関連付けをするとエラーが出てしまいます。
    (BackWPup 3以上だとサーバーの関係でインストールできませんでした。)

    【↓英文】
    Fatal error: Uncaught exception ‘backwpup_DropboxException’ with message ‘(35) error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure’ in /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/libs/dropbox.php:182 Stack trace: #0 /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/pages/header_backwpupeditjob.php(278): backwpup_Dropbox->oAuthAuthorize(‘http://shukatu….’) #1 /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/backwpup-functions.php(67): require_once(‘/export/sd207/w…’) #2 [internal function]: backwpup_menu_page_header(”) #3 /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-includes/plugin.php(406): call_user_func_array(‘backwpup_menu_p in /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/libs/dropbox.php on line 182

    【↓翻訳したもの】
    致命的なエラー:メッセージでキャッチされない例外’backwpup_DropboxException’ ‘(35)エラー:14094410:SSLルーチン:SSL3_READ_BYTES:SSLv3のアラートハンドシェイクに失敗」で/輸出/ sd207 / WWW / JP / R / E / gmoserver / 3月7日/ sd0344837 / shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/libs/dropbox.php:182スタックトレース:#0 /エクスポート/ sd207 / WWW / JP / R / E /gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/pages/header_backwpupeditjob.php(278):backwpup_Dropbox-> oAuthAuthorize( ‘ http:// shukatu …. ‘)#1 /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack- undernavicontrol / WP-コンテンツ/プラグイン/ backwpup / backwpup-のfunctions.php(67):require_onceを( ‘/エクスポート/ sd207 /ワット…’)#2 [内部関数]:backwpup_menu_page_header( ”)#3 /エクスポート/ sd207 / WWW / JP / R / E / gmoserver / 3月7日/ sd0344837 / shukatu.hanamaru-souken.com /ワードプレス-3.5-JA-のjetpack-undernavicontrol / WP-含ま/ plugin.php(406):call_user_func_array( ‘でbackwpup_menu_p /export/sd207/www/jp/r/e/gmoserver/3/7/sd0344837/shukatu.hanamaru-souken.com/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/plugins/backwpup/libs /dropbox.php行に182

    このエラーの意味や、直し方がわからず困っています。
    お分かりのかたいらっしゃいましたら、教えていただけましたら幸いです。

    どうぞよろしくお願い致します。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • プラグインのバージョン3.0以降で Dropbox との通信に関する変更がいくつか行われているので、セキュリティ(脆弱性など)の面からも、WordPress 本体を含めたバージョンアップをお勧めします。

    https://ja.wordpress.org/plugins/backwpup/changelog/

    Version 3.2.4
    Changed: Dropbox API URLs

    Version 3.1.3
    Changed: Dropbox now uses oAuth 2 Protocol
    Changed: Dropbox change to TLS Protocol
    Improved: Dropbox chipper list not on NSS cUrl backend

    Version 3.1.2
    Improved: Dropbox SSL handling

    など・・・

    モデレーター のむらけい (Kei Nomura)

    (@mypacecreator)

    @gblsmさんの回答のとおりですが、補足として

    BackWPup 2.1.17で Dropboxへの関連付けをするとエラーが出てしまいます。
    (BackWPup 3以上だとサーバーの関係でインストールできませんでした。)

    と書いていただいているので、おそらくサーバのPHPが5.2系なのでしょう。
    PHP5.2系だとモジュールの関係とかでSSLでの通信ができないのでBackWPup2系でないと動かないのでしょうが、
    いくらBackWPupプラグイン側がかろうじて動くバージョンのものを使っても、
    肝心のDropbox側が非暗号化通信をブロックするよう仕様変更されていることも考えられるので(Dropboxの仕様書は読んでないので推測ですが)、その場合はどうにもできないです。
    Dropboxではない箇所に同期するか、より新しいバージョンのPHPが使えるサーバに乗り換えが必要です。

    gblsm 様
    mypacecreator 様

    この度は、ご丁寧なご返答誠にありがとうございました。
    やはり、サーバーやWPのバージョンアップは必須なのですね。
    詳しい説明をありがとうございました。

    また、返信が遅れましたことお詫び申し上げます。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「BackWPup 2.1.17で Dropboxへの関連付けをするとエラーが出てしまいます。」には新たに返信することはできません。