サポート » プラグイン » bbpressのtitleタグで「ページが見つかりませんでした」と表示されるページがある

  • 大変お世話になっております。
    WordpressとPHPの勉強に目覚めた初心者です。
    何度もご教示をいただきながら、希望通りのフォーラムページが出来上がってきました。
    本当にありがとうございます。

    今回また教えていただきたいことがございまして、投稿いたしました。
    何度もすみませんがよろしくお願いします。

    発生している問題:
    bbpress内の以下のページを表示させるときだけ、
    Webページのタイトルが「ページが見つかりませんでした」となってしまいます。
    ・プロフィール
    ・開始したフォーラムトピック
    ・フォーラムへの返信
    ・お気に入りフォーラムトピック
    ・購読中のフォーラム
    ・編集
    Webページのソースからtitleを見るとこのようになっています。
    <title>ページが見つかりませんでした – (製品名)テクニカルフォーラム</title>

    環境について:
    Wordpress 4.7.5
    バージョン 2.5.13
    使用テーマ:Twenty Sixteern Child テーマ

    その他必要な情報がありましたら、すぐアップさせていただきますので、
    これは仕様なのか、何か不具合が起きているのか、教えていただけますでしょうか。
    不具合の場合、解決方法についてご教示いただけますでしょうか。

    よろしくお願いいたします。

    • このトピックはsatoumeが6年、 9ヶ月前に変更しました。
9件の返信を表示中 - 1 - 9件目 (全9件中)
  • CG

    (@du-bist-der-lenz)

    チャイルドテーマからではなく、TwentySixteen で行った場合も同様という結果でしょうか。

    トピック投稿者 satoume

    (@satoume)

    CG様
    ご確認くださりありがとうございました。

    先ほどWordPress4.7.5(Twenty Sixteen テーマ)に変更してみました。
    しかし同様の現象が起きました。
    ご面倒をおかけいたしますが、引き続きよろしくお願いいたします。

    こんにちは

    PHP エラーが発生しているのかもしれません。
    下記ページを参考にエラーメッセージを確認してみるといいかなと思います。
    https://wpdocs.osdn.jp/WordPressでのデバッグ

    CG

    (@du-bist-der-lenz)

    WordPressの構造に関わるカスタマイズをしていませんか、コードを変更している場合はプレーンに戻して、bbPress以外のプラグインは停止して確認していますよね。データベースのリライトルールの更新出来ているとは思いますが、bbPressが問題なく設置できているか、親テーマで動作しないというのは疑わしいところです。引き続きテストはしていますが、Twenty Sixteen のチャイルドテーマ「20/16 VCReady」を使用しているわたしのサイトでは同現象がまだ再現できません。

    トピック投稿者 satoume

    (@satoume)

    ishitaka様
    CG様
    何度もご確認ご返信いただき、本当にありがとうございます。

    >ishitaka様
    エラーの確認方法を教えていただきありがとうございました。
    さっそく設定を行ってみました。
    1つだけこちらのエラーが表示されました。
    [30-Aug-2017 04:11:54] PHP Notice: Undefined offset: 1 in /virtual/x.x.x.x/ssl/home/forum/wp-admin/includes/dashboard.php on line 1227
    しかし、その後再現できず、この一度だけでした。
    他のエラーは記録されませんでした。
    すみません、どういうタイミングで発生したのか分かっていません。
    その後はエラーが発生しない状況です。

    >CG様
    他のすべてのプラグインをいったん全て停止して確認するまで考えが及びませんでした。
    ですので、今一度以下の環境で確認してみました。
    1)Twenty Sixteen テーマに変更
    2)bbPress以外のすべてのプラグインを停止
    3)問題のページを表示
    しかし、同様の現象で、改善されていませんでした。

    環境についてもう少し詳細を書かせていただきます。
    当初bbPressのインストールに関し、こちらのWebページを参考にさせていただきました。
    http://rentalhomepage.com/bbs/
    こちらのサイトのテーマは「Twenty twelve」ですが、私の環境の「Twenty Sixteen」にも同じようにフォルダとファイルを配置し、カラム落ち修正の調整を行いました。
    その後、何度かWordpress側のアップデートもあって今に至っています。

    CG様の環境のTwenty Sixteenでは問題ないとのことですので、もう一度、最初から構築してみようとも思っています。

    度々ご教示いただき、本当にありがとうございます。
    引き続きよろしくお願いいたします。

    • この返信は6年、 9ヶ月前にsatoumeが編集しました。
    • この返信は6年、 9ヶ月前にsatoumeが編集しました。
    • この返信は6年、 9ヶ月前にsatoumeが編集しました。理由: IPアドレスを伏せました。
    • この返信は6年、 9ヶ月前にsatoumeが編集しました。理由: 失礼な表現がございました。訂正しました。

    PHP のバージョンはいくつでしょうか?

    今回のケースが該当するかどうかはちょっと分かりませんが、bbPress 提供元のフォーラムの下記トピックによると「bbPress 2.5 系は、PHP 7.0/7.1 で問題がある」とのことです。
    https://bbpress.org/forums/topic/bbpress-2-5-13-doesnt-work/

    2.6 で対応するようなのでリリースを待つか、PHP のバージョンを変更可能であれば変更してみてください。
    あと、あまりお勧めはできませんが 2.6 のリリース候補版やベータ版がダウンロードできるので試してみるのもいいかもしれません。
    https://bbpress.org/download/

    トピック投稿者 satoume

    (@satoume)

    ishitaka様
    大変お世話になっております。
    情報を調べてくださりありがとうございました。
    私の環境のPHPのバージョンは5.1となっていました。
    PHP 7.0/7.1 で問題があるとのことですので、
    PHPは現行の5.1のままで大丈夫ということですね。

    実は先ほど、テスト環境で再構築してみたところ、
    構築の初期段階で今回の現象は起きていないことを確認しました。
    環境について:
    WordPress:4.7.5
    テーマ:Twenty Sixteen
    bbPress:2.5.13

    インストール後、ログインウィジェットを追加して、
    プロフィール画面を確認してみたところ、
    タイトルが「ページが見つかりませんでした」
    という今回の現象は起きず、フォーラム名が正常に表示されています。

    原因は分からないままですが、ひとまずこの環境でもういちど作っていきたいと思います。
    環境を設定するどこかの過程で、原因が分かるかもしれません。

    CG様
    ishitaka様
    今回も貴重なお時間を割いてくださり本当にありがとうございました。
    取り急ぎ、現状の報告のみとなりますが、お礼を申し上げたく、
    返信させていただきました。

    構築の過程で何かわかりましたら、また書かせていいただきますので、
    引き続きよろしくお願いいたします。

    CG

    (@du-bist-der-lenz)

    タイトルが「ページが見つかりませんでした」となっている方と、同じ設定をしてから両方のブラウザ上でのURLを比較しましょう。パーマリンク設定を更新出来ているなら、データベースのリライトルールの更新出来ていると思いますが。

    トピック投稿者 satoume

    (@satoume)

    CG様
    大変お世話になっております。
    何度か返信しようとしましたが、
    どういうわけか「送信」を押しても返信内容をアップできませんでした。

    その後、テスト環境で本番と同じ環境を作りました。
    このテスト環境では、「ページが見つかりませんでした」と
    表示される問題は発生しませんでした。

    そして確認をしていて、次のことが分かりました。
    問題が発生している側のデータベースをテスト環境にインポートすると、
    同様の現象がテスト環境でも発生してしまいました。

    行った作業は以下のとおりです。
    1)問題が発生している側のWordpressのデータベースをバックしました。
    2)問題が発生していないテスト環境のデータベースを削除しました。
    3)1)でバックアップした問題のデータベースをテスト環境にインポートしました。
    4)wp_optionsテーブルのsiteurlとhomeをテスト環境のURLに適宜修正しました。
    5)ログイン後、プロフィール画面を表示すると、同じ現象が起きました。

    これは、データベースに問題があるということでしょうか。
    データベース上を見てみましたが、どこをチェックしたらいいか分かりませんでした。

    どのように確認したらいいか、引き続きご指南いただけますでしょうか。
    よろしくお願いします。

9件の返信を表示中 - 1 - 9件目 (全9件中)
  • トピック「bbpressのtitleタグで「ページが見つかりませんでした」と表示されるページがある」には新たに返信することはできません。