サポート » 使い方全般 » class-phpmailer.phpのバージョンアップとは

  • 解決済 suzukitoro

    (@suzukitoro)


    会社の上司から、私用の頼み事をうけました。
    とあるWPサイトの
    class-phpmailer.phpのバージョンアップをしてほしいと。
    メールに関するphpファイルのようですが、私自身よくわかっていません。

    すくなくとも、そのサイトのWPのバージョンが「 4.4.1 」でしたので、WPを最新のバージョンにあげるだけで
    、class-phpmailer.phpも最新になるような気がしますが、
    なんらの確証もありません。

    そこで、WPのバージョンを上げることで、「class-phpmailer.php」が最新になるのか、
    他の方法しかないのか?

    お分かりになるかた、お教えください。

    • このトピックはsuzukitoroが2年、 2ヶ月前に変更しました。
5件の返信を表示中 - 1 - 5件目 (全5件中)
  • こんにちは

    WordPress を最新版にすれば、class-phpmailer.php も WordPress に含まれているものの中では最新版になります。

    class-phpmailer.php (PHPMailer) のバージョンは、
    WordPress 4.4.1は5.2.14、
    WordPress 5.4.2は5.2.27
    です。

    ちなみに、次のメジャーリリース5.5 (来月リリース予定) は6.x (5.5 Beta 2は6.1.6) です。

    トピック投稿者 suzukitoro

    (@suzukitoro)

    お二人ともありがとうございます。
    5.2.14 と 5.2.27 では、そう違いが小さいようですね。

    個別にバージョンを上げるというのは、
    class-phpmailer.php
    を拾ってきて、FTPにて/wp-includes/
    に上げるだけではないですよね。
    やはり、設定的な何かが必要でしょうか?

    単純にファイルを置き換えるだけではできません。それなりの作業が必要です。
    こちらのチケットが参考になると思います。

    トピック投稿者 suzukitoro

    (@suzukitoro)

    有意義な情報ありがとうございました。
    WPを更新することで対応いたします。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「class-phpmailer.phpのバージョンアップとは」には新たに返信することはできません。