• uc0448

    (@uc0448)


    上記サイトで、複数あるCSSが一度に読み込まれず正常に表示されません。ソースコードを見ながら再読込をしたところ、飲み込まれていないCSSが赤文字で表示されていましたが10回目ですべてのCSSの読み込まれ正常な表示になりました。

    メディアに登録している画像が破損したのか表示できないものが多数発生しました。破損のようなサムネイルのみの表示になっているものが多数発生しています。

    • このトピックはuc0448が1年前に変更しました。
10件の返信を表示中 - 1 - 10件目 (全10件中)
  • shokun0803

    (@shokun0803)

    @uc0448 さん、こんにちは。

    上記サイトで

    どちらのサイトでしょう? URL をご提示頂けると良いかもしれません。

    複数あるCSSが一度に読み込まれず正常に表示されません。

    複数ある CSS とは、example.com/a.cssexample.com/b.cssなど複数ファイルに分かれている CSS がすべて読み込まれないという認識であっておりますか?

    メディアに登録している画像が破損したのか表示できないものが多数発生しました。破損のようなサムネイルのみの表示になっているものが多数発生しています。

    CSS でbackground: url(a.jpg)などと記載した画像が読み込まれないという認識で合ってますか?

    もう少し詳細を提示頂けると回答が付きやすいと思います。

    ご参考になれば。

    トピック投稿者 uc0448

    (@uc0448)

    shokun0803さん、お返事ありがとうございます。

    URL下記になります。

    http://artten.extrem.ne.jp/tanome/

    ソースコードを見ながら表示すると、読み込まれていないCSSが多く、10回ほど再読み込みすると、全部読み込まれるようです。

    画像に関してですが、ダッシュボード内のメディアに収納されていた画像が、ファイル破損のようなサムネイルになってしまったものが多く、表示できない状態に、ある時点でなってしまいました。おそらく、読み込まれてはいるが、ファイルが破損している状態だったと思われます。操作はしていませんが、ある時点で、画像ファイルが破損したという印象です。画像を入れすぎたのでしょか?ファイル破損を招いた原因を知りたいです。CSSの不調を解消してから、画像ファイルは再構築したいと思っています。

    上記2つの障害は同時に起きた印象です。改善策を教えていただくと助かります。よろしくお願いします。




    見てみました。

    Safariのコンソールで見ると、読み込まれていないCSSが読み込まれていない理由が「Failed to load resource: the server responded with a status of 503 (Service Temporarily Unavailable)」となっています。

    つまり、サーバに障害が発生している可能性が大です。Webサーバのログを確認してみてください。

    それと気になった点ですが、「Blocked a frame with origin “http://artten.extrem.ne.jp” from accessing a frame with origin “https://www.youtube.com”. The frame requesting access has a protocol of “http”, the frame being accessed has a protocol of “https”. Protocols must match.」という警告も出てました。今時ですから、https化はした方がいいですよ、必須レベルで。

    それと、画面の大きなパソコンで見たんですが、最初の動画みてたら船酔い状態になって気持ち悪くなってしまいました。まあ最後のは個人の感想なので無視していただいてけっこうです。(^^;)

    • この返信は11ヶ月、 2週前にmokkosanが編集しました。
    トピック投稿者 uc0448

    (@uc0448)

    mokkosanさんありがとうございます。
    サーバ障害の可能性も考慮していましたが、色濃くなってきました。

    「https」の独自ドメインを取得して、サーバを変えるのが解決の近道のようです。

    • この返信は11ヶ月、 2週前にuc0448が編集しました。

    uc0448さん、こんにちは。

    提示されたサイトの URL からおそらく「エクストリム」レンタルサーバーをご利用かと思いますが、 SSL の部分に関しては全プランで共有 SSL の提供があるようですよ。管理画面等にて確認されてみてはいかがでしょうか。

    もしかしたら外部からの SSL 読み込み等が非 SSL 環境によるアクセス拒否の可能性があるならばいくらかは解決するかもしれません。おそらくそれだけで解決するとは思えませんが(サーバーが非常に重そう…)、やれることから実施されてみることをお勧めいたします。

    ご参考になれば。

    こんにちは

    キャッシュプラグインなどをご利用なら、そのプラグインを削除してみてください。

    トピック投稿者 uc0448

    (@uc0448)

    munyaguさん

    ありがとうございます。試してみます。

    shokun0803さん

    ありがとうございます。試してみます。

    • この返信は11ヶ月、 2週前にuc0448が編集しました。
    トピック投稿者 uc0448

    (@uc0448)

    ワードプレスのダッシュボードで、PHPの7.4を推奨していますが、エクストリームサーバで、5.6(モジュール版)から7.4(CGI版)に変更すると、サイトが表示されなくなります。

    uc0448さん、こんにちは。

    可能性として使用しているプラグインやテーマの中で PHP 7 系に対応していない物がある可能性があります。

    すべてのプラグインを停止、テーマをデフォルトに設定してから PHP のバージョンを変更されてみてはいかがでしょうか。

    その状態(素の WordPress )で表示されるならばサーバーや WordPress の問題ではないので、テーマを元に戻してみたりプラグインをひとつずつ有効化して状況を確認します。表示されないならばサーバーの用意されている CGI 版 PHP 7 系統に WordPress が動作しない何かがあるのかもしれません。その場合はサーバー屋さんに問い合わせてみてください。

    ご参考になれば。

    トピック投稿者 uc0448

    (@uc0448)

    shokun0803さん

    ありがとうございます。試してみます。
    エクストリムサーバに問い合わせてみます。

    • この返信は11ヶ月、 2週前にuc0448が編集しました。
10件の返信を表示中 - 1 - 10件目 (全10件中)
  • トピック「CSSが一度に読み込まれない。」には新たに返信することはできません。