サポート » インストール » DOM拡張モジュールのインストールについて

  • johnnybrian

    (@johnnybrian)


    初めまして。
    初歩的なことかと思われるのですが、書かせていただきました。

    WordPressによるサイトを運営しており、この度、AMP対応をすることになりました。
    プラグインによる対応を行い、下記プラグインをインストールしました。
    AMP
    Yoast SEO
    Glue for Yoast SEO & AMP

    各種SEOのためのプラグイン競合エラー等も対応し、対応の一歩手前まできているかと思うのですが、
    下記エラーが、ダッシュボード上部に表示されております。

    AMP plugin unable to initialize.
    The following PHP extension is missing: dom. Please contact your host to finish installation.

    インターネットで調べたところ、https://blog.hashihei.com/2018/12/01/wordpress%E3%82%92%E7%B0%A1%E5%8D%98%E3%81%ABamp%E5%AF%BE%E5%BF%9C%E3%82%B5%E3%82%A4%E3%83%88%E3%81%AB%E3%81%99%E3%82%8B%E3%80%82/
    のページの、手順2-2や2-3のコードを使用するのではないかまでは突き止めましたが、そのコードをどこに入れれば良いかが分からない状況です。

    もし、ご存知の方がおりました、ご教授いただけますと、助かります。

    使用しているものは、
    WordPress 5.2.2 (habakiriテーマ)
    各プラグインは更新済みの状態です。

    何卒、よろしくお願い申し上げます。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • npssl

    (@npssl)

    どのようなサーバーを利用されていますか?

    PHP extensionはサーバーの管理者権限が無いとインストールできません。
    WordPressの管理者であってもインストールできません。

    インストールの方法については、サーバーOS(CentOSとかUbuntuとか)のフォーラムで尋ねてください。
    サーバーOSによってインストールコマンドが異なりますし、使用しているPHPのバージョンによってもインストールするモジュールの名前が異なります。

    johnnybrian

    (@johnnybrian)

    ご返信ありがとうございます。

    ちょうど、お仕事でお手伝いし始めたところでしたので、どのサーバーを使用しているかの把握がまだでした。

    承知いたしました。
    サーバーOSのフォーラムで尋ねてみます。

    どのサーバー、サーバーOS、そしてphpのバージョンを確認いたします。

    ありがとうございます。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「DOM拡張モジュールのインストールについて」には新たに返信することはできません。