サポート » プラグイン » Elementor 無料ver. でのエラーについて

  • 解決済 oszsan

    (@oszsan)


    こんにちは、
    
    Elementor 無料バージョン使用です。
    
    
    Elementorで作った固定ページを「表示設定」→「ホームページ」に設定後、「サイトを表示」すると、エラーになります。
    
    ① ソース確認で、2個のCSSについて、
    
    「リソースを読み込み中にエラーが起きました。」のエラー
    
    
    
    Failed to load resource: the server responded with a status of 404 ()
    
    と、
    
    ファイルのURL
    
    が表示されている。
    
    しかし、このURLフォルダとファイルは存在しません。
    
    
    
    
    ②
    
    Wordpress の全体設定で、メディア画像の保存先(アップロード先)を変更後にこの現象が起きます。
    
    デフォルトに戻すと、このエラーは起きません。
    
    =======================
    
    Wordpress URL
    
    https://www.●●●.com/△△△
    
    変更後のメディア画像フォルダ
    
    https://www.●●●.com/■■/aaa
    
    =======================
    
    読み込みエラーのcssファイルURLが、この変更後のメディア画像保存先フォルダの中になっている。
    
    =======================
    
    https://www.●●●.com/■■/aaa/elementor/css/post-6.css?ver=1*******6
    
    =======================
    
    しかし、変更後のメディア画像フォルダ下に、ここで指定されているフォルダもファイルも存在しない。
    
    
    
    
    ③
    
    メディア画像の保存先(アップロード先)変更が原因で、このエラーと考えていますが、どなたか解決策を教えてくださいませんか。
    
    よろしくお願いいたします。
6件の返信を表示中 - 1 - 6件目 (全6件中)
  • こんにちは

    Elementor create the CSS file only once unless you update and there is regenerated for the updates to apply.

    https://github.com/elementor/elementor/issues/7237

    とありますので、投稿を更新したら再作成されるんじゃないでしょうか。

    私は試したことがないですが・・・

    • この返信は1年、 2ヶ月前にmunyaguが編集しました。
    トピック投稿者 oszsan

    (@oszsan)

    @munyagu さん、

    返信ありがとうございます。

    投稿を更新しても無理でした。

    新規投稿、投稿の複製、更新、すべて無理でした。

    プラグイン、テーマの再インストールも無理でした。

     

    キャッシュ関連も全て行いましたが無理でした。

    トピック投稿者 oszsan

    (@oszsan)

    理由がわからないのですが、解決になったのでクローズします。
    
    
    
    今回、最初にアップロード先の変更を行った手順は、
    
    ① 管理画面「options.php」
    
    での変更
    
    
    この方法で何度も様々な事を試しましたが無理でした。
    
    
    次に
    
    ② プラグイン 「WP Original Media Path
    
    でも、同様に無理でした。
    
    
    
    どちらも、変更は出来ましたが、エラーが発生する状況。
    
    パスの確認は何度も繰り返し、ワードプレスの再インストール(データベースも新しくして)後に、再設定しても同じ現象が起きていました。
    
    
    
    
    
    最後に、ダメもとで、
    
    ③「wp-config.php」にアップロードパスを追記する方法を行いましたら、この方法で解決されたようです。
    
    エラーメッセージの指定先フォルダとファイルもつくられました。
    
    おそらく、これで大丈夫かと思います。
    
    
    
    
    アップロード先フォルダの変更方法として、
    
    ① 管理画面「options.php」での変更
    
    ② プラグイン 「WP Original Media Path
    
    ③「wp-config.php」にアップロードパスを追記する方法
    
    
    のどれでも可能と見ていたので、最初の二つを行ったのですが、私には「wp-config.php」への追記しか効果がありませんでした。
    
    ご参考まで。
    
    ありがとうございました。

    では、先ほどの引用元にもある、を試すことぐらいしかご提案できないです。

    wp elementor flush_css

    参考:https://developers.elementor.com/docs/cli/flush-css/

    oszsanさん、こんにちは。

    解決済みになっているので解決されている感じですかね…

    WordPress の全体設定で、メディア画像の保存先(アップロード先)を変更後にこの現象が起きます。

    んー、 WordPress のデフォルトでそんな設定ありましたか?もしかして upload_path 等の設定変更を行っています?

    まさかとは思いますが、一般設定の「WordPress アドレス (URL)」を変更しているとかではないですよね…?

    Elementor にもメディアの保存先を変更するような機能があるようには見えませんが(未確認)。

    まずはその辺りをきちんと確認されることをお勧めいたします。

    ご参考になれば。

    トピック投稿者 oszsan

    (@oszsan)

    @munyagu さん、

    ご親切にありがとうございます。

    wp-config.phpにアップロードパスを追記する方法で、今のところエラーなく動いていますので、再度エラーが出た時にご提案いただいた事を試してみます。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「Elementor 無料ver. でのエラーについて」には新たに返信することはできません。