サポート » プラグイン » Fatal errorが発生して、管理画面サイトが表示されません。

  • Fatal error: Can’t inherit abstract function N2FormElementContainer::getForm() (previously declared abstract in N2FormTabContainer) in /www/a-mail/myglobalryugaku.jp/public_html/wordpress/wp-content/plugins/smart-slider-3/nextend/library/libraries/form/tab.php on line 7

    という画面画面が出て、その先が進めません。このようなエラーは初めてで初心者なのでどうしたらいいのか?

    方法などありますでしょうか?

    ヘルプの必要なページ: [リンクを見るにはログイン]

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • CG

    (@du-bist-der-lenz)

    対照のプラグインを停止したら、変化ありませんか。PHPのバージョンはいくつですか。同じことをさせるための命令で、異なることを命令しているから起こるエラーです。

    ありがとうございます。

    管理画面自体に入れないのですが、どうしたらいいのでしょうか?

    モデレーター Okamoto Hidetaka

    (@hideokamoto)

    FTP / SFTP / SSHなどで問題の出ているプラグインファイルをwp-content/plugins配下「以外」に一度移動させましょう。

    こんにちは

    phpのバージョンを5.3.9以降に変更できるのであれば、変更してください。
    しかし、アルファメールをお使いかと思いますが、アルファメールでは変更できないように思います。
    サポートや営業の方に確認してみてください。

    phpのバージョンを変更できない場合、プラグインを無効にするため、エラーメッセージに表示されているディレクトリ名、「smart-slider-3」を、FTPやファイルマネージャを利用して、なんでもいいので別の名前に変更してください。
    例)「_smart-slider-3」

    プラグインに必要なphpのバージョンが5.4ですね。

    https://ja.wordpress.org/plugins/smart-slider-3/

    munyaguさん

    さくらインターネットを使用していまして、PHPのバージョンは変更可能です。

    バージョンを5.3.9以降というのは例えば、最新のphp7に変更ということでしょうか?

    ああすいません。
    さくらでしたか。

    とりあえず、5.4にして正しく動作するか確認しましょうか。
    7にすると他のプラグインなどで動作しない可能性がありますので、5.4で確認した後、7に変更してみてください。
    7で動作したら、そのまま7で運用すれば良いと思います。

    現在バージョンは5.4です。
    一つ上のバージョンは5.6ですが、こちらにあげてもいいのでしょうか?
    バージョンアップ以外の名前の変更をしましたが変わりませんでした。

    バージョンを5.6に変更しましたが、できません。

    PHP のバージョンは 5.3.2 (X-Powered-By によると)のままのようです。
    対象のサーバは、さくらインターネットで合っていますか?

    はい!さくらインターネットです。

    再度調べてみましたが、http://myglobalryugaku.jp/があるのはさくらではなく、アルファメールです。
    アルファメールを契約していたことはないのでしょうか?

    ディレクトリ名にもa-mailと入っており、私は使ったことがないですが、これはアルファメールのサーバのディレクトリ名のように思います。

    さくらだとお思いなのであれば、サイトのURLと共にエラーが出るとさくらインターネットに問い合わせしてみてはどうでしょうか?

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • このトピックに返信するにはログインが必要です。