サポート » 使い方全般 » httpsからhttpに戻すには

  • 解決済 WP_manabu

    (@wp_manabu)


    おせわになっております。

    事情により、ウェッブサイトを、一時的にhttpsからhttpに戻す必要がありまして。

    トップページだけは(.htaccessファイル内の、httpからhttpsにリダイアルさせる際に記述した、かつてのコードを削除して)なんとか、httpのページを表示させることが出来ました。

    ちなみに、削除したコードは以下の通りとなります。

    `<IfModule mod_rewrite.c> RewriteEngine on RewriteCond %{ENV:HTTPS} !on RewriteCond %{REQUEST_URI} !^/wp-cron.php$ RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L] </IfModule>

    一方、その他のページはhttpに戻すことは出来ず、
    またWordPressのダッシュボードにログインする際のページも戻っておらず、そちらからの作業が出来ない状況になっております。

    これは推測ですが、ダッシュボード > 設定>一般設定のフォーム内のURLの記述が、httpsになっていることが原因かな、と思ったりもしております。

    質問は、もし上記のことが原因なら、それが記述されているファイル名を知りたい、ということです。当方、さくらのレンタルサーバを利用していまして。同社で用意されたコントロールパネルから、ファイルの記述を変更することなら可能であります。

    また、推測が的外れの場合、どのような手順を踏めばよいのか、ご教示いただければと存じます。

    なお、一時的にhttpsからhttpに変更こする理由、こちらに質問させて頂くまでの経緯は、teratailへの質問投稿/応答にて、ご覧になれます。途中からの、こちらへの質問になってしまい、失礼します。どうぞ、よろしお願いいたします。

    https://teratail.com/questions/250977

    • このトピックはWP_manabuが4ヶ月、 1週前に変更しました。

    ヘルプの必要なページ: [リンクを見るにはログイン]

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • こんばんは
    wp-config.php
    で設定されているのではないでしょうか?

    ご回答、ありがとうございます。
    wp-config.phpのファイルを見てみました。
    ぼくも、そう思ったりもしていたのですけれど、httpsの記述が見当たらないのです汗

    サーバー(さくら)側の基本的な、どこかの設定かな、とも思い始めておりまして。
    その際は、こちらのフォーラムの範疇からから外れてしまい、すみません。

    状況把握できておらず失礼しました。

    設定自体は、データベース(MySQL)に保存されていると思います。

    wp-config.php に記述することで、設定を上書きすることができると思います。

    すみません、URLが展開されてしまい、意図したリンクを提示できませんでした。
    スライドの、17ページ目と、18ページ目を、ご参考になればと思い提示させていただきました。

    原因が分かりました。たぶん…

    config.phpの中に通常は、httpsのURLが書き込まれているのですが、
    セキュアにするため、「秘密鍵サービス」にて、通常では分からない文字列に変換していたかもです。

    config.phpの中に以下のような記述を見つけました。

    >それぞれを異なるユニーク (一意) な文字列に変更してください。
    > * 秘密鍵サービス} で>自動生成することもできます。
    > * 後でいつでも変更して、既存のすべての cookie を無効にできます。これにより、すべてのユーザーを強制的に >再ログインさせることになります。

    しかし、これを元の状態に戻すには、どうしたら良いのでしょう汗)

    • この返信は4ヶ月、 1週前にWP_manabuが編集しました。

    word pressのチュートリアルをチェックすると、
    https://wpdocs.osdn.jp/%E3%82%B5%E3%82%A4%E3%83%88_URL_%E3%81%AE%E5%A4%89%E6%9B%B4
    wp-config.php ファイルの中に、以下の記述があるようなのですが、当方のwp-config.phpの中には、それが見当たらないのです汗)

    define(‘WP_HOME’,’http://example.com&#8217;);
    define(‘WP_SITEURL’,’http://example.com&#8217;);

    こんにちは

    wp-config.php のことは一旦おいておいて、さくらのレンタルサーバーを使っていて、https にしたときにさくらが提供している SAKURA RS WP SSL プラグインを使って SSL 化していたのではなかったでしょうか。

    FTP でアクセスし、wp-content/plugin ディレクトリの中にある、このプラグインのディレクトリ名を変更するなどしてみて下さい。

    ご回答ありがとうございます。
    SAKURA RS WP SSL の名前を変更してみました。が…やはり、うまく行きませんでした。

    たしか…当プラグインを使ってみたものの、まだ、できたての状態にて、うまく機能しないため、チェックを外し..その代わりに、htaccessファイルの中に、質問で記載しましたコードを記述した、と記憶しております。

    不明な点が2つあります。

    1).htaccessで記述していたコードを削除し、リダイレクトを解除した結果、トップページはhttpにて表示されますが(ただし、ヘッダーの画像は表示されません)、その他のページはhttpsとなり、表示することが出来ません。ダッシュボードを操作するためのログイン画面も、やはり表示されません。

    2)ダッシュボード > 設定 >一般の「wordpressアドレス(URL)」 「サイトアドレス(URL)」がhttps〜になっていて、それを http〜に変更すれば解消されるかな、とも思っているのですが、現状、肝心のログイン画面を開くことが出来ません。なのでcongif.phpのどこかに、それに対応する箇所はないのかということで、足踏みしております。

    言葉足らずにて失礼しました。

    現在、wp-config.php に WP_HOME と WP_SITEURL の定義は記載されていない状況とお見受けいたしますが、wp-config.php に WP_HOME と WP_SITEURL の定義を追記することにより、設定を上書きすることができ、これにより、ダッシュボードがとりあえず表示できる状態にできるのではないかと思います。

    ダッシュボード > 設定 >一般の「wordpressアドレス(URL)」 「サイトアドレス(URL)」 の設定は、データベースの options のテーブルに書かれているので、それを直接編集すれば、変更することができるかと思います。

    お手数をおかけしております。ありがとうございます。

    wp-config.php での記述、あると思っていたものが、なかったり、だんだんビビって来ましたー。
    なんか、そそうをすると、いけないので、明日の朝、クリアなアタマで、アドバイス通りやってみたいと存じます。
    また、ご報告しますね〜

    h84mさま

    おはようございます。できましたー。ありがとうございます〜

    同じトラブルの方参照用として、手順をまとめておきます。

    1)config.phpファイルの中に以下の記載をする。
    define(‘WP_HOME’,’サイトのURL’ );
    define(‘WP_SITEURL’,’サイトのURL’);

    2)これにより、ログイン画面が表示されるようになる。
    ダッシュボード > 設定 > 一般
    その中の「サイトアドレス (URL)」のhttpsのsを削除し、httpとする。
    一方の「WordPress アドレス (URL)」は、既存の記載がhttpになっていたので、問題なし。

    3) 1)の記述を削除する。

    注) 1)の記述は、最初、ファイルの一番「最後」に記述したが、うまく反映されなかった。「最初」に記述し、うまく行った。

    以上

    • この返信は4ヶ月、 1週前にWP_manabuが編集しました。
    • この返信は4ヶ月、 1週前にWP_manabuが編集しました。
12件の返信を表示中 - 1 - 12件目 (全12件中)
  • このトピックに返信するにはログインが必要です。