サポート » プラグイン » jetpackの機能を利用した場合のサイトマップが表示されない

  • 解決済 ytgrsua4

    (@ytgrsua4)


    お世話になります。

    Google Search Consoleにて5月4日付けでサイトマップにエラーが出ていたため、アクセスして確認してみたところ

    「サイトマップが見つかりません。現在生成中の可能性もあります。後でもう一度お試しください。」

    と表示されました。

    サイトマップはjetpackの機能を利用しています。

    jetpackを最新のバージョン(4.9)にアップデートしてみましたが、現象は変わりませんでした。

    試しにテスト環境(WordPress 4.7.3、jetpack 4.7)で確認してみたところサイトマップは正常に生成されていました。

    テスト環境を本番環境と同じWordpress 4.7.4、jetpack 4.9にしてみましたが現象は発生しませんでした。

    同様の現象に遭遇された方は居ませんでしょうか?

    よろしくお願いします。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • いつのアップデートか忘れましたが、Jetpackのサイトマップの仕様?が変わったみたいで、
    わたしも同じようにエラーが出ていました。

    しょうが無いので、そのまま同じサイトマップを登録しなおしたら、
    しばらくして処理されるようになっていました。

    なので、もう一度登録されてはどうですか。

    CG

    (@du-bist-der-lenz)

    4月4日の4.8への更新の時に、見直されているようです。

    「Sitemaps are faster and now support sites with a very large amount of posts.」

    https://wordpress.org/plugins/jetpack/#developers

    ioxrxogiさん、CGさん

    回答ありがとうございます。
    既存のサイトマップを登録したままにしてみましたが、約3日経った今も状況は変わりませんでした。

    ちょっと気になったのですが、

    >既存のサイトマップを登録したまま

    登録し直してみてはどうでしょうか。
    (なんというか、リセットする?)

    CG

    (@du-bist-der-lenz)

    ドメイン/sitemap.xml
    ドメイン/news-sitemap.xml
    で、サイトマップが開きますか。開いても、記事がリストされていますか。

    > ioxrxogiさん
    この現象に気づいた際に一度機能をオフにして再度オンにしてみましたが変わりませんでした。

    > CGさん
    ドメイン/sitemap.xmlは
    「サイトマップが見つかりません。現在生成中の可能性もあります。後でもう一度お試しください。」
    が表示されます。
    ドメイン/news-sitemap.xmlは最新の記事が1つだけのxmlが生成されています。

    > ioxrxogiさん
    「登録し直してみてはどうでしょうか。」
    というのがGoogle Search Console上でサイトマップを送信し直すという意味でしたら、試してみましたが昨日付けで再度エラーが表示されていました。

    そうですか。

    わたしの場合、sitemap.xml をGoogle Search Console上で送信しなおした後に、

    しばらくして、sitemap.xml が登録できて、
    それをクリックすると、
    image-sitemap-1.xml
    sitemap-1.xml
    のふたつが登録されていました。

    CG

    (@du-bist-der-lenz)

    ドメイン/sitemap.xmlでサイトマップがセットされていないということでしょう。
    Jetpackプラグインでサイトマップが有効になっているか確認。結論、本番環境が異常だと推測します。

    > ioxrxogiさん、CGさん

    色々と助言頂きありがとうございました。
    先程テスト環境を覗いたところ、本番環境同様にドメイン/sitemap.xmlで
    「サイトマップが見つかりません。現在生成中の可能性もあります。後でもう一度お試しください。」
    のエラーが表示される状態になっておりました。
    そのため、jetpackのバージョンを4.7.1(4.8.2では現象が改善しなかった)までバージョンダウンしたところ、サイトマップが正常に生成されるようになりました。
    Jetpack 4.8以上がいけないのか、Wordpress 4.7.4がJetpack 4.8以上と相性が悪いのか・・・
    原因は分かりませんが現象は改善しましたので解決とさせていただきます。
    ありがとうございました。

    • この返信は2年、 9ヶ月前にytgrsua4が編集しました。
10件の返信を表示中 - 1 - 10件目 (全10件中)
  • トピック「jetpackの機能を利用した場合のサイトマップが表示されない」には新たに返信することはできません。