サポート » プラグイン » Jetpack for WordPress.comと連携ができません。

  • こんにちは、初めまして。
    表題の件の症状が改善されず、ご助言を頂きたくて投稿させていただきました。

    具体的には、
    WP管理画面から、「Jetpackと連携」ボタンを押すと、
    —————————————–
    エラー詳細: The Jetpack server was unable to communicate with your site [HTTP 403]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/
    ——————————————
    というエラーが表示され、連携ができません。

    色々試してみましたが、改善されませんでした。
    なお、下記が試してみたことです。

    ・Jetpackをいったん削除し、再度インストール
    ・プラグイン「SiteGuard WP Plugin」を一旦停止してから、連携をこころみる
    ・ロリポップの該当ドメインのWAF機能を無効に設定

    なお、環境としては、
    サーバー:ロリポップ
    WordPressバージョン:4.6.1–ja
    使用テーマ:WpTHK Child Themeバージョン: 3.01
    WordPress.comのアカウントは、別のプラグイン(Akismet)をインストールする際に
    作成済みです。
    このJetpackに関しては今まで連携したことはなく、今回が初めての連携となります。

    です。

    どうか、よろしくお願いいたします。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • モデレーター Daisuke Takahashi

    (@extendwings)

    https://jetpack.com/support/debug/ に当該のサイトURLを入力してみてください。
    その際、テーマをデフォルトテーマに戻すことも試してみてください。

    Daisuke Takahashiさま
    お返事ありがとうございます。

    ご指定のURLにサイトURLを入力したところ、以下のようなエラーメッセージが出てきました。
    なお、テーマをデフォルトテーマ(Twenty Sixteenバージョン: 1.3)に戻しても同じ結果でした。
    ——————————————-
    XML-RPC is not responding correctly ( 403 )
    It looks like XML-RPC is not responding correctly. Please make sure XML-RPC is turned on for your site and is set up to respond to all content types. You can test this yourself by running the following command from the command line:

    curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ http://bodoge-note.com/xmlrpc.php

    The answer should be:

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <methodResponse>
    <params>
    <param>
    <value>
    <string>Hello!</string>
    </value>
    </param>
    </params>
    </methodResponse>
    If you continue to get this error, please check out our troubleshooting guide or contact support.
    ——————————————–

    よろしくお願いいたします。

    お役にたてるかどうか不安ですが、同じ現象でしばらく悩んでいた者です。

    私の場合、以下の変更で解決しました。

    php.ini で以下の2項目を書き換えました。

    include_path = <– ココヘ pear へのパスを追加

    always_populate_raw_post_data = -1 <– コメントになっていたのを有効化

    どちらが実際に有効だったのかはわかりませんが、これで解決しました。
    二つ目の設定は php-7 では設定自体がなくなっています。 php-5.6 の場合には、これを有効化して解決しました。
    たまたま2種類のサーバーをつかっていて、 php-5.6 php-7 での挙動の違いから見つけたのですが、もしもphpがphp-7 でないのなら、お試しください。

    kirari4612さま
    お返事が大変遅くなってしまい申し訳ありません。
    ご教授いただきありがとうございます。

    教えていただいた方法で試そうと思ったのですが、
    当方で使用しているサーバーが、ロリポップである関係上、
    php.iniの中でも、設定できる項目が書きに限定されているようです。
    https://lolipop.jp/manual/user/php-setting/#p-php-ini

    ————————————-

    なお、先日URLを調べたときのエラーメッセージから、
    XML-RPCに対するアクセス制限をどうにかすれば、という記事をネットで見つけましたので
    それにならって、下記のような記述を、「.htaccess」に足してみました。
    ==============
    <Files ~“xmlrpc.php$”>
    Allow from jetpack.wordpress.com
    Deny from all
    </Files>
    =============
    でもうまくいかなかったです。
    他に方法が何かありましたら、よろしくお願いいたします。

    <Files ~ “xmlrpc.php$”>
    Allow from 192.0.64.0/18
    Deny from all
    </Files>

    ならどうでしょうか。192.0.64.0/18 は Automattic(JetPack提供元)のIPアドレス群です。

    モデレーター Naoko Takano

    (@nao)

    プラグイン開発会社 Automattic の者です。

    もしかしてすでにご覧いただいているかもしれませんが、以前こちらのようなケースがありました。

    ロリポップにおけるJetpackの色々なエラーはWAFの仕業ではなくなった!?

    WordPress.com 側で共用サーバーの一定の IP アドレスをブロックしている場合、上記と同様に「ロリポップ様担当者の方にブロックの元となった問題サイトに警告をしていただき、ブロックの解除」を行う必要があります。

    サイト URL をお知らせいただいた上で調査が必要ですので、お手数ですが、http://jetpack.me/contact からご連絡頂けますと幸いです(英語で返信が来る場合がありますのでご了承ください)。また不明なことがありましたらお知らせください。よろしくお願いします。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「Jetpack for WordPress.comと連携ができません。」には新たに返信することはできません。