• 解決済 hokutonojikei

    (@hokutonojikei)


    jQueryを使用する際、$をjQueryと置き換えて使用することが前提だと思いますが
    パッケージ(例えばdeck.jsなど)を使用する際は使用する全てのjsファイル内の
    $を置き換えなければ動作しないのでしょうか?

    これを回避する(置き換えなくても動作させる)プラグインなどありましたら
    教えていただきたいです。

    また最新のwordpressでも置き換えは必須なのでしょうか。

    よろしくお願いします。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • モデレーター gatespace

    (@gatespace)

    WordPressに同報されているjQueryはオリジナルと異なり
    他のライブラリ(prototype.jsなど)と同時に利用されても大丈夫なように
    noConflict が付いています。
    これが 自分で用意したjQueryで $ を(そのままでは)使えない理由です。

    最新版でも、というかWordPressのプラグインなどで他のライブラリが使われる可能性がある以上、同報されているjQueryはバージョンが上がっても noConflict の処理が入ると思います。

    回避策ですが、
    自分で用意した jQuery のスクリプト(プラグイン)のみを使用されるのであれば、
    WordPressに同報されたjQueryではなく、外部APIなどのjQueryを読み込むようにしても良いかと思います。

    http://dogmap.jp/2011/07/02/wordpress-dequeu-jquery/

    ただし、この方法をとるとWordPressのプラグインなどでjQueryを使っているとそちらが動かなく可能性があります。

    そうではなくプラグインなどの利用も考え、WordPress同胞のjQueryを使うのであれば、
    自分で用意した jQuery のスクリプト(プラグイン)を書き換えてください。
    (jQueryのプラグインも寄りますが、他のライブラリとの併用を考えられている物であれば、不要かと思いますが)

    http://kachibito.net/web-design/wordpress-with-jquery.html

    トピック投稿者 hokutonojikei

    (@hokutonojikei)

    gatespaceさん、返信が遅れ申し訳ありません。

    ご回答ありがとうございました。
    jQueryを使うとき$を書き換えるというのはわかっていましたが
    noConflictが指定されているとか、具体的なところがまだまだ
    理解が浅かったので参考になりました。

    結局プラグインや、wordpress本体に他のライブラリを使う可能性がある以上
    書き換えは避けられないということですね。

    プラグインやライブラリがシンプルな場合はgoogleなどのアップされているものを
    使うというところも理解が深まりました。

    今回のものについては書き換えをがんばってみます。

    ご回答ありがとうございました。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「jQueryを使用する際の$について」には新たに返信することはできません。