サポート » その他 » jQuery3系への対応について

  • WordPressのWEBサイトに対して、jQueryのバージョンを最新版の3.3.1へ更新したい、という話が出ております。
    ただ、確認したところ、WordPressの最新版(4.9.8)でも、使用しているjQueryは1系のようでした。

    こちら、jQueryのバージョンを3系に更新する予定はあるのでしょうか。
    また、現行のWordPressで、手動でjQueryのバージョンを更新した場合、サイトの挙動に影響等は出ないでしょうか。

    加えて、jQueryの1系、2系は既にサポートが終了していると聞いておりますが、jQuery1系のままでセキュリティのリスクにはならないでしょうか。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • CG

    (@du-bist-der-lenz)

    jQuery2.2.0にアップデートすることは、WordPress5系で動作はするようです。ただプラグインなどもjQuery1.xを読み込むことを前提として作られているものが多いのが現状。そうしたプラグインを使用しないことで、WordPressのバグが出てくれば、対応を前もって考えられますね。今、作業中のサイトでjQueryのバージョンの確認をしましたら、1.11.4から4.9.8が検出されました。

    動くかどうかはやってみないと分からないと思います。

    個人的には jQuery Migrate も jQuery3 に対応したものに差し替えたら大抵はうまく行くんじゃないだろうかと思います。

    jashinn0

    (@jashinn0)

    ご回答ありがとうございます。
    やはり、自分で実際に更新してみて動作確認する必要があるでしょうか。

    本件、jQuery3系への更新の予定があるかを開発元に質問できる、公式の問い合わせフォーム等はどこかにあるでしょうか。
    英語版でも構いませんので、ご存じでしたら教えて頂けると助かります。

    munyagu

    (@munyagu)

    こちらで議論されているようですよ。
    いつ取り込まれるかは未定です。

    https://core.trac.wordpress.org/ticket/37110

    nobita

    (@nobita)

    こんにちは、

    テーマのデバッグ用に使っているのですが、Jquery Updaterというプラグインがあります。

    https://wordpress.org/plugins/jquery-updater/

    jquery-3.3.1
    jquery-migrate-3.0.0.min

    が入っています。

    jQuery1系のままでセキュリティのリスク

    Chromeのaudits(Lighthouse)等でチェックすると、セキュリティの警告が出たと思います。

    • この返信は2 週間前に  nobita さんが編集しました。

    ご回答ありがとうございました。

    教えて頂いたJquery Updaterを実装したので、動作確認してみようと思います。
    障害の事例などがあれば教えて頂けると幸いです。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。