サポート » プラグイン » ktai entry 画像があると投稿できず(泣)

  • 解決済 showta

    (@showta)


    かなり色々検証したのですが(泣)、どうにもだめで、何卒お力をお貸し頂ければ幸いです。

    テキストのみの送信ではOKなのですが、画像を添付すると(50kb程度の軽い画像でもダメです。)自動での投稿は「下書き」となり、手動での投稿は、

    ***************************
    There is 1 message(s).

    Fatal error: Call to undefined method KtaiEntry_Post::log_error() in /○○○○○○/wp-content/plugins/ktai-entry/inc/post.php on line 801

    ・・・となってしまいます(泣)。

    何かヒントでもいただけませんでしょうか。。。

    お詳しい方、レスいただけましたら幸いです。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • レスありがとうございます!大変ありがたいです。

    頂きました情報ですが、

    1、日本語ファイル名ではありません。
    2、JPEGのMIMEは、image/jpeg のようですので、問題なさそうです。
    3、MACではなく、androidのスマホからと、XPからで、両方でダメです。
    4、PNGは送っていません。

    ・・・従いまして、全て当てはまらないようなのですが(泣)。。。

    他に何か、ヒントでも、ありませんでしょうか(泣)(泣)

    そうですねぇ、上記リンクのブログにあるように

    Ktai Entryのpost.phpで、parse($input)という関数の先頭で、
    $inputに転送してもらったメールを丸々代入してデバッグしましたw
    ちなみに、ktai_entry.phpのdefine(‘KE_DEBUG’, true);のコメントアウトを外すと、
    管理画面で「すぐにメッセージを読み出す。」をしたときに、詳細なログが表示できます。

    などで具体的に調査してみるしかないと思うのですが…

    XPから送られていると言うことですが、メーラーを変えてみるとか、もちろん添付の画像を色々変更してみる(gif、jpeg、pngなど形式も変えてみる)とか、画像の加工時におかしくなっていないかとか、調査してみるしかないと思いますねぇ。

    http://ja.forums.wordpress.org/topic/418?replies=6
    この辺とか、ヒントにならないかなぁ?

    http://www.yuriko.net/arc/2011/09/07/ktaientry-091/#comment-7927
    これを見る限り、もしかしたら最新版WordPressでは不具合あるかもしれませんけど…
    ゆりこさん最近絶不調なので、ここ(forum)にいつ現れるか分かりませんねヽ(;´Д`)ノ

    関係が無いかも知れないのですが

    There is 1 message(s).

    Fatal error: Call to undefined method KtaiEntry_Post::log_error() in
    /xxx/xxx/wp-content/plugins/ktai-entry/inc/post.php on line 801

    こんなエラーが出ていたので、以下を参考にして
    http://wppluginsj.sourceforge.jp/ktai_entry/qa/

    wp-contents/upload のフォルダのパーミッションを変えてみたところ、うまくいきました。
    セーフモードで動いている環境だったので。
    こんな初歩的なことは間違えてないかもですね、とりあえず自分の覚えがきに投稿させていただきます。

    ありがとうございました!

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「ktai entry 画像があると投稿できず(泣)」には新たに返信することはできません。