サポート » プラグイン » Ktai Styleプラグインが有効化できない

  • 解決済 yama4629

    (@yama4629)


    WP2.6.2です。

    Ktai styleプラグインを導入してみましたが
    下記のようなエラーが出て有効化出来ませんでした。

    Fatal error: Cannot redeclare auth_redirect() (previously declared in /ドメイン名/http/fp/wp-includes/pluggable.php:658) in /ドメイン名/http/fp/wp-content/plugins/ktai_style/admin/pluggable-override.php on line 13

    pluggable.php
    pluggable-override.php
    上記2つのファイルは変更しておらず、デフォルトのままです。

    原因がよく分からず困っております。
    どなたかご存知の方がいらっしゃいましたら、ご教授お願い致します。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック投稿者 yama4629

    (@yama4629)

    追記です。

    :Myasqlのバージョンは5.0.51b
    :他のプラグインは全て無効化したがダメ
    :wpを他のディレクトリに新規にインストールし、プラグインをktai styleだけをにしても同じエラーがでる。

    他のトピックも色々調べてみましたが、うまく該当する物がありませんでした。

    よろしくお願い致します。

    トピック投稿者 yama4629

    (@yama4629)

    自己解決しました。

    原因はおそらくFirefoxのFire Mobile Simulatorアドオンです。
    試しに、IEでプラグインを有効化したらできました。

    Fire Mobile Simulatorアドオンの設定でデフォルトにしても
    wordpress側で携帯からのアクセスとして解釈してると思われます。

    モデレーター IKEDA Yuriko

    (@lilyfan)

    プラグイン作者です。

    原因はおそらくFirefoxのFire Mobile Simulatorアドオンです。

    はい。これが原因です。携帯電話からのプラグインを有効化することはできません。これは、アドオン等で携帯電話のユーザーエージェントをシミュレートする場合も同様です。はまりがちのパターンとしては、スマートフォンから有効化する場合でしょうか。

    ドキュメントに書いてあるのですが、User Agent Switcher アドオンについては言及しているものの、Fire Mobile Simulator は書いてませんでした。次期バージョンではこのアドオンについても書いてみます。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「Ktai Styleプラグインが有効化できない」には新たに返信することはできません。