サポート » プラグイン » Lightboxの効果が付加されません

  • 解決済 thukimura

    (@thukimura)


    WordPress2.6.2から2.7.1へ手動にてバージョンアップしました。

    バージョンアップして新規投稿したら、Lightboxの効果が付加されません。
    画像にリンクさえも張れないし、もちろん黒の背景に「にょろ~ん」となることもなくなりました。

    また、違う方法で投稿したら大丈夫かな?と思って、Windows Live Writerから投稿すると、
    効果は付加されるのですが、画像が二枚記録されていきます。
    バージョンアップ前には、こういうことはありませんでした。
    サンプル見本↓
    http://www.teruteru-factory.com/rakugaki/yukidaruma.jpg

    元のように、滞りなく効果を発揮させるのは、どうしたらよいのでしょうか?
    なにかヒントを戴ければと思います。

    プラグインはAdd Lightboxバージョン0.4.1と、Lightbox 2バージョン2.0.2を組み込んでいます。
    ブラウザはIE7とLunascape4 バージョン4.8.1で確認しました。

    また、Add Lightboxバージョン0.4.1と、Lightbox 2バージョン2.0.2以外に、
    効果的なプラグインがあれば、それに乗り換えたいと思い、いくつか試したのですが、
    いずれも効果は付加されませんでした。

    デフォルトで効果を付加させたい場合、WordPressをグレードダウンしたほうがいいでしょうか?

    よろしくお願い致します。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • WordPressが正常にアップグレードされているとして、
    組み込むプラグインをLightbox2だけにすると、どうなりますか?
    Add Lightboxのことは知りませんが、機能が不足してしまいますか?
    私は、この環境で正常に利用できています。
    サムネイルは作られていますが、メディアライブラリにはリストされてませんね。

    スレッド開始 thukimura

    (@thukimura)

    >nocchiさま
    お返事ありがとうございます。
    まったく答えがつかないので、ほとほと困り果てておりました…。
    他のどこに相談していいのか…。

    質問を書き込んだあと、どうにも効果が付加されないので、
    バージョンは前に戻しました。
    これはこれで正常に作動しています。

    …が、しかし、新しいバージョンのほうで使って行きたいので、
    バージョンアップさせるよりも、別にインストールして
    (記事だけを)引っ越すかたちのほうがいいかな?と思い、新しく2.7.1をインストールしました。

    それがこちらのURLになります。
    http://www.teruteru-factory.com/memento/

    そうしましたら、こちらでもLightboxの効果が一切付加されません。
    本当に困りました。
    引き続き、こちらの解決を相談させていただきたいと思います。

    現在、こちらをAkismet2.2.3 、WP Multibyte Patch 、Lightbox 2 2.8.2 の
    プラグインのみで試用してみました。

    エントリーの画像投稿では次のような感じのHTML表示になります。
    <img src=”http://www.teruteru-factory.com/memento/wp-content/uploads/2009/04/img_2545-150×112.jpg&#8221; alt=”まんじゅう2” title=”まんじゅう2” width=”150″ height=”112″ class=”alignnone size-thumbnail wp-image-141″ />

    画像を投稿するときに、手打ちで何かタグを打たないといけないのでしょうか?
    (できれば画像投稿をしただけでLightboxが付加されるとありがたいのですが…。
    旧ブログではそのとおりに使えます。)
    他のLightbox系のプラグインを使ってみても同じです。

    ちなみにサーバーは、さくらのレンタルサーバです。
    ブラウザは Firefoxも使ってみましたが、何も変わりません。
    新ブログは、他の機能は正常に使えていると思います。

    ご迷惑かと思いますが、本当によろしくお願い致します。

    こんにちは。

    Lightboxの設定で、”自動設定を有効にする”にチェックは入ってますか?
    Lightbox 2 2.8.2なら設定画面、”Auto-lightbox image links”横のチェックボックスです。

    私はWP2.7.1にLightbox2.0.2を入れているのですが、今こちらを使用不可にして2.2.8.2を入れて試してみました。特に問題なく動いてますよ。

    過去記事に同じ問題の解決方法が掲載されていました。
    デフォルトのテーマでも動作しませんか?
    http://ja.forums.wordpress.org/topic/681?replies=18

    上手くいかないようでしたらLyteboxを試してみてください。
    同じような感じのプラグインだと思います。
    http://grupenet.com/2007/08/03/wp-lytebox/

    スレッド開始 thukimura

    (@thukimura)

    ご協力ありがとうございます。

    >fuuさま
    > Lightboxの設定で、”自動設定を有効にする”にチェックは入ってますか?
    これも、つけてもはずしても、うんともすんとも…でした。
    設定もちゃんと保存して有効化したのち、記事を入れて、記事表示もリロードしました…。

    >nocchiさま
    >デフォルトのテーマでも動作しませんか?
    全て試してみたのですが、どのテーマでもまずいみたいです…。
    ヘッダー、フッターの<?php wp_head(); ?>、<?php wp_footer(); ?>も確認しています。
    手動でrel=”lightbox”をつけても同じく何も変わらず。

    >上手くいかないようでしたらLyteboxを試してみてください。
    こちらもだめでした。
    いずれのLightboxも、設定部分はちゃんと表示されていますので、プラグイン自体はきちんと読めていると思われます。

    ‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥

    過去の旧ブログから、Lightboxが付加されているエントリーの記述を、インポートしたら
    それは正しく読めるようです。

    ※Lightboxは、WordPressをインストールして、
    最初に記事が何もない状態から、プラグインだけでテストしても
    何も効果が付加されませんでした。

    ‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥‥

    あくまでも、このブログだけの問題のようですが、何も手がかりがない状態です。
    これももう一度、WordPress自体のインストールからやり直したほうが良いのか悩んでいます。

    画像を大きく詳細に見せられることが出来れば、それでもよいので
    Lightbox以外にそういう効果のあるプラグインなどはあるのでしょうか…?
    ベストなのはLightboxの効果だと思って使っていたのですが。

    引き続き、みなさまにご援助いただければと思います。
    よろしくお願い致します。

    Lyteboxの場合
    新しくインストールしたURLを確認しました。
    画像部分にLytebox呼び出し用のコードが入っていないようです。
    以下のように、投稿に画像が挿入されているだけになっています。

    <img src="http://www.teruteru-factory.com/memento/wp-content/uploads/2009/04/img_2642-150x112.jpg" alt="ハンバーガー" title="ハンバーガー" width="150" height="112" class="alignnone size-thumbnail wp-image-162" />

    Lyteboxを動作させるには、以下のようになっている必要があります。

    <a href="images/image.jpg" rel="lytebox"><img src="images/image-thumbnail1.jpg" /></a>

    「rel=”lightbox”」ではなく、rel=”lytebox”である点にも注意してください。

    ソースが不十分なのは、プラグイン適用後に投稿していないからですか?
    それとも、投稿したけれどコードが付与されないとか、投稿環境など他の影響でしょうか?

    参考
    Lyteboxの使い方
    http://www.syboos.jp/opensource/bookmark/detail/lytebox.html

    スレッド開始 thukimura

    (@thukimura)

    できました!!
    やっとできました。

    …どうやらflashアップローダです。
    こちらのアップローダの
    「リンクURLの指定」がきちんと読み込めていなかったようです。

    こちらの「リンクURL」→「なし」「ファイルのURL」「投稿のURL」のURL表示ができていなかったようです。
    今まで、こちらをいちいち指定していなかったので、全く気が付きませんでした。
    「今まで、画像って勝手にリンクを引っ張って来ていたような気がする…」と思って見直して、気が付きました。

    こちらを「ファイルのURL」を指定しましたら、画像にリンクを張ることができ、
    lightbox系のプラグインが全て使用することが出来ました。
    全て使用できることを確認しました。
    ※いずれも手打ちでは一切のタグの記述など足さずに効果が付加されています。

    本当にお騒がせしました。
    ありがとうございました。
    ‥‥‥‥‥‥‥‥‥‥‥
    >nocchiさん
    最後まで丁寧に説明していただき、本当にありがとうございました。
    たくさんのヒントを戴き、たいへんに助かりました。
    また何かのときにはよろしくお願い致します。

           

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「Lightboxの効果が付加されません」には新たに返信することはできません。