サポート » プラグイン » lightbox-2-wordpress-pluginが使えない

  • WP2.6で、ightbox-2-wordpress-plugin1.8.2を使用したいのですがうまくいきません。
    http://www.4mj.it/lightbox-js-v20-wordpress/
    より、ダウンロードしてpluginsフォルダーにightbox-2-wordpress-pluginフォルダーごとアップして、プラグインを有効化しても、何も変化なしなのですが、WPのバージョンのせいでしょうか?

15件の返信を表示中 - 1 - 15件目 (全17件中)
  • フォルダーからだして、lightbox.phpとlightboxフォルダーをpluginsフォルダーフォルダーにアップしてから有効化してもだめでした。

    外してたらごめんなさい。

    「lightbox-2-wordpress-plugin」フォルダの中身をプラグインフォルダ直下にアップロードして有効化してから、挿入した画像のアンカータグに rel=”lightbox” と記述しないと使えませんが、画像のアンカータグも記述していますでしょうか?

    kentanjpさん、ありがとうございます。
    rel=”lightbox”は、記述したり、とってみたりもしましたが、ウンともスンともなじょうたいです。
    まるで、読みにいっていないようです。

    どなたか、教えてください。

    WPのほかのバージョンで試せないのですが、バージョンの問題でしょうか?

    ちなみに、わたしもLightbox-2を使っていますが、ここからダウンロードして使っています。
    Wordpressは2.6.2です。
    プラグインのバージョンは、2.7.8です

    http://wordpress.org/extend/plugins/lightbox-2/

    nuttspoyonありがとうございます。

    WordPressは2.6.2、プラグインのバージョンは、2.7.8でやってみましたが、やはりダメでした。
    どこか、単純なミスのような気がするのですがいかがでしょうか?手順を書きます。

    1、解凍したlightbox-2フォルダーをそのまま、wp-content/plugins/にアップロード

    2、ダッシュボードの管理、プラグインでLightbox 2を有効化

    表示させたいファイルには、rel=”lightbox”はつけずにそのままにしています。

    なぜでしょうか?

    フォルダーのパーミッションはわたしは755にしています。
    ブラウザーのjavascriptは有効になっています。
    それから以前わたしもうごかないことがあって、それは同じようなプラグインと競合していたからです。
    そのプラグインをはずしたら動きました。
    そのぷらぐいんは、WP Piclens というものでした。
    画像をクリックしてレビューするときに効果がつくような、ほかのプラグインは使っていらっしゃいませんか?

    別のプラグインは使ってないです。
    headerの書き方がわるいのでしょうか?下記に写しておきます。

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    
    <head>
    
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    
    <meta name="description"content="<?php bloginfo('description'); ?>"/>
    
    <title><?php bloginfo('name'); ?><?php wp_title(': '); ?></title>
    
    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats please -->
    
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?>(RSS 2.0)" href="<?php bloginfo('rss2_url'); ?>" />
    
    <link rel="alternate" type="application/atom+xml" title="<?php bloginfo('name'); ?>(Atom)" href="<?php bloginfo('atom_url'); ?>" />
    
    <link rel="stylesheet" type="text/css" href="<?php bloginfo('stylesheet_url'); ?>" />
    
    <script type="text/JavaScript">
    <!--
    function MM_preloadImages() { //v3.0
      var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
        var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
        if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
    }
    
    function MM_swapImgRestore() { //v3.0
      var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
    }
    
    function MM_findObj(n, d) { //v4.01
      var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
        d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
      if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
      for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
      if(!x && d.getElementById) x=d.getElementById(n); return x;
    }
    
    function MM_swapImage() { //v3.0
      var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
       if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
    }
    //-->
    </script>
    
    <script src="<?php bloginfo('template_directory'); ?>/Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
    
    </head>

    設定の、Lightbox 2 OptionsのAuto-lightbox image linksは、チェックをいれているのですが、ソースを見てもイメージリンクにrel=”lightbox”は付加されていないようで、やはりまるで動作していないようです。
    別のファイルでも同じでした。

    どなたかお分かりになる方いらっしゃいませんか?

    プラグインを有効にしてから画像付の投稿をしましたか?
    過去の投稿の画像についてはそのままではlightboxが有効にならなかったような気がしました…

    また、Add Lightboxを使ってみたらどうでしょうか?

    違ってたらごめんなさい。

    過去の投稿にもできております。。。

    もし違っていたらごめんなさい
    上のjavascript はスワップイメージのスクリプトですよね
    もしかしてこのファンクションのついた画像をLightbox-2で表示させるのでしょうか。。。?
    そうだとしたらそれはできないんじゃないかと。。
    的外れなこと言ってましたら、申し訳ありません。

    </head>の前に
    <?php wp_head(); ?>
    がないとプラグインが必要ファイルを設置できません。

    あわせて
    footer.phpの</body>の前に<?php wp_footer(); ?>があるかも確認してください。

    ightbox-2-wordpress-pluginがどちらを使っているかは分かりませんが、両方記述しておいた方が良いと思います。

    taikikenさん、ありがとうございます。

    <?php wp_head(); ?>、<?php wp_footer(); ?>を付加したら、ほぼうまく作動しました。
    しかし、いくつかの投稿では作動せず、手動でrel=”lightbox”をつけると作動しましたが、スライドショーができません。矢印がでてきません。

    ためしに、うまく作動した記事を、うまくいかなかった記事にコピーペーストしたら、正常に作動しました。

    理由がわかりません。

    アドバイスお願いいたします。

    あと、area shapeを使ってリンクしたものは、手動でrel=”lightbox”をつけてもだめでした。

    ちなみに、これらのファイルはHTMLファイルだとすべて、通常のlightboxで正常に表示されていました。

    WPの表記等の何かが原因だとおもいます。

    スライドショーがうまくいく、うまくいかない、についてですが、記述の中で半角スペースのつもりが全角スペースになっているという事はありませんか?
    例えばtitle=””の中や、rel=”lightbox”の前後など

    手動でrel=”lightbox”をつけると作動しましたが、スライドショーができません。矢印がでてきません。

    lightboxでスライドショーするには

    <a href=”images/image-1.jpg” rel=”lightbox[roadtrip]”>image #1
    <a href=”images/image-2.jpg” rel=”lightbox[roadtrip]”>image #2
    <a href=”images/image-3.jpg” rel=”lightbox[roadtrip]”>image #3

    のようにイメージをグループ化しないといけないと思います。

    lightboxの説明はご覧になりましたか?

15件の返信を表示中 - 1 - 15件目 (全17件中)
  • トピック「lightbox-2-wordpress-pluginが使えない」には新たに返信することはできません。