サポート » テーマ » スタイルシートがロードされない

  • 解決済 dosracc

    (@dosracc)


    04webserverにてwordpressを運用しようと思っております。

    OSはwindows 7 64bitです。
    PHPは5.5.6を使用。

    トピックタイトルの通り、localではテーマが正しく表示されるのですが、他のネットワークから自分のサーバーへ接続すると、文字しか表示されておりません。

    具体的には、local上では
    http://gyazo.com/737b4295a311b99bb248d8e7b7f37121
    と、正しく表示されております。
    が、一度こちらへアクセスしていただければわかると思いますが、別のネットワークからだと文字しか表示されません。

    phpやperlや04webserverはC:\にインストールし、wordpressのディレクトリは別のドライブ(F:\server\wordpress)を指定しております。
    また、解説サイトなどにも目を通し、PHPやPerlの設定(パス通しや04webserverの設定)は済ませております。local上でも、他のネットワークからでもPHPの動作確認(phpの詳細な情報を表示させるコマンド)はしてあり、特に問題は無いです。

    テーマについても、他のテーマをいくつかダウンロードし、有効化してみましたがダメでした。初期テーマも正しく表示されませんでした。

    自力でできうることはすべて行ったつもりではありますが、どうにも解決できません。
    皆様のお力添えをいただければなと思い、新しくトピックを作成させていただきました。

    何卒、よろしくお願いいたします。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • こんにちは、

    ソースのURLがlocalhostになっているので、ローカルからのアクセスでしか、表示できないのだと思います

    http://localhost/wordpress/wp-content/themes/8some1/style.css
    トピック投稿者 dosracc

    (@dosracc)

    >>nobita 様

    大変すばやい返信、誠にありがとうございます。

    私自身、最初それを疑っており、CSSを覗いてみましたがどこにも「localhost」という記述が見つからずに断念しておりました。

    nobita様の書き込みを見て、もう一度CSSを覗いてみましたがやはり「localhost」が見つからず。

    ただ、wordpress本体の設定で確か”http://localhost/wordpress/”と指定されている箇所があったな、と思い出し、wordpress設定 一般の、「Wordpress アドレス」と「サイトアドレス」を「http://agumon.ddo.jp/wordpress/に変更すると正しく表示されました。

    いやはや、こんな簡単なミスも見つけられず、お恥ずかしい限りでございます。

    早期の返信、重ね重ねありがとうございました。

    モデレーター Takayuki Miyoshi

    (@takayukister)

    タイトルが空の状態になっていましたので、こちらで内容に基づいたタイトルを付けさせていただきました。タイトルがないと一覧からたどれないため回答が非常に付きにくくなります。質問を投稿する際は内容に合ったタイトルを必ず付けるようにしてください。

    良いトピックタイトルをつける

    もし、タイトルを入力したはずなのに消えていた、というようなことがありましたら、何らかのシステム上のトラブルが発生していた可能性もありますので、原因究明のため以下の情報をご提供ください。

    • 設定したはずのタイトル(覚えていれば)
    • 投稿時に使用したブラウザとそのバージョン
    • そのほか何か気になったことがあれば
    トピック投稿者 dosracc

    (@dosracc)

    タイトルは設定していたと思いますが……。

    設定したはずのタイトル
    ・localではテーマが正しく表示されるが、それ以外だと文字しか表示されな‏い
    投稿時に使用したブラウザとそのバージョン
    ・FireFox 26.0
    そのほか何か気になったことがあれば
    ・特にないですが、タイトルはもしかしたら最後の「い」が抜けていたかもしれません。

    最初にトピックが立った時は「localではテーマが正しく表示されるが、それ以外だと文字しか表示されな‏」だったようです。

    @Takayuki Miyoshi

    私が回答した時点では、タイトルは空欄ではありませんでした

    Notify me のメールは以下のとおりです
    http://tenman.info/labo/snip/files/title-issue.png

    タイトルの最後の文字列が文字化けしているように見えますので、タイトルを一定長さに丸めるときに、何らかの不具合が出ているのかもしれません

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「スタイルシートがロードされない」には新たに返信することはできません。