サポート » プラグイン » MW WP Form誤動作?

  • 解決済 sora8115

    (@sora8115)


    ご覧くださりありがとうございます。

    正常に動いているサーバのデータを別サーバへ移したのですが
    MW Formの動作に異常が起きております。

    追加した投稿タイプの投稿内にMW Formを表示しているのですが
    (1)
    投稿ページ表示→フォーム入力→確認画面へ→送信しても完了へ移動しない(メールも飛んでいない)

    (2)
    投稿ページ表示→フォーム入力→確認画面からページバックで戻る→一瞬戻ったページが表示されるが、一瞬で確認画面になる

    (3)
    (2)の状態から、投稿一覧ページへとさらに戻り、また投稿ページへ入るとMW Formの確認画面になってしまう

    cookieを削除すれといちどは投稿ページへ入ることが出来ますが
    またフォーム確認画面へ進むと同じ現象になります。

    自身で調べた中では、キャッシュ系プラグインやセキュリティ系のプラグインが影響するとあったのですが
    キャッシュ系らしきものはなく、セキュリティのプラグインも有効になっていませんでした。

    元々ちゃんと動いているサイトなので、何が悪いのかさっぱりわかりません。

    ——–
    関係あるのか分からないのですが、
    元サーバはさくらで、<? the_title(); ?>こちらでタイトルが表示されていましたが
    移動先サーバのロリポップでは<?php the_title(); ?>こうしなければならないようでした。
    ——–
    インストールしてあるプラグイン
    admin-menu-editor 有効
    advanced-custom-fields 有効
    akismet 削除(元サイトでも無効)
    all-in-one-seo-pack 有効
    custom-post-type-permalinks 有効
    custom-post-type-ui 有効
    duplicate-post 有効
    ewww-image-optimizer 有効
    google-analytics-dashboard-for-wp 有効
    google-sitemap-generator
    intuitive-custom-post-order 有効
    mw-wp-form 有効
    ps-taxonomy-expander 有効
    sakura-rs-wp-ssl
    siteorigin-panels
    so-css
    so-widgets-bundles
    ultra-admin(元サイトで有効)
    wordpress-importer 有効
    wp-add-custom-css
    wp-admin-ui-customize(元サイトで有効)
    wp-basic-auth
    wp-multibyte-patch

    ——–

    何が悪そうかご教示いただけますと幸いです。
    宜しくお願いいたします。

    • このトピックはsora8115が1年、 7ヶ月前に変更しました。
    • このトピックはsora8115が1年、 7ヶ月前に変更しました。
    • このトピックはsora8115が1年、 7ヶ月前に変更しました。
    • このトピックはsora8115が1年、 7ヶ月前に変更しました。
13件の返信を表示中 - 1 - 13件目 (全13件中)
  • こんにちは

    メールフォームを作成し直してみてはどうでしょうか?
    作成し直しても状況が変わらないようでしたら、WordPress のデバッグモード(下記ページを参照)や、JavaScript、サーバーのエラーログを確認してみてください。
    http://wpdocs.osdn.jp/WordPressでのデバッグ#WP_DEBUG

    下記ページも参考にしてみてください。
    https://plugins.2inc.org/mw-wp-form/faq/

    スレッド開始 sora8115

    (@sora8115)

    ご返信ありがとうございます。

    ひとまずご指示どおりフォームを作り直そうとしたのですが
    なんとなくでフォームをゴミ箱に入れた状態でページを見たところ
    なぜかフォームが表示されたまま動いていました。

    これも改善のヒントになりますでしょうか。

    さすがにWW Formプラグインをオフにしましたら識別子がべた書きされた状態になりました。

    そういえば、最初WPのエクスポートファイルをインポートしたときに
    MW Formの〇〇が有効ではありません(?)のメッセージが出ておりました。

    • この返信は1年、 7ヶ月前にsora8115が編集しました。
    • この返信は1年、 7ヶ月前にsora8115が編集しました。
    スレッド開始 sora8115

    (@sora8115)

    理由は分からないのですが新しいことが分かりました。

    移行先の環境では、
    MW Formフォーム編集画面のURL設定で各リダイレクトURLを空にしたところ
    メール送信完了までいくことができました。

    現状、戻るボタンを設置していないのでページバックで戻ると
    フォーム部分は確認表示のままではありますが
    一覧へ戻ってから投稿ページへ進んでも強制的に確認画面に入る状況ではなくなりました。

    URL設定で固定ページを参照するようにすると
    元のおかしい状況に戻ります。

    固定ページがおかしいのか、
    パーマリンク?がおかしいのか
    MW Formがおかしいのか?

    引き続きご教示お願い申し上げます。

    スレッド開始 sora8115

    (@sora8115)

    WPデバッグモードON → 特に表示されず、
    サーバ側のphpエラー表示ON → 特に表示されず
    ブラウザのコンソールエラー有無確認 → エラーはでていましたが移行元でも出ていました
    /mw-wp-form/faq/ → 拝読しました糸口にならずでした

    ゴミ箱に入れた状態でページを見たところ
    なぜかフォームが表示されたまま動いていました。

    ゴミ箱のフォームも表示されるようです。再現しました。

    最初WPのエクスポートファイルをインポートしたときに
    MW Formの〇〇が有効ではありません(?)のメッセージが出ておりました。

    「〇〇」は何が入る(メールアドレス?)のでしょうか?

    URL設定で固定ページを参照するようにすると
    元のおかしい状況に戻ります。

    下記トピックが参考になるかもしれません。
    https://ja.wordpress.org/support/topic/mw-wp-formで確認画面にいかない/

    下記トピックのトラブルシューティングは試されたでしょうか?
    https://ja.wordpress.org/support/topic/問題解決のためのチェックリスト-ドラフト版/

    スレッド開始 sora8115

    (@sora8115)

    ご返信ありがとうございます。
    いただいたURLを確認してみます。

    もう一度思い出してみましたが、たしかこの様な感じでした。
    〇〇がインポートできませんでした。MW Formのmwf_910が有効ではありません。
    ↑この〇には、MW Formのメール件名に入っていた文言と一致していた気がします。

    ——

    URL設定なしで、1ページで完結の状態にした件ですが
    戻るボタンも設置していちおう正常らしき状態にはなりました。

    しかしながら移行前と変わってしまったので
    根本的な解決に至っておりません。

    宜しくお願いいたします。

    スレッド開始 sora8115

    (@sora8115)

    元の環境がさくらサーバで、SSLが設定されているのですが関係ありませんよね。。

    もとのhtaccessには下記が記述してあり、
    今の環境はまだhttpなのでコメントアウトしてあります。

    # BEGIN WP BASIC Auth
    #<IfModule mod_rewrite.c>
    #RewriteEngine On
    #RewriteCond %{HTTP:Authorization} ^(.*)
    #RewriteRule ^(.*) – [E=HTTP_AUTHORIZATION:%1]
    #</IfModule>
    # END WP BASIC Auth
    # BEGIN Force SSL for SAKURA
    # RewriteしてもHTTPS環境変数を有効にする
    #SetEnvIf REDIRECT_HTTPS (.*) HTTPS=$1

    # 常時HTTPS化(HTTPSが無効な場合リダイレクト)
    #<IfModule mod_rewrite.c>
    #RewriteEngine on
    #RewriteCond %{ENV:HTTPS} !on
    #RewriteCond %{REQUEST_URI} !/wp-cron\.php$
    #RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    #</IfModule>
    # END Force SSL for SAKURA

    エラーが発生していないとなると、ちょっと分かりませんね。サーバ移行で何にか失敗(URL の置換作業?)したような気がしますが・・・?
    新サーバにおいて、別途 WordPress をインストールして検証してみるといいかもしれません。

    スレッド開始 sora8115

    (@sora8115)

    wordpressのインポート機能で移行したので
    置換作業というのは行っていないのですよね。

    テーマをtwentyseventeenにし
    フォーム入力 / 確認画面 / 完了画面の固定ページを作成して送信を試したところ正常に送信できました。
    テーマがおかしくなっているのかもしれません。。。

    スレッド開始 sora8115

    (@sora8115)

    元サイトから改めてテーマを持ってきましたが改善されず・・

    スレッド開始 sora8115

    (@sora8115)

    謎が解決いたしましたのでご報告にあがりました。

    移行元と移行先でshort_open_tagのon/offに設定差があり
    こちらをonにしたところ移行元と同じ動作になりました。

    恐らくオリジナルテーマの中でphp開始タグの省略とそうでない記述が混在しており
    プログラムの一部が動いて一部が動かない状態だったため、
    MW Formにも悪影響が出ていたものと思われます。

    当方としましてはishitaka様に何度もご返信いただけて心が救われておりましたが
    見当違いな解決でなんとも申し訳なく思っております。

    しかしながらありがとうございました。

    スレッド開始 sora8115

    (@sora8115)

    なぜここまでの不具合になったかをまとめて締めたく思います。

    テーマ内のfooter.phpにて
    <? wp_footer(); ?>
    というように
    MW Formで不具合の原因としてよく挙がる上記が省略式で書かれており
    移転先でshort_open_tagがOFFだったため異常な動作となりました。

    本投稿で同じ現象になった方が救われることを祈ります。

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • トピック「MW WP Form誤動作?」には新たに返信することはできません。