サポート » 使い方全般 » MySQL 5.0.45 から 5.1.73 への移行について

  • 解決済 kimihiro

    (@kimihiro)


    ワードプレスの引っ越し作業において、問題が発生しましたので質問させて頂きます。

    環境Aから環境Bへ移行させた際、全ての固定ページ・全ての投稿が表示されなくなってしまいました。
    環境A:PHP5.2.6 Mysql5.4.45
    環境B:PHP5.3.3 Mysql5.1.73
    ワードプレスのバージョンはいづれも4.1です。

    トップページは表示されますし、管理画面に入る事もできます。
    しかし、固定ページや投稿の数は認識されていますが、それぞれは存在しない事になっています。
    デバッグモードで表示すると下記のようなメッセージがでます。
    私が考えるに、MySQL 5.0 から 5.1に移行する際、なにかしらのデータのコンバートが必要なのではないかと。
    単純に、mysqldumpとリストアではダメなのではないかと思っています。

    このあたり、お心当たりのある方は宜しくアドバイスの程、宜しく申し上げます。

    =====
    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /home/〇〇〇/htdocs/public_html/wp/wp-includes/functions.php on line 3497 Deprecated: Function ereg() is deprecated in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/event-calendar/options.php on line 90 Deprecated: Function ereg() is deprecated in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/event-calendar/options.php on line 96 Deprecated: Function ereg() is deprecated in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/event-calendar/options.php on line 101 Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /home/〇〇〇/htdocs/public_html/wp/wp-includes/functions.php on line 3497 Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home〇〇〇/htdocs/public_html/wp/wp-includes/functions.php on line 3547 Notice: add_custom_image_header の使用はバージョン 3.4 から非推奨になっています! 代わりに add_theme_support( ‘custom-header’, $args ) を使ってください。 in /home/〇〇〇/htdocs/public_html/wp/wp-includes/functions.php on line 3378 Notice: register_widget_control の使用はバージョン 2.8 から非推奨になっています! 代わりに wp_register_widget_control() を使ってください。 in /home/〇〇〇/htdocs/public_html/wp/wp-includes/functions.php on line 3378 Notice: register_widget_control の使用はバージョン 2.8 から非推奨になっています! 代わりに wp_register_widget_control() を使ってください。 in /home/〇〇〇/htdocs/public_html/wp/wp-includes/functions.php on line 3378 Notice: Undefined index: ec3_before in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/event-calendar/eventcalendar3.php on line 511 Notice: Undefined variable: a in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/event-calendar/eventcalendar3.php on line 512 Notice: Trying to get property of non-object in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/allow-categories/allowcat.php on line 239 Warning: Parameter 1 to ec3_filter_posts_where() expected to be a reference, value given in /home〇〇〇/htdocs/public_html/wp/wp-includes/plugin.php on line 269 Warning: Parameter 1 to ec3_filter_posts_join() expected to be a reference, value given in /home/〇〇〇/htdocs/public_html/wp/wp-includes/plugin.php on line 269 Warning: Parameter 1 to ec3_filter_posts_groupby() expected to be a reference, value given in /home/〇〇〇/htdocs/public_html/wp/wp-includes/plugin.php on line 269 Warning: Parameter 1 to ec3_filter_posts_fields() expected to be a reference, value given in /home/〇〇〇/htdocs/public_html/wp/wp-includes/plugin.php on line 269
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘FROM wp_posts WHERE 1=1 ORDER BY wp_posts.post_date DESC’ at line 1]
    SELECT FROM wp_posts WHERE 1=1 ORDER BY wp_posts.post_date DESC

    Notice: Trying to get property of non-object in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/allow-categories/allowcat.php on line 239 Notice: Trying to get property of non-object in /home/〇〇〇/htdocs/public_html/wp/wp-content/plugins/allow-categories/allowcat.php on line 239 Parse error: syntax error, unexpected $end in /home/〇〇〇/htdocs/public_html/wp/wp-content/themes/evening-shade/404.php on line 39
    =====

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • モデレーター Daisuke Takahashi

    (@extendwings)

    とりあえずは、プラグインをすべて無効にしてください。
    それでも、正常に動作しませんか?

    ありがとうございます。

    全てのプラグインを停止させると、正常に動作しました。
    そして原因となったプラグインも特定する事が出来ました。

    おかしくなったら、「プラグインを停止してみる」。
    ワードプレスの基本でしたね。

    改めて感謝申し上げます。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「MySQL 5.0.45 から 5.1.73 への移行について」には新たに返信することはできません。