サポート » 使い方全般 » Notice: WP_Queryにつきまして。

  • 解決済 ikechan

    (@ikechan)


    お詳しい方にお聞きしたいのですが、デバッグモードで出る、

    Notice: WP_Query の使用はバージョン 3.1 から非推奨になりました ! 代わりに “caller_get_posts” は非推奨です。代わりに “ignore_sticky_posts” をお使いください。 を使ってください。 in /home/squib/liaise.jp/public_html/wp-includes/functions.php on line 3466

    このメッセージは、解消方法をどのようにすれば良いのでしょうか?

    よろしくお願い致します。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック投稿者 ikechan

    (@ikechan)

    お詳しい方にお聞きしたいのですが、デバッグモードで出る、

    Notice: WP_Query の使用はバージョン 3.1 から非推奨になりました ! 代わりに “caller_get_posts” は非推奨です。代わりに “ignore_sticky_posts” をお使いください。 を使ってください。 in /home/squib/liaise.jp/public_html/wp-includes/functions.php on line 3466

    このメッセージは、解消方法をどのようにすれば良いのでしょうか?

    よろしくお願い致します。

    こんにちは

    メッセージが少し変ですが、caller_get_posts()は、3.1からは廃止予定になったので、ignore_sticky_posts()を使って下さいという事だと思います。

    メッセージの内容も注意ですので、今直ぐ差し迫った内容ではないではないですが、将来、caller_get_posts()がなくなった時にエラーになりますので、ignore_sticky_posts()を使ってコードの書き換えが必要です。

    WordPressは、少しずつ変化していますので、過去のバージョンで定義されていた関数などが廃止されることは珍しいことではありません。

    トピック投稿者 ikechan

    (@ikechan)

    redcockerさんへ、
    有難うございました。

    今後、勉強してコードの書き換えぐらいは、出来るようにしておきます。

    ありがとうございました。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「Notice: WP_Queryにつきまして。」には新たに返信することはできません。