サポート » 使い方全般 » Parse errorの対処方法について

  • 解決済 gakiyu

    (@gakiyu)


    WordPressを使いサーバーはXserverをレンタルしてブログ運営をしています。
    この1年間は、ほとんどブログ更新をしていません。

    そんな中、1週間ほど前にWordPressのダッシュボードから
    バージョンのアップデートやプラグインのアップデートを行いました。
    そして、サイト表示をさせたら次のようなエラーメッセージが表示されるだけで、
    サイト表示ができなくなってしまいました。

    エラー内容は

    Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /home/testsv008/inazodomain01.com/public_html/wp-content/plugins/wordpress-23-related-posts-plugin/config.php on line 130

    です。

    何しろ初めてのことでショックを受けています。
    アップデートするまでは正常に動いていたのに。
    元どおりに表示させるにはどう対処したらいいのでしょうか。

    なお、バックアップはプラグインのBackWpupで
    毎日DropBox内で行っています。
    改めてバックアップの内容を見てみましたら
    「データが壊れています」とのことでした。
    泣き面に蜂状態です。

    どうしようもないのでしょうか。
    なんとかしたいと思ってますのでどなたかご教示ください。
    宜しくお願いします。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • manbo

    (@manbo)

    WordPress Related Postsプラグインを旧バージョンに上書きで戻すかFTP等で削除してみてください。
    https://downloads.wordpress.org/plugin/wordpress-23-related-posts-plugin.3.6.3.zip

    WordPress Related Postsの最新版3.6.4はPHP5.4以上しか対応していないそうですがPHPのバージョンはいくつですか?

    モデレーター Okamoto Hidetaka

    (@hideokamoto)

    エックスサーバーであればPHPのバージョン変更はできたような気がします。
    5.4よりも古いバージョンになっている様子であれば、5.6に変更してみてください。

    おそらくいま使用しているPHPのバージョンでは使用できないコードがプラグイン内に記載されているものと思われます。

    早速のご指導ありがとうございます。
    ご指摘のとおりPHPバージョンを5.6.30に
    変更しました。
    すると一気に復活しました。
    本当にありがとうございました。
    大変勉強になりました。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。