サポート » 使い方全般 » PHPのバージョンアップで管理画面が使えません。

  • 解決済 naka4187

    (@naka4187)


    お世話になります。
    クイッカのサーバーでワードプレスのサイトを複数運営していますが久しぶりにワードプレスの管理画面にログインしたらほとんどの複数サイトで下記3つのエラー表示が出て管理画面が使えなくなっていました。(最後にログインした時には管理画面使えていました。サイト自体の表示はできています)

    Warning: Illegal string offset ‘total_users’ in /home/●●/public_html/●●.net/wp-includes/update.php on line 67

    Warning: Cannot modify header information – headers already sent by (output started at /home/●●/public_html/●●.net/wp-includes/update.php:67) in /home/●●/public_html/●●.net/wp-includes/functions.php on line 861

    Warning: Cannot modify header information – headers already sent by (output started at /home/●●/public_html/●●.net/wp-includes/update.php:67) in /home/●●/public_html/●●.net/wp-includes/functions.php on line 862

    影響が出ているのはワードプレスのバージョンはWordPress 3.3.1全てのサイトで影響が出ています。
    WordPress 4.8のサイトはこれまでどおり、使えています。
    ちなみにロリポップでも同じようにワードプレス使っていますが問題ないです。

    サーバーのクイッカ側に問い合わせたところ下記の返答がきました。(サーバー側でPHPのバージョンアップがされたようです。)

    >サーバーのPHPバージョンが5.6になったため、関連のエラー(ワーニング)が出力されるようになったように見受けられます。
    >WordPress自体の機能、仕様等に関しましてはこちらではサポートができかねてしまいますため、恐れ入りますが詳細はWordPress公式フォーラム等でご確認いただければと存じます。

    初心者の為、対応方法がわからず、管理画面が使えなくて困っています。
    どなたか対応方法が分かりましたらご教授頂けないでしょうか。
    大変お手数をおかけしますがよろしくお願いいたします。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • CG

    (@du-bist-der-lenz)

    クイッカからの回答のとおりでしょう。PHPバージョンが5.6以下の提供が終了したためです。「WordPress 4.8のサイトはこれまでどおり、使えています。」とのことですので、WordPressを対応させませんか。

    ご回答ありがとうございます。
    そうしたいのですが管理画面が使えないのでWordPressのバージョンアップができません。
    管理画面を使わずにWordPressを対応させる方法があればご教示ください。

    CG

    (@du-bist-der-lenz)

    「WordPress自体の機能、仕様等に関しましては」都合があってWordPress 3.3.1で使ってきたのなら「サポートができかねてしまいます」。でもWordPress 3.3.1で使ってきたのには、何らも未練がないのでしたら、最新バージョンをインストールしてしまうことで「サーバーのPHPバージョンが5.6になったため、関連のエラー(ワーニング)が出力されるようになったように見受けられます。」の解消は簡単です。

    検索エンジンで探したら「WordPressの手動アップデートの方法」とそれに伴って必要な「プラグインを手動で無効化する方法」がネット上で紹介されていたのでそのとおり試したら解決できました。
    ありがとうございました。

    CG

    (@du-bist-der-lenz)

    クイッカのサービスに、FTPがあったので心配はしていませんでした。管理画面が使えなくても、ファイル操作ができることをしっかり認識しておきましょう。FTPアカウントが判明すれば、外部から直接操作できるというわけです。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「PHPのバージョンアップで管理画面が使えません。」には新たに返信することはできません。