サポート » インストール » PHPのバージョンアップ後のエラー

  • ロリポップサーバーで、サーバーアップグレードした際に、PHP5.3から、PHP7に移行してみたものの、下記のようなエラーが出て、ログイン画面も出なくなってしまいました。
    原因あるいは解決方法をご存知の方、いらっしゃいますでしょうか?

    経過は以下です。
    ①プラグイン「db-cache-reloaded-fix」にてエラーが発生。
    ━━━━━━━━━━━━━━━━━━━━━━━━━━
    >Parse error: syntax error, unexpected ‘new’ (T_NEW) in /home/users/2/lolipop.jp-4555107e4212fdd4/web/wp-content/plugins/db-cache-reloaded-fix/db-module.php on line 214
    ━━━━━━━━━━━━━━━━━━━━━━━━━━

    そのため一旦「db-cache-reloaded-fix」を無効化。
    改善するか確認してみたものの、今度は以下のエラーが発生。

    ━━━━━━━━━━━━━━━━━━━━━━━━━━
    Warning: require_once(/home/users/2/lolipop.jp-4555107e4212fdd4/web/wp-content/plugins/db-cache-reloaded-fix/db-module.php): failed to open stream: No such file or directory in /home/users/2/lolipop.jp-4555107e4212fdd4/web/wp-content/db.php on line 94

    Fatal error: require_once(): Failed opening required ‘/home/users/2/lolipop.jp-4555107e4212fdd4/web/wp-content/plugins/db-cache-reloaded-fix/db-module.php’ (include_path=’.:/usr/local/php/7.3/lib/php’) in /home/users/2/lolipop.jp-4555107e4212fdd4/web/wp-content/db.php on line 94
    ━━━━━━━━━━━━━━━━━━━━━━━━━━

    上記エラーを確認する限りでは「db.php」にてエラーが発生しているようですが、復旧していません。

    ヘルプの必要なページ: [リンクを見るにはログイン]

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • こんにちは

    このプラグインは、プラグインのディレクトリを削除しただけではダメなようです。
    こちらの記事が参考になると思います

    5年以上に成るか、かなり前ですが、同じ症状で戸惑ったことがありましたので、回答しているトピックがあります。「db-cache-reloaded-fix」もプラグインで設定したことを解除してから無効化する必要があるでしょう。

    @fugaku

    下記のようなエラーが出て、ログイン画面も出なくなってしまいました。

    スレッド開始 choraku34

    (@choraku34)

    皆様、ありがとうございます。
    すべて試させていただいて、効果なしでした。
    キャッシュなども削除する施策をとったのですが、
    サイト自体も表示されなくなってしまいました。。

    そうなると、ちょっと分からないですね。データベースのデータの破損も考えられるので、バックアップから復元されるのがいいかと思います。その際は、PHP を元のバージョンに戻して動作するようにしてから、プラグインを正しい方法(マニュアルをご覧ください)でアンインストールされるといいかと思います。

    DB Cache Reloaded Fix プラグインは、PHP 7系にしますと必ずクラッシュします。
    修正は確かかなり苦労したと覚えておりますが、wp-content/内の生成されたcodeと、後何かを修正しないと駄目な筈で忘れまてしまったのですが、復旧は難しいかと思われます。

    スレッド開始 choraku34

    (@choraku34)

    そうですか…ありがとうございます。
    諦めるしかなさそうですね。。

    スレッド開始 choraku34

    (@choraku34)

    恥ずかしながら、バックアップを取りそびれていました。。
    サーバーもロリポップ的には戻せないという注意書きがあったのにアップグレードしてしまいました。
    動作確認をして、php7で動かないため、このサイトだけ5.3で運用していたのですが、時間が立ちすぎて忘れていました。。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。