サポート » インストール » phpのバージョンアップ後再度戻した際の不具合

  • 解決済 11wood11

    (@11wood11)


    初心者です。
    php5.2を7.3にして不具合があったため、5.2に戻してもらいました。
    その後下記のようなエラーが出ます。
    どのような解決方法がありますか?
    Warning: require_once(__DIR__/admin.php) [function.require-once]: failed to open stream: No such file or directory in /home/users/0/main.jp-〇〇〇/web/2012/wp-admin/index.php on line 10

    Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/admin.php’ (include_path=’.:/usr/local/php/5.2/lib/php’) in /home/users/0/main.jp-〇〇〇/web/2012/wp-admin/index.php on line 10

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • こんにちは

    WordPress 5.2 から PHP 5.6.20 以上が必須となりました。
    PHP 7.3 で動作しないのであれば、PHP 5.6.20 以上、7.3 未満で試されてみてはどうでしょうか。

    ありがとうございます。
    初心者で分からないことだらけで、すみません。

    このエラーが出たまま、変更可能でしょうか?
    ロリポップ使用中ですが、7.1以上しか選択できません。
    ちなみに、7.3にしたところ、固定ページの本文?の部分が表示されなくなりました。

    PHP のバージョンの変更方法はロリポップのマニュアルをご覧ください。
    https://lolipop.jp/manual/user/php-setting/

    一度元の状態に戻したいと思っていますが、しても大丈夫でしょうか?

    All-in-One WP MigrationというプラグインでPHP変更前にバックアップを取りましたが
    復元する方法が分かりません。

    一度元の状態に戻したいと思っていますが、しても大丈夫でしょうか?

    分かりません(どのような状態なのか分からないので絶対大丈夫とは言い切れません)

    復元する方法が分かりません。

    下記ページなどが参考になると思います。
    https://design-plus1.com/tcd-w/2019/07/all-in-one-wp-migration.html
    https://www.arakurenote.com/892.html

    ダッシュボードにも入れない状態で、
    Warning: require_once(__DIR__/admin.php) [function.require-once]: failed to open stream: No such file or directory in /home/users/0/main.jp-〇〇〇/web/2012/wp-admin/index.php on line 10

    Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/admin.php’ (include_path=’.:/usr/local/php/5.2/lib/php’) in /home/users/0/main.jp-〇〇〇/web/2012/wp-admin/index.php on line 10

    というエラーが出ている状態です。

    こちらのエラーも以前のレスと同じ理由です。

    PHP のバージョンを上げるか、WordPress バージョン 5.2 未満をインストールして復元するかになるかと思います。

    ※ もし、自信が無ければ専門の方や業者に依頼されたほうが後々のことを考えるといいのかなと・・・

    11wood11

    (@11wood11)

    専門の方に依頼してエラーの修正や最新の状態にして頂きました。
    丁寧に相談にのっていただき、ありがとうございました。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。