サポート » インストール » PHPの更新をするとwordpressにアクセスできない

  • 解決済 yoriyoku

    (@yoriyoku)


    wordpressのダッシュボードで

    「PHPの更新が必要です」

    と表示されました。

    PHPバージョンを
    PHP5.6(モジュール)→php73
    に変更しました。

    すると

    サイトで技術的な問題が発生しています。サイト管理者のメールを確認して指示に従ってください。

    という表示がブラウザーにでてしまいます。

    php72、PHP7.1(cgi)、PHP7.0(cgi)と同じような症状になります。
    PHP5.6(cgi)は大丈夫でした。

    PHP Compatibility Checkerを実行させてもプラグインなどに問題はないようです。

    使っているサーバーは、value-serverです。
    管理会社のvalue-domainに連絡したらwordpressの問題だと言われました。

    何が問題で、どう解決したらいいのでしょうか?

    ヘルプの必要なページ: [リンクを見るにはログイン]

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • @yoriyoku さん、はじめまして。

    デバッグモードを有効にしてエラーメッセージを確認してみてください。
    http://wpdocs.osdn.jp/WordPressでのデバッグ

    また、「問題解決のためのチェックリスト」トピックを一読ください。

    CG

    (@du-bist-der-lenz)

    テーマを確認すること、プラグインを確認すること。PHP5.6で動作するテーマ、プラグインに影響されていませんか。

    「問題解決のためのチェックリスト」にも書かれていますが、使用しているプラグインとテーマの情報(名称、入手先 URL、バージョン)等の情報をお知らせください。

    ishitakaさん
    CGさん
    ありがとうございます。
    解決しました。

    プラグインが怪しいのだということを教えていただいたので、全部停止して一つずつ有効にしていく作業をしたら原因がみつかりました。

    Facebook
    Add Facebook social plugins and the ability to publish new posts to a Facebook Timeline or Facebook Page. Official Facebook plugin.
    バージョン 1.5.5 | 作成者: Facebook
    が問題でした。

    CG

    (@du-bist-der-lenz)

    5年も更新なかったんですから、PHPをアップしたら動きませんよね。それだけ放っていたのだから、この機会に他も見直しましょう。

    問題は解決したということでよろしいのでしょうか?解決したらトピックのステータスを「解決済み」に変更しておいてくださいね。
    https://ja.wordpress.org/support/topic/質問ルール/

    はい。
    色々と教えていただきありがとうございました。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「PHPの更新をするとwordpressにアクセスできない」には新たに返信することはできません。